Results 1 to 10 of 10

Stuck In WOT??

This is a discussion on Stuck In WOT?? within the General Help forums, part of the LSx Technical Help Section category; Every once in a while, occuring more often as time goes on, my camaro seems to get stuck in WOT ...

  1. #1
    R.I.P. LS1 LS1Power06's Avatar
    Join Date
    Aug 2005
    Location
    817, Texas
    Age
    28
    Posts
    135
    03 Terminator

    Stuck In WOT??

    Every once in a while, occuring more often as time goes on, my camaro seems to get stuck in WOT after i get on it for a little bit. Ill haul ass for a bit, then let off and push in the clutch, but the RPMs stay up at 5K+ for a few seconds and then it slowly drops. What is causing this and how can i fix it? Thanks

    RyAn

  2. #2
    MEMBER 5150's Avatar
    Join Date
    Aug 2005
    Location
    Visalia Cali
    Age
    41
    Posts
    661

    SILVER
    2000 Z/28

    sticky throttle cable, maybe. try spraying some wd-40 inside the cable but first with the car off, unhook the cable from the tb if that moves freely it is more than likely the cable or possible something with the pedal itself.

  3. #3
    Got Rice? Liquifire's Avatar
    Join Date
    Aug 2005
    Location
    central wisconsin
    Age
    37
    Posts
    702
    I know it sounds foolish, but make sure that your floor mats are clear of the pedal @ WOT........

  4. #4
    Member Capster78's Avatar
    Join Date
    Dec 2005
    Location
    Newport News Va
    Age
    38
    Posts
    578

    Silver
    1998 WS6 M6

    Probably need to clean the MAF to.. just watch out for the sensor.. dont want to get that wet.

  5. #5
    Member jmhvenom's Avatar
    Join Date
    Oct 2005
    Location
    Cincinnati, OH
    Age
    31
    Posts
    821

    Silver
    2002 Z28

    Yea I cut the piece out of the top right of my floormat. It definatly hits it, and even was keeping it from going down all the way to the floor. But i would recommend something else for lubricant since WD40 is a penetrating oil..

  6. #6
    Blown, Stroked, & Sprayed

    Ed Blown Vert's Avatar
    Join Date
    Aug 1999
    Location
    San Diego, Ca
    Posts
    50,526

    Black
    383 Procharged & N20 Vert

    Quote Originally Posted by Liquifire
    I know it sounds foolish, but make sure that your floor mats are clear of the pedal @ WOT........

    I have seen this happen many times.
    Black 1999 Blown Convertible A4
    Forged 383, ATI D-1SC
    NX MAF Kit | 222/226 .585 115
    AS Stage II 6.0L FI Heads
    Moser 9" | 3.70 | Wavetrac | 35 Spline | Vigilante 3600
    548.0 RWHP - 563.8 RWTQ - 10# - D1

    666.0 RWHP - 734.2 RWTQ - 125 Shot - P1

    Black 2009 Escalade Hybrid 4WD
    Black 2008 GMC Yukon Hybrid 4WD (Totaled)

    Black 2013 Chevy Volt (Gone)

  7. #7
    R.I.P. LS1 LS1Power06's Avatar
    Join Date
    Aug 2005
    Location
    817, Texas
    Age
    28
    Posts
    135
    03 Terminator

    Quote Originally Posted by jmhvenom
    Yea I cut the piece out of the top right of my floormat. It definatly hits it, and even was keeping it from going down all the way to the floor. But i would recommend something else for lubricant since WD40 is a penetrating oil..
    well what would u recommend then? anyone else can chime in with what i should use if not WD-40. thanks

    RyAn

  8. #8
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    68
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    Quote Originally Posted by LS1Power06
    well what would u recommend then? anyone else can chime in with what i should use if not WD-40. thanks

    RyAn
    Kroil.

  9. #9
    Grand Imperial Wizard Sarge's Avatar
    Join Date
    Aug 2005
    Location
    Texas Department of Corrections
    Posts
    18,123
    Retired Outlaw Sum Bitch

    Probably a mechanical issue like everyone is saying...but a vacum leak can cause a WOT condition that slowly works its way back down also...just FYI...

  10. #10
    R.I.P. LS1 LS1Power06's Avatar
    Join Date
    Aug 2005
    Location
    817, Texas
    Age
    28
    Posts
    135
    03 Terminator

    alrite i will look into it further and maybe try some kroil. thanks for all the help!

    RyAn

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. wont shift at WOT HELP! after cam install
    By ahowell3 in forum Automatic Transmission
    Replies: 1
    Last Post: 01-28-2006, 05:47 PM
  2. RPM window switch, and WOT switch
    By corvettelover in forum Parts Wanted / Trade
    Replies: 1
    Last Post: 12-02-2005, 12:21 AM
  3. WOT switch
    By WS SICK in forum Nitrous
    Replies: 5
    Last Post: 11-04-2005, 05:24 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •