Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Steering wheel radio control light fix

This is a discussion on Steering wheel radio control light fix within the General Help forums, part of the LSx Technical Help Section category; Since I see this from time to time in here I thought I'd sticky the site that has the instructions ...

  1. #1
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    21,911

    98 Formula
    06 duramax

    Steering wheel radio control light fix

    Since I see this from time to time in here I thought I'd sticky the site that has the instructions on fixing this problem.

    Radio Controls light fix

  2. #2
    Junior Member
    Join Date
    Sep 2006
    Location
    Mountville , pa
    Age
    47
    Posts
    28

    white
    2000 camaro

    burned out

    thanks for the help on this . but i have more then one lamp in mine .

  3. #3
    Impwnded Smkn_TA's Avatar
    Join Date
    May 2007
    Location
    Davenport, Iowa
    Age
    26
    Posts
    1,977

    Bright Red
    1999 Trans Am Ws6

    Did not even know they were supposed to light up until I chanced upon this thread. Went to radio shak and they had to order the bulbs. Must not be an item they sell a lot of. One on the shelf looked like it had been there since edison invented it.

  4. #4
    Impwnded Smkn_TA's Avatar
    Join Date
    May 2007
    Location
    Davenport, Iowa
    Age
    26
    Posts
    1,977

    Bright Red
    1999 Trans Am Ws6

    Did this over the weekend last night...long story short, the wires are ridiculously short, got them out, no way to get them back in. I ended up pulling out the airbag, after that it was a cake job!

  5. #5
    Junior Member
    Join Date
    Sep 2006
    Location
    Mountville , pa
    Age
    47
    Posts
    28

    white
    2000 camaro

    glad it all worked out for ya . ya the wire is short !!

  6. #6
    Junior Member fbody01's Avatar
    Join Date
    Nov 2007
    Location
    orlando
    Age
    25
    Posts
    6

    black
    2001 Firebird

    Quote Originally Posted by Smkn_TA View Post
    Did not even know they were supposed to light up until I chanced upon this thread. Went to radio shak and they had to order the bulbs. Must not be an item they sell a lot of. One on the shelf looked like it had been there since edison invented it.
    i didnt either. does any one know if the power windows, mirrors and door locks on the door panel are supposed to light up too??
    2001 Pontiac Firebird
    3.8L V6
    5-spd

  7. #7
    Junior Member
    Join Date
    Sep 2006
    Location
    Mountville , pa
    Age
    47
    Posts
    28

    white
    2000 camaro

    on my 2000 camaro there is a little light that glows down on them
    hope this helps

    i need help on the abs break light thats on ? i put a new unit on the hub but it didn't change anything . even though thats what the chevy dealer told me .

  8. #8
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    21,911

    98 Formula
    06 duramax

    Quote Originally Posted by yodabill View Post
    on my 2000 camaro there is a little light that glows down on them
    hope this helps

    i need help on the abs break light thats on ? i put a new unit on the hub but it didn't change anything . even though thats what the chevy dealer told me .
    please start a new thread for this so the sticky doesn't get side tracked.

  9. #9
    Preferred Member CWW17's Avatar
    Join Date
    Apr 2006
    Location
    Central Illinois
    Age
    27
    Posts
    356

    Black | Black
    '07 Z06 | '98 WS6

    This fix did not help me. Then I tried replacing the whole control, Didn't work either. So it must be my wiring then? Anyone else have or solved this problem?

  10. #10
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    None of my lights works.. havent replaced them yet. All the fuzes are good. What could be the problem??

  11. #11
    Junior Member
    Join Date
    Sep 2006
    Location
    Mountville , pa
    Age
    47
    Posts
    28

    white
    2000 camaro

    you may just need new ones . i tryed the new bulb . but that was not the way to go in my case . so i just got a whole new one . it took me less then 15min to switch out the old to the new (the wire hook up is real short no joke ) that was the hardest part to the whole job. good luck
    bill

  12. #12
    Junior Member Raleigh TA's Avatar
    Join Date
    Jan 2006
    Location
    Raleigh, NC
    Posts
    73

    Blue on white
    1999 Trans Am

    Ground?

    Quote Originally Posted by JoshieDoom View Post
    None of my lights works.. havent replaced them yet. All the fuzes are good. What could be the problem??
    I have similar lighting issues, it has been suggested that I may have a ground issue. I have not attempted to trace it. My display on my Monsoon, my odometer, and trip meter, and sometimes a tail light are off most of the time.

  13. #13
    Member TopForm11's Avatar
    Join Date
    May 2007
    Location
    Chicago
    Posts
    107

    Black
    2002 Trans Am WS6

    Thanks...helped me

  14. #14
    Junior Member
    Join Date
    Sep 2006
    Location
    Indiana
    Age
    25
    Posts
    79

    Red
    94 Pont. Firebird Formula

    got any write ups for the lt1 controls? i am in need so i can turn my bulbs blue

  15. #15
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    21,911

    98 Formula
    06 duramax

    Quote Originally Posted by squeals99 View Post
    got any write ups for the lt1 controls? i am in need so i can turn my bulbs blue
    no, but I would assume they were very similar. Probably just have to switch to a blue led.

  16. #16
    Junior Member
    Join Date
    Nov 2006
    Location
    Corinth Mississippi
    Posts
    4

    Red
    2000 Camaro SS M6,3.42's

    Quote Originally Posted by Raleigh TA View Post
    I have similar lighting issues, it has been suggested that I may have a ground issue. I have not attempted to trace it. My display on my Monsoon, my odometer, and trip meter, and sometimes a tail light are off most of the time.
    Had a similar problem with my 2000 SS dash lights and monsoon display would not work. Checked and fuses were good. Replaced them with new ones anyway and now they work. Sweet!

  17. #17
    Junior Member
    Join Date
    Apr 2008
    Location
    San Diego
    Posts
    21

    Black
    1999 Trans Am

    Quote Originally Posted by Smkn_TA View Post
    Did this over the weekend last night...long story short, the wires are ridiculously short, got them out, no way to get them back in. I ended up pulling out the airbag, after that it was a cake job!
    I've had it out for weeks now since I couldn't get it back in with the ridiculously short wires. How can one remove the airbag without having it go off? I would really like to get the controls back in.

  18. #18
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,854

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    I usually use a hooked pic (the 1st one on the left in pic) to grab the connector and guide it into the switch.

  19. #19
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    66
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    Quote Originally Posted by Cutlass View Post
    I usually use a hooked pic (the 1st one on the left in pic) to grab the connector and guide it into the switch.
    I used a big paper clip bent to a similar shape

  20. #20
    Junior Member
    Join Date
    Apr 2008
    Location
    San Diego
    Posts
    21

    Black
    1999 Trans Am

    That is cool, thanks!! I guess once I guide it into place, then it will click into the clip as I push it into its space

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •