Results 1 to 9 of 9

Starter Install?

This is a discussion on Starter Install? within the General Help forums, part of the LSx Technical Help Section category; I am new to this site and am in need of some answers. I own a 99 Trans Am WS6 ...

  1. #1
    Junior Member
    Join Date
    Aug 2009
    Location
    Canada
    Age
    27
    Posts
    37

    Red
    1999 WS6

    Starter Install?

    I am new to this site and am in need of some answers.
    I own a 99 Trans Am WS6 and have recently ordered a starter through a mechanic i know. I got the Powermaster 9509 Which is supposed to fit on my LS1. I removed the old starter and wired up the new one. I went to bolt up the new starter but there was some sort of sensor blocking it. Does anyone know how to get around this sensor? Or what is it for? or any information would be much appretiated.

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    If I recall, that is most likely the oil level sensor on the side of the oil pan. No idea what to do about it other then utilize a stock replacement starter that fits. I looked up that starter at Summit's website and it does list it for your application.
    Last edited by pajeff02; 08-08-2009 at 03:27 PM. Reason: Looked up more info.

  3. #3
    Junior Member
    Join Date
    Aug 2009
    Location
    Canada
    Age
    27
    Posts
    37

    Red
    1999 WS6

    Thanks for your input thats what i was thinking i had to do. I also have one more question, probly a stupid one, my car with the old starter still installed will sometimes not start at all even after trying numberous times and sometimes it will start right up. could the key have anything to do with it because my security light is on when it is running?

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by Trans Am WS6 View Post
    Thanks for your input thats what i was thinking i had to do. I also have one more question, probly a stupid one, my car with the old starter still installed will sometimes not start at all even after trying numberous times and sometimes it will start right up. could the key have anything to do with it because my security light is on when it is running?

    Several possibilities, but I would check out the security system since that seems to have an issue. Never messed with ours, but it most likely includes a protection circuit to disable the starter. You can also search this forum to see if anyone has had a similar problem in the past.

  5. #5
    Junior Member
    Join Date
    Aug 2009
    Location
    Canada
    Age
    27
    Posts
    37

    Red
    1999 WS6

    Ok thanks for your help

  6. #6
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Quote Originally Posted by Trans Am WS6 View Post
    Ok thanks for your help

    That's what this site is all about.

  7. #7
    Member
    Join Date
    Aug 2005
    Location
    tx
    Age
    37
    Posts
    108

    pewter
    99 trans am ws6

    it could be that your key is going bad, just wear and tear. i had the same problem for a bit. the security light would turn on while driving. swapped keys and no more light.

  8. #8
    Junior Member
    Join Date
    Aug 2009
    Location
    Canada
    Age
    27
    Posts
    37

    Red
    1999 WS6

    I finally got my starter installed. I had to brake down and get a shop to do it for me. They got it to fit but i am still having the starting problem. The security system is acting up still so i will have to check on that.

  9. #9
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    read this thread
    VATS sticky

    that should fix you right up and take about 30 minutes to do and cost less than $5.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. For Sale: ls1 new starter
    By 98maro in forum Parts For Sale / Trade
    Replies: 2
    Last Post: 03-18-2011, 08:36 AM
  2. is my starter bad?
    By Zboner in forum External Engine
    Replies: 11
    Last Post: 07-08-2009, 05:07 AM
  3. Starter Going Bad.. HELP
    By LS1_WS6_TransAm in forum Firebird / WS6
    Replies: 2
    Last Post: 01-15-2007, 12:51 AM
  4. WTB LS1 starter
    By lowonair6173 in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 03-20-2006, 05:35 PM
  5. Link to S2000 push button starter install?
    By Beast in forum General Help
    Replies: 0
    Last Post: 08-27-2005, 01:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •