Results 1 to 5 of 5

SS Air Conditioning - Need Help

This is a discussion on SS Air Conditioning - Need Help within the General Help forums, part of the LSx Technical Help Section category; When I turn the air on in my '99 SS the clutch doesnt engage. I checked the fuse and it ...

  1. #1
    PCM Designer 99WickedSS's Avatar
    Join Date
    Feb 2011
    Location
    Clutier, IA
    Posts
    99

    Silver
    1999 Camaro SS

    SS Air Conditioning - Need Help

    When I turn the air on in my '99 SS the clutch doesnt engage. I checked the fuse and it looked ok. I put in a new relay and fuse since I had spares and it still didn't help.

    Is the AC controlled at all by the PCM? Just wondering if a tune could have disabled the AC or if this is just a problem with the AC motor or wiring.

    Anyone else ever have this issue? Any ideas?

  2. #2
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by 99WickedSS View Post
    When I turn the air on in my '99 SS the clutch doesnt engage. I checked the fuse and it looked ok. I put in a new relay and fuse since I had spares and it still didn't help.

    Is the AC controlled at all by the PCM? Just wondering if a tune could have disabled the AC or if this is just a problem with the AC motor or wiring.

    Anyone else ever have this issue? Any ideas?
    well the 1st thing I will check is to make sure that the clutch is getting 12v. Remove the plug out of the compressor and turn the A/C on. Put a voltmeter at the end of the plug and see of are getting 12v. If you are then the clutch is bad and needs to be replaced.

    have you checked how much refrigerant you got in the system? If it is low the pressure switch will not allow 12v to the compressor. That will be my next step to check if you dont have 12v at the compressor plug. Low freon or bad pressure switch.

  3. #3
    PCM Designer 99WickedSS's Avatar
    Join Date
    Feb 2011
    Location
    Clutier, IA
    Posts
    99

    Silver
    1999 Camaro SS

    Quote Originally Posted by JayTA98 View Post
    If it is low the pressure switch will not allow 12v to the compressor.
    I believe this is probably it. I talked to the original owner and he said they drained the AC when the heads were put on a few years back and they hadn't recharged the system so it's empty.

    I didn't know this but it makes sense since there is no freon in the system. I'll get a recharge and verify the system isn't leaking.

    Thanks!

  4. #4
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Make sure you have the air cranked when filling.

  5. #5
    ls1 powered seabee sutie's Avatar
    Join Date
    Mar 2007
    Location
    oxnard, ca.
    Age
    30
    Posts
    300

    red and black
    1999 Formula/WS6

    if you need a new one, let me know, ive got extra A/C parts

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Air conditioning not working
    By pdr-79 in forum General Help
    Replies: 9
    Last Post: 10-20-2015, 04:20 AM
  2. Help: Air Conditioning Took A Crap!
    By 90ARAPAJ in forum Firebird / WS6
    Replies: 2
    Last Post: 05-22-2012, 10:05 AM
  3. Blowing Air Conditioning Fuses
    By ls1camino in forum General Help
    Replies: 6
    Last Post: 07-29-2011, 06:15 PM
  4. Air Conditioning
    By 10spokess in forum General Help
    Replies: 5
    Last Post: 04-12-2011, 05:44 AM
  5. suburban air conditioning
    By Wayne Selzler in forum General Help
    Replies: 0
    Last Post: 01-02-2006, 07:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •