Page 1 of 2 12 LastLast
Results 1 to 20 of 22

Speedometer WAY off need some help!

This is a discussion on Speedometer WAY off need some help! within the General Help forums, part of the LSx Technical Help Section category; I've had my TA 2 days now and I'm trying to get stuff lined out on fixing the few issues ...

  1. #1
    Junior Member
    Join Date
    Jul 2007
    Location
    West Virginia
    Age
    31
    Posts
    64

    Satin Silver / RED
    02 Acura RSX/93 Transam

    Speedometer WAY off need some help!

    I've had my TA 2 days now and I'm trying to get stuff lined out on fixing the few issues it has. My primary concern is the speedo, it reads 31mph when I'm actually traveling about 70mph. The car has 4.11's in a moser 9". The previous owner was told it should be able to be programmed out, however my father, who owns a garage, feels that as far off as it is it must need a mechanical correction as well.

    Any ideas??

  2. #2
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Any tuner shop or handheld programmer will work. Not sure if the dealer could do it.

  3. #3
    Junior Member
    Join Date
    Jul 2007
    Location
    West Virginia
    Age
    31
    Posts
    64

    Satin Silver / RED
    02 Acura RSX/93 Transam

    I thought only the later model years with the OBDII could be flashed to fix the speedo.

  4. #4
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    I just noticed it was a 93. I am not sure if it is electrical or not.

  5. #5
    Senior Member mrr23's Avatar
    Join Date
    Jul 2005
    Location
    orlando, fl
    Posts
    7,134

    dark bowling green
    2000 corvette

    electric speedo. have to have the chip flashed. 1993 was the last year for remove able chips.

  6. #6
    Junior Member
    Join Date
    Jul 2007
    Location
    West Virginia
    Age
    31
    Posts
    64

    Satin Silver / RED
    02 Acura RSX/93 Transam

    Ok well I found out today the car was converted to OBDII so now it should be a simple plug in and reflash issue right?

  7. #7
    Bone it like you own it FORD RECOVERY EXPERT's Avatar
    Join Date
    Sep 2005
    Location
    TEXAS... U mad?
    Posts
    6,158

    Black / Stryker Blue
    2K WS.6/ 2K9 G8GT

    should be, any resolve to this yet??

  8. #8
    Junior Member
    Join Date
    Jul 2007
    Location
    West Virginia
    Age
    31
    Posts
    64

    Satin Silver / RED
    02 Acura RSX/93 Transam

    Well I'm not sure what all's going on. Went to plug up to it yesterday, and its an OBDI connector but has communication issues when 93 year is chosen, but works smoothly when 95 is chosen. This was just a diagnostics computer, no two way communication. No codes thrown though! So I don't think a 93 programmer is going to help. I'm going to let some of the techs at work take a look at it this weekend. (I sell cars at a GM dealership and get along pretty well with several of the techs.)

    Hopefully I'll know more Saturday.

  9. #9
    Junior Member
    Join Date
    Jul 2007
    Location
    West Virginia
    Age
    31
    Posts
    64

    Satin Silver / RED
    02 Acura RSX/93 Transam

    UPDATE:

    Never got the speedo fixed. I had a performance shop tell me I need a new gm speedo gear. GM service dept pulls up only one being available, so it must be whats already in the car. Had a tech suggest maybe its the vehicle speed sensor buffer?? Any other ideas? I'd buy a tuner and try to correct, but considering how off it is, I don't know if thats possible. If its reading 31, and I'm actually traveling 70, is a tuner going to fix that?

  10. #10
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    590

    Black
    2000 Camaro SS Conv.

    When the tuner plugs in, he will just select the gearing so it should be easy. Find a tuner in your area and let them fix it. Most have a low price for a simple speedo correction.

  11. #11
    That guy thearborbarber's Avatar
    Join Date
    Nov 2007
    Location
    SoDak
    Posts
    892

    White over Red
    1991 Suburban

    1993 is last year of the "mechanical" transmissions for the camera. You will need a new speedo gear to correct your speedometer. The PCM does not control any functions of the transmission. This page should have all the info you need;

    http://www.tciauto.com/Products/Tech...eedo_gears.asp

  12. #12
    Member qwk93ta's Avatar
    Join Date
    Oct 2006
    Location
    Fairfield, Ohio
    Age
    54
    Posts
    944

    Black
    00 WS6

    Quote Originally Posted by thearborbarber View Post
    1993 is last year of the "mechanical" transmissions for the camera. You will need a new speedo gear to correct your speedometer. The PCM does not control any functions of the transmission. This page should have all the info you need;

    http://www.tciauto.com/Products/Tech...eedo_gears.asp
    No he won't, I had the car converted to mass air....he just needs to have a speed shop change the tune for the gears in the 9".

  13. #13
    That guy thearborbarber's Avatar
    Join Date
    Nov 2007
    Location
    SoDak
    Posts
    892

    White over Red
    1991 Suburban

    Quote Originally Posted by qwk93ta View Post
    No he won't, I had the car converted to mass air....he just needs to have a speed shop change the tune for the gears in the 9".
    That is true for every year of 4th gen but 1993. It still had the 700r4 (AKA 4l60) not the electronic version 4L60E on the 94 and newer f bodies. The speedo was still mechanical and driven from a gear off the tranny. The tranny got its throttle position information via a TV cable (old school kick down cable) off the throttle body.

    http://en.wikipedia.org/wiki/Fourth-...evrolet_Camaro

    http://www.ls1lt1.com/forum/showthread.php?t=25245

    The easiest way to tell which transmission is there is to look on the side of the throttle body where the throttle cable attaches. If there is a second cable that traces back to the tranny then it's a 700r4, if there is only the throttle cable then it's a 4l60e.

  14. #14
    Junior Member
    Join Date
    Jul 2007
    Location
    West Virginia
    Age
    31
    Posts
    64

    Satin Silver / RED
    02 Acura RSX/93 Transam

    Every shop I've called is telling me that won't do it.

  15. #15
    Junior Member
    Join Date
    Jul 2007
    Location
    West Virginia
    Age
    31
    Posts
    64

    Satin Silver / RED
    02 Acura RSX/93 Transam

    Flashing it that is. If it would I should just be able to buy a handheld programmer and fix it, but cincy speed says its the speedo gear issue.

  16. #16
    Junior Member Snakes4's Avatar
    Join Date
    May 2008
    Location
    Goldsboro, NC
    Posts
    32

    Red
    96 TA WS6 with LS1/Trans

    Hey, just get your ECM reprogrammed for the 411 gears and any tire size ratio differences other than stock. You might as well do some other mods and then get it programmed so you only do it once.

  17. #17
    Member qwk93ta's Avatar
    Join Date
    Oct 2006
    Location
    Fairfield, Ohio
    Age
    54
    Posts
    944

    Black
    00 WS6

    Quote Originally Posted by thearborbarber View Post
    That is true for every year of 4th gen but 1993. It still had the 700r4 (AKA 4l60) not the electronic version 4L60E on the 94 and newer f bodies. The speedo was still mechanical and driven from a gear off the tranny. The tranny got its throttle position information via a TV cable (old school kick down cable) off the throttle body.

    http://en.wikipedia.org/wiki/Fourth-...evrolet_Camaro

    http://www.ls1lt1.com/forum/showthread.php?t=25245

    The easiest way to tell which transmission is there is to look on the side of the throttle body where the throttle cable attaches. If there is a second cable that traces back to the tranny then it's a 700r4, if there is only the throttle cable then it's a 4l60e.

    I replaced the 700r4 with a 4l60e and then had an M6 installed, and I had a 94 or 95 computer and harness put in the car.....so it's really not a 93 any longer.

  18. #18
    That guy thearborbarber's Avatar
    Join Date
    Nov 2007
    Location
    SoDak
    Posts
    892

    White over Red
    1991 Suburban

    Quote Originally Posted by qwk93ta View Post
    I replaced the 700r4 with a 4l60e and then had an M6 installed, and I had a 94 or 95 computer and harness put in the car.....so it's really not a 93 any longer.
    That would have been some useful info from the get go.

  19. #19
    Member qwk93ta's Avatar
    Join Date
    Oct 2006
    Location
    Fairfield, Ohio
    Age
    54
    Posts
    944

    Black
    00 WS6

    Quote Originally Posted by thearborbarber View Post
    That would have been some useful info from the get go.


    The new owner knows all about it.

  20. #20
    Member mild2wild's Avatar
    Join Date
    Apr 2009
    Location
    E of Rochester NY
    Age
    48
    Posts
    116

    Orange/Black
    1999 Camaro SS

    Just curious, did you get these issues worked out yet??
    I'm a CHICK with a gun and an LS1, nuff said...


    1999 CAMARO SS #81 of 4829
    LS6 intake * 3.73's * Borla catback * L/T Headers
    ZO6 18's * MSD/NGK * SLP Lid/Bellows * KYB Adjustables
    Summit Racing Springs * Fresh paint/interior in 08

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Improving Pontiac Speedometer Accuracy - Speedometer Super-T
    By Ed Blown Vert in forum Firebird / WS6
    Replies: 0
    Last Post: 02-27-2012, 10:10 PM
  2. speedometer off
    By wvbrett in forum Firebird / WS6
    Replies: 5
    Last Post: 06-06-2011, 10:30 AM
  3. 110 MPH speedometer on Z28
    By Dave-TransAm in forum Camaro / SS
    Replies: 13
    Last Post: 03-24-2010, 08:39 PM
  4. Speedometer
    By Dave-TransAm in forum Firebird / WS6
    Replies: 2
    Last Post: 03-12-2010, 10:53 PM
  5. speedometer help
    By shortbed454 in forum Stereo and Electronics
    Replies: 0
    Last Post: 01-13-2006, 11:25 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •