Results 1 to 6 of 6

Speedo inop

This is a discussion on Speedo inop within the General Help forums, part of the LSx Technical Help Section category; stupid speedo quit working and i dont know why? is it a fuse? sensor? where do i look? help!!!...

  1. #1
    Member
    Join Date
    Nov 2005
    Location
    allenhurst GA
    Age
    41
    Posts
    369

    onyx black
    1999 formula firebird

    Speedo inop

    stupid speedo quit working and i dont know why? is it a fuse? sensor? where do i look? help!!!

  2. #2
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    well check your fuses first. is your car an auto or manual? if it is an auto is it having trouble shifting?

  3. #3
    Member
    Join Date
    Nov 2005
    Location
    allenhurst GA
    Age
    41
    Posts
    369

    onyx black
    1999 formula firebird

    M6 car no troubles shifting..just got a stage 2 T56 from tick performance and a complete RAM VDS clutch pkg too & Z06 slave

  4. #4
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    okay the reason i ask for the auto is the pcm relies on your vss to know when to upshift. if you just had that stuff done your vss connector could very well come loose or somethin. crawl up under there and check

  5. #5
    Member
    Join Date
    Nov 2005
    Location
    allenhurst GA
    Age
    41
    Posts
    369

    onyx black
    1999 formula firebird

    my ses light came on and i had it scanned at autozone * free* and it came back as a sensor that plugs into my tranny the vehicle speed sensor..friggin sensor is $55 but how do i tell if the other one is actually bad and i dont have a bad wire? i will buy the sensor ifi have to...and where the hell is it at on the transmission?

  6. #6
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    i dont know exactly but most likely on the tailshaft. that is what i was saying was going out or unplugged. vss=vehicle speed senor...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Speedo inop
    By 99 Formula in forum Stereo and Electronics
    Replies: 3
    Last Post: 09-07-2008, 06:08 PM
  2. ABS and TCS Inop.
    By V8MUSCLE in forum Drivetrain
    Replies: 1
    Last Post: 12-01-2007, 07:37 PM
  3. abs inop?
    By 440 rwhp trans am in forum General Help
    Replies: 9
    Last Post: 08-16-2007, 01:49 PM
  4. Abs Inop ?
    By redwhiteandnew in forum Firebird / WS6
    Replies: 5
    Last Post: 08-14-2007, 04:57 PM
  5. Abs Inop / Tcs Off
    By 79Firebird_99TA in forum General Help
    Replies: 4
    Last Post: 06-26-2007, 11:09 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •