Results 1 to 10 of 10

So my car's electrical blew up today.........

This is a discussion on So my car's electrical blew up today......... within the General Help forums, part of the LSx Technical Help Section category; I don't know what happened here. I don't think I've ssen anything like it. I have an 02 T/A with ...

  1. #1
    Junior Member
    Join Date
    Feb 2007
    Location
    Moon
    Posts
    6

    So my car's electrical blew up today.........

    I don't know what happened here. I don't think I've ssen anything like it. I have an 02 T/A with 14K on it and it sits. Don't drive it and it sits. To keep the battery charged I use a solar charger directly to the battery posts and untill. If that maters, I don't know? I started it up today to move it two feet and it ran for about 3 minutes. I went to move it forward and it was like lighting hit it. Went like boom and everything just powered down. Like that robot when Smith pulls his power pack in Lost in Space.

    Now I get nothing...no power at all. It's totally dead. Nothing lights dings or cranks. No power locks. No alarm....nothing. Dead.

    This migh sound silly but is there some kind of a main fuse in a car?
    Last edited by RRU; 11-24-2010 at 02:36 PM.

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    If it went boom that bad you should be able to see where it smoked. Any possibility the starter harness contacted the exhaust? Batteries do occasionally go poof, is the case distorted? Alternator harness? Battery cables? Lots to look at -- definitely start by disconnecting the ground from the battery before you go playing with things.

  3. #3
    Junior Member
    Join Date
    Feb 2007
    Location
    Moon
    Posts
    6
    Quote Originally Posted by pajeff02 View Post
    If it went boom that bad you should be able to see where it smoked. Any possibility the starter harness contacted the exhaust? Batteries do occasionally go poof, is the case distorted? Alternator harness? Battery cables? Lots to look at -- definitely start by disconnecting the ground from the battery before you go playing with things.
    No smoke no smell nothing looks crazy. It's outside and it's raining 30 dregrees in Chicago. Strange the batery seems fine. The green eye even looks up at me. That's why I was thinking fuse.

    I've had strange stuff happen with GM electical before but this is confounding.

    I'll have to go put a meter on battery and see what it says.

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    If the battery tests good then start with the cables. Not a bad idea to wear eye protection, just in case.

  5. #5
    Member
    Join Date
    Aug 2005
    Location
    Tulsa,OK
    Age
    37
    Posts
    914

    Quick Silver
    2002 Z06

    That is VERY strange. If your solar charger does not have a voltage regulator/ charge controller then it could possibly have been over charging the battery to the point it cooked it. I have seen a battery be dead with the green eye still glowing before.

    Let us know what you find out, I'm sure we can help figure it out!


    Slow Passenger Window - Want Passenger Express Down - Tired of Replacing DayTime Running Light Bulbs

    Camaro Owners Click Here
    Firebird Owners Click Here

    Need instructions to replace your F-Body window motor?
    www.AutoTrix.net

  6. #6
    Junior Member
    Join Date
    Feb 2007
    Location
    Moon
    Posts
    6
    I went an put a voltmeter on it and it came up with 12V but there's no way to tell the amps. This time the alarm light was flickering when I opened the door. Maybe it's just the battery?........... Is costco open on Thanksgiving?

  7. #7
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    The last time I heard a "BOOM", it was a battery for a Dodge Ram Cummins. Was a few years ago. Coworker connected a battery tester to the battery and..."BOOM!!!!!"

  8. #8
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    590

    Black
    2000 Camaro SS Conv.

    Most of the electrical issues are either connections or the battery. First step is to remove both cables, thoroughly clean the terminals, and have the battery tested or conet it back up and see what you have after cleaning the terminals.

  9. #9
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    I'd carefully take the battery up to and autoparts store that testes them for free.

    Then I'd do what Jeff recommended and inspect all of the major wires.

    If you can't find the any problems with any of them, take the alternator off and get it tested as well.



    All-in-all, I think your solar power charger might be to blame for this. The only reason I think I might not be is because it didn't happen right away. I think that is it had over charged the battery, it wuld have wetn pop right as is got overcharged, before you even started it. Or even when you first put a load on the battery, not 3 minutes later. Sounds like something in the charging went bad though.

  10. #10
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    I agree with the theories regarding the solar charger. May have caused a voltage spike as well if your car's security light is flashing.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: My engine just blew....... Wtf!!!!!
    By Eganslp in forum Camaro / SS
    Replies: 26
    Last Post: 08-30-2011, 12:13 PM
  2. speakers blew
    By transamgirl89 in forum Stereo and Electronics
    Replies: 7
    Last Post: 06-16-2011, 08:32 PM
  3. I just blew 100 bucks almost
    By JoshieDoom in forum Almost Anything Goes
    Replies: 41
    Last Post: 06-06-2008, 11:52 PM
  4. My car blew up
    By 86 IROC-Z in forum Almost Anything Goes
    Replies: 39
    Last Post: 04-14-2008, 06:32 PM
  5. QTP Electric cut out BLEW UP today
    By wesTXwitesnake05 in forum External Engine
    Replies: 3
    Last Post: 08-29-2006, 02:36 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •