Page 1 of 4 1234 LastLast
Results 1 to 20 of 68

so im getting 8-9 mpg...

This is a discussion on so im getting 8-9 mpg... within the General Help forums, part of the LSx Technical Help Section category; any idea wat can be happening. i dont think ive ever had gas mileage that bad....

  1. #1
    Member slpdablueZ28's Avatar
    Join Date
    Sep 2008
    Location
    brooklyn
    Posts
    403

    blue
    2002 Camaro Z28

    so im getting 8-9 mpg...

    any idea wat can be happening. i dont think ive ever had gas mileage that bad.
    2002 z28-slp cai, slp loudmouth, slp tuned headers, slp 85 mm MAF, slp high flow cats, 3" y-pipe and collectors
    331.6 rwhp/356.9 rwtq

  2. #2
    Member Justin93's Avatar
    Join Date
    Oct 2007
    Location
    CANFIELD, OHIO
    Age
    31
    Posts
    654

    PEWETER METALIC
    2002 CAMARO Z-28 M-6

    Quote Originally Posted by slpdablueZ28 View Post
    any idea wat can be happening. i dont think ive ever had gas mileage that bad.
    Holly crap thats horrible, What kind of tune does it have, I have heads, cam, and intake and still get 21mpg and thats getting on it every once and a while.
    Is your car an auto or six speed?

    Whens the last time its had a good fuel filter, plugs, and wires

  3. #3
    Member slpdablueZ28's Avatar
    Join Date
    Sep 2008
    Location
    brooklyn
    Posts
    403

    blue
    2002 Camaro Z28

    its an auto. it used to be doing fine. but since i got back home its been shitty. i think i might have an exhaust leak would that affect gas mileage? or is it just the nyc driving thats doing it?

  4. #4
    Member Justin93's Avatar
    Join Date
    Oct 2007
    Location
    CANFIELD, OHIO
    Age
    31
    Posts
    654

    PEWETER METALIC
    2002 CAMARO Z-28 M-6

    Quote Originally Posted by slpdablueZ28 View Post
    its an auto. it used to be doing fine. but since i got back home its been shitty. i think i might have an exhaust leak would that affect gas mileage? or is it just the nyc driving thats doing it?
    Honestly alot of city driving will kick an autos ass as far as mileage goes, with that said however 8-9mpg is way off. My buddies 01 ss auto gets about 17 in the city with similar mods to yours. Also when my car was stock way back when lol I went from getting 32mpg highway and 19 city to 22 highway 15 city due to the front O2 sensors going bad. I replaced them and was right back to normal.
    Last edited by Justin93; 03-07-2009 at 02:10 PM.

  5. #5
    Member slpdablueZ28's Avatar
    Join Date
    Sep 2008
    Location
    brooklyn
    Posts
    403

    blue
    2002 Camaro Z28

    i normally used to get around 15 in the city. this is a big drop in mileage for me

  6. #6
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    why do you have that maf? Is the car tuned for that "special" maf? You still have both front and rear 02's? Cat? Any codes? Codes turned off? Plugs? Fuel filter?

  7. #7
    Member slpdablueZ28's Avatar
    Join Date
    Sep 2008
    Location
    brooklyn
    Posts
    403

    blue
    2002 Camaro Z28

    Quote Originally Posted by Hi-Po View Post
    why do you have that maf? Is the car tuned for that "special" maf? You still have both front and rear 02's? Cat? Any codes? Codes turned off? Plugs? Fuel filter?
    bought it a while back cause i thought it would help. last thing i did to the car was have it tuned and its been running good. on the highway ive been getting around 25 mpg. still have all the o2s and cats. theres no codes popping up. spark plugs i changed about a year and a half ago. fuel filter i never touched

  8. #8
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,998

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Does it seem to be running rich? can you smell it? I assume you still have all 4 gears and torque converter clutch working. Maybe someone is siphoning gas from you?

  9. #9
    James Bond Spikito's Avatar
    Join Date
    Aug 2007
    Location
    Texas
    Age
    30
    Posts
    4,546

    2001 3.8 Black - sold
    2000 SS Black M6

    remove some of the lead from your foot?

    Ive always noticed my gas mileage goes to shit a tank or two before something breaks

  10. #10
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    69
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    Fuel leak somewhere???

  11. #11
    Member slpdablueZ28's Avatar
    Join Date
    Sep 2008
    Location
    brooklyn
    Posts
    403

    blue
    2002 Camaro Z28

    Quote Originally Posted by Cutlass View Post
    Does it seem to be running rich? can you smell it? I assume you still have all 4 gears and torque converter clutch working. Maybe someone is siphoning gas from you?
    its all working fine but by the time it shifts to second i already have to be slowing down most of the time

  12. #12
    Member slpdablueZ28's Avatar
    Join Date
    Sep 2008
    Location
    brooklyn
    Posts
    403

    blue
    2002 Camaro Z28

    Quote Originally Posted by Spikito View Post
    remove some of the lead from your foot?

    Ive always noticed my gas mileage goes to shit a tank or two before something breaks
    i havent been driving any more aggressively than before

  13. #13
    Member slpdablueZ28's Avatar
    Join Date
    Sep 2008
    Location
    brooklyn
    Posts
    403

    blue
    2002 Camaro Z28

    Quote Originally Posted by rbob93 View Post
    Fuel leak somewhere???
    havent seen any puddles around the car, havent smelt anything either

  14. #14
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    my first guess is fuel filter if it has never been done, next would be the O2s, one or both front ones could have drifted out of calibration but not set a code. Could also try putting the stock MAF back in and seeing what happens?

    Also get a scanner and see if it entering closed loop? What is your water temp doing?

  15. #15
    Moderator Firebirdjones's Avatar
    Join Date
    May 2006
    Location
    Arizona
    Posts
    12,552
    Quote Originally Posted by slpdablueZ28 View Post
    any idea wat can be happening. i dont think ive ever had gas mileage that bad.
    Damn,,,my 638hp 454 chevelle with 4.10 gears and no overdrive does better than that

    You sure there isn't a huge leak somewhere before it reaches the motor??? Is your math correct??

    In all seriousness you definately have something going on. Even if it never reaches closed loop for whatever reason I still can't see 8 mpg,,,sheeeesh

    You definately need to get a scanner on that thing and go for a drive to see whats going on. You've got some very slow switching 02's or an MAF thats so dirty it's not metering fuel properly,,,,but still,,,8 mpg????

  16. #16
    Member slpdablueZ28's Avatar
    Join Date
    Sep 2008
    Location
    brooklyn
    Posts
    403

    blue
    2002 Camaro Z28

    Quote Originally Posted by Orcus79 View Post
    my first guess is fuel filter if it has never been done, next would be the O2s, one or both front ones could have drifted out of calibration but not set a code. Could also try putting the stock MAF back in and seeing what happens?

    Also get a scanner and see if it entering closed loop? What is your water temp doing?
    i figured at first it might have been just the cold weather that was making it burn a lot of gas. i used to have lean codes thrown by the o2s until i got my tune. i dont think i have the stock maf anymore and this maf never gave me a problem with anything. i got a diablo programmer ill try to see if itll read anything. but i think i have an exhaust leak would that do anything?

  17. #17
    Member slpdablueZ28's Avatar
    Join Date
    Sep 2008
    Location
    brooklyn
    Posts
    403

    blue
    2002 Camaro Z28

    Quote Originally Posted by Firebirdjones View Post
    Damn,,,my 638hp 454 chevelle with 4.10 gears and no overdrive does better than that

    You sure there isn't a huge leak somewhere before it reaches the motor??? Is your math correct??

    In all seriousness you definately have something going on. Even if it never reaches closed loop for whatever reason I still can't see 8 mpg,,,sheeeesh

    You definately need to get a scanner on that thing and go for a drive to see whats going on. You've got some very slow switching 02's or an MAF thats so dirty it's not metering fuel properly,,,,but still,,,8 mpg????
    i always put $20 into the tank which is almost 10 gallons on the dot. i do somewhere between 80 and 90 miles before i have to put in another 20

  18. #18
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    depends on where it is? but, it could possibly cause it if it were near the cats or O2s.

  19. #19
    Member slpdablueZ28's Avatar
    Join Date
    Sep 2008
    Location
    brooklyn
    Posts
    403

    blue
    2002 Camaro Z28

    Quote Originally Posted by Orcus79 View Post
    depends on where it is? but, it could possibly cause it if it were near the cats or O2s.
    thats where i think it might be coming from. i think it might be just infront of one of my cats

  20. #20
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    69
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    Fuel thief hitting your tank??

Page 1 of 4 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •