Page 2 of 2 FirstFirst 12
Results 21 to 23 of 23

Sluggish

This is a discussion on Sluggish within the General Help forums, part of the LSx Technical Help Section category; did you figure it out? What was it?...

  1. #21
    down with the lot lizards blackhawk01's Avatar
    Join Date
    Dec 2006
    Location
    Pensacola
    Age
    28
    Posts
    1,565

    Red
    2001 Camaro SS A4

    did you figure it out? What was it?

  2. #22
    www.eautocad.com
    Join Date
    Oct 2007
    Location
    FL
    Posts
    257

    Silver
    1998 Camaro Z28

    he says he doesn't have trac control--- now does he not have the button? Or did he change his rear-end and loose the trac control? If you have stock rear end and no button, I'd say you have trac control w/ no option to turn it off.. I think thats how GM did it,, could be wrong,, someone care to fill in the blanks?

  3. #23
    Member 02sscamaro's Avatar
    Join Date
    Mar 2007
    Location
    long island,n.y
    Posts
    112
    that happen to me in my m6 it was the cats gone bad and no codes.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 98 z is sluggish
    By phil85 in forum General Help
    Replies: 21
    Last Post: 04-12-2011, 11:54 PM
  2. Sluggish in low rpms
    By Rhinohuey in forum General Help
    Replies: 12
    Last Post: 03-15-2009, 03:11 PM
  3. Sluggish acceleration?
    By onetroubledguy in forum General Help
    Replies: 23
    Last Post: 03-10-2009, 05:33 PM
  4. Sluggish LS1, WHY!!!!
    By Chicago TDP in forum General Help
    Replies: 12
    Last Post: 08-20-2007, 08:29 AM
  5. Idle problems, car seems very sluggish
    By sills1 in forum General Help
    Replies: 4
    Last Post: 01-14-2007, 12:34 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •