Results 1 to 14 of 14

Slp maf installation

This is a discussion on Slp maf installation within the General Help forums, part of the LSx Technical Help Section category; I recently Installed a Volant CAI in my 2000 TA WS6. I tried attaching an slp MAF sensor that i ...

  1. #1
    Junior Member
    Join Date
    May 2009
    Location
    New York
    Posts
    4

    Question Slp maf installation

    I recently Installed a Volant CAI in my 2000 TA WS6. I tried attaching an slp MAF sensor that i bought and replace the stock one. I successfully installed it and when i start the car now it Idles around 4-500rpm and stutters and stalls sometimes but when driving its fine ans u can feel the Hp difference. Can anyone help to tell me why this does this or how to fix it? Thanx

  2. #2
    Knight of Chaos xzaero0's Avatar
    Join Date
    May 2007
    Location
    Nebraska
    Age
    37
    Posts
    468

    Black
    2000 Trans Am

    90% of the online community will tell you to LEAVE THE STOCK MAF alone! Its more than good enough for most street cars.

    Most will also tell you to stay away from SLP stuff too... just to give you a heads up.

  3. #3
    Member c5z28's Avatar
    Join Date
    Apr 2008
    Location
    Bay Area
    Posts
    8,120

    On your ass flashing
    my highbeams

    what the above said, you can tune for the slp maf but there are better mods to spend money on. If you want more in depth I can post a link.

  4. #4
    Bullet Boy Same ol Situation's Avatar
    Join Date
    Dec 2008
    Location
    Cincinnati, Ohio
    Posts
    156
    2002 CETA m6

    i was considering a slp MAF, but i feel like you would have to get a tune to get the most out of it.


    and i just dont have the dough stacks for that mayne

  5. #5
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Quote Originally Posted by Liguy26 View Post
    but when driving its fine ans u can feel the Hp difference
    How does one feel 2RWHP?


    Your computer is now trying to adjust for that stupid aftermarket MAF and the fact you are running lean. Sounds like it is adding fuel to try to make up for it.
    That is how those MAF's make any power....they lean you out. Sometimes enough for detonation to occur.
    Stocker is good for 500RWHP and more in many cases. If possible, return that MAF and get a good modification for your car.
    2008 Trailblazer SS
    Yank PTB3600, Kooks 1 7/8" LT's, 4" intake, E-fans, Magnaflow, Sonnax kit, tranny cooler, tune.
    Lowered, HID's, tinted.

    1999 Pontiac Trans Am WS.6 #1747 SOLD
    531.1 RWHP 481.3 FT/Pounds all motor.

  6. #6
    Junior Member
    Join Date
    May 2009
    Location
    New York
    Posts
    4
    Thanks for the info guys I will try and return it to the ws6store.

  7. #7
    Junior Member
    Join Date
    Jun 2008
    Location
    Butler mo
    Posts
    76

    Blue
    98 Trans Am

    this will make u guys sick, i put a hypertech tuner and a slp maf and a new air lid on and at first it stalled a little but after the computer got it figured out the car runs very strong.

  8. #8
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Quote Originally Posted by heath26 View Post
    this will make u guys sick, i put a hypertech tuner and a slp maf and a new air lid on and at first it stalled a little but after the computer got it figured out the car runs very strong.
    And very lean.
    Probably so much it pulls timing....but unless you plug in a good scanner you won't be able to tell.

  9. #9
    Knight of Chaos xzaero0's Avatar
    Join Date
    May 2007
    Location
    Nebraska
    Age
    37
    Posts
    468

    Black
    2000 Trans Am

    Research is the key... research possible problems with the parts you are going to purchase and look at part reviews of the same part, if your plans dont involve XXX then dont buy a part that you wont need if you are never going to get to where you have to have it. It will save you alot of money and headache along the way.

    Just clean your stock MAF and put it back on, and hope you can get your money back.

  10. #10
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Quote Originally Posted by heath26 View Post
    this will make u guys sick, i put a hypertech tuner and a slp maf and a new air lid on and at first it stalled a little but after the computer got it figured out the car runs very strong.
    I bet you get hooked up to a "real" scanner/editor and you will be sick looking at your AFR numbers with that joke of a MAF.

  11. #11
    Member DaddySS's Avatar
    Join Date
    Oct 2005
    Location
    Bergen Co. NJ
    Posts
    590

    Black
    2000 Camaro SS Conv.

    Some people see results from MAFs, many don't. I agree they are not a good value unless you have major power adder mods like heads and a big cam.

    I don't agree that you should stay away from SLP stuff, they make some good parts - and like evrryone else they have some questionable items too.

    If the WS6 store will not let you return it you might try doing the idle relearn, I believe the procedure is:
    Reset PCM:
    1)turn on key but do not start car 2)pull PCM BAT and PCM IGN fuses in engine compartment 3)wait a few minutes 4)turn ignition off 5)replace fuses.

    Then start the car - do not touch the gas or brake and let it idle for 10 minutes. Shut it off, and wait 15 seconds.

  12. #12
    Senior Member karpetcm's Avatar
    Join Date
    Oct 2008
    Location
    Tujunga, CA
    Posts
    1,646

    White
    01 Camaro 6speed

    They should make a sticky on leaving your MAF alone and staying away from SLP products. Well maybe the lid is OK but other then that i would leave the stock MAF alone. Its not worth the extra 2hp if that to change it out. Even if i got one for free i would never install it since its very hard to get it tuned right with a aftermarket MAF and there is nothing wrong with the stock one, its plenty good for what most of us pull. One thing people dont understand is and i hear this from time to time, wow my car is much better runs stronger after i put on my aftermarket MAF, well maybe your stock one was dirty or damaged beyond cleaning it and that will without a doubt cause your car to lose power and not run properly.

    I had a dirty maf on my 01 SS a few years back and didnt know why my car was low on power, eventually the car would hardly idle and would die out on me so it gradually got bad from losing some power to not being able to drive. I was told by many to change the MAF to a aftermarket one and after cleaning my stock one the car was running just like the first day i bought it.

  13. #13
    Junior Member
    Join Date
    May 2009
    Location
    New York
    Posts
    4
    Actually on a follow up I decided to try to hook it up one more time before trying to return the MAF and I bolted ip up started the car and It worked perfectly it doesnt idle rough at all in fact its idling at around 900-1000 rpms constantly even after sitting and driving for a while. i think maybe the computer adjusted to the more air flow. Any ideas or and I just lucky?

  14. #14
    Stockitie Stock Stock 95camaroZNC's Avatar
    Join Date
    Jun 2008
    Location
    Raleigh NC
    Age
    30
    Posts
    897

    Red
    1999 Trans Am

    Their not saying it idling right is bad, their saying that the running lean that the part is causing is bad.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. PAC SWI-PS installation
    By cascade in forum Stereo and Electronics
    Replies: 3
    Last Post: 08-03-2011, 06:41 PM
  2. Frc Installation
    By kebie05 in forum Appearance Section
    Replies: 22
    Last Post: 06-16-2009, 08:31 AM
  3. HELP! MAC ORY installation.
    By JoshieDoom in forum External Engine
    Replies: 2
    Last Post: 08-14-2008, 10:44 PM
  4. installation??
    By food nd cars in forum Internal Engine
    Replies: 1
    Last Post: 07-23-2006, 06:33 PM
  5. Lt1 Cam Installation
    By 96lt1z28 in forum LT1
    Replies: 2
    Last Post: 07-05-2006, 06:29 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •