Page 1 of 2 12 LastLast
Results 1 to 20 of 22

SLP lid problems!

This is a discussion on SLP lid problems! within the General Help forums, part of the LSx Technical Help Section category; so i bought a new slp lid and smooth bellows and im slightly disappointed. let me say that both products ...

  1. #1
    Member Zedtwentyeight's Avatar
    Join Date
    Aug 2008
    Location
    Syracuse, NY
    Posts
    127

    White
    2002 WS6

    SLP lid problems!

    so i bought a new slp lid and smooth bellows and im slightly disappointed. let me say that both products are great, but together, i cant get them to work right. The fit is horrible. if i check the lid after driving for a bit the left latch is always undone. Am i doing something wrong or is this a common problem?

    The performance gains are great by the way. i do not regret this purchase i just wonder about fit. help me cause i'm a little stressed out by this!

  2. #2
    Just me Y2KPewterSS's Avatar
    Join Date
    Nov 2006
    Location
    Broken Arrow, OK
    Age
    42
    Posts
    23,353

    Pewter metallic
    2000 Camaro SS

    Take a razor blade and trim the bellows. I had to trim mine this way. After trimming some of the bellows off, it will fit much better.
    CCW SP 500s 18x10 275/35 18x11 295/35
    SLP CME with GMMG style catback
    Painted manta stripe

    Quote Originally Posted by konigandy6 View Post
    I'd rather be bi than full homo!!!!

  3. #3
    Member Bouvers's Avatar
    Join Date
    May 2006
    Location
    Canada
    Age
    31
    Posts
    857

    Blue 1997 Trans Am(Sold)
    Pewter 2001 Trans Am Vert

    second that... had to do the same... might even have to take even more off. One thing I noticed with my bellow you have to tilt your maf slightly of centered, otherwise the slots won't line up. if you try tilting your bellow it will throw off the angle and will force one side of the lid out more then the other...

    hope that helps...

  4. #4
    Senior Member 1MileCrash's Avatar
    Join Date
    Mar 2007
    Location
    Wisconsin Rapids, WI
    Posts
    2,851

    Black
    1999 Z/28 M6

    oh man i thought i was alone in this thing...granted i don't have the smooth bellows but my left clip has a tendency to pop off with the stock bellows.

  5. #5
    Member Bouvers's Avatar
    Join Date
    May 2006
    Location
    Canada
    Age
    31
    Posts
    857

    Blue 1997 Trans Am(Sold)
    Pewter 2001 Trans Am Vert

    what I find strange is my clips have never come undone... however the back tabs barely sit into the holes and thereby allows my lid to sit up and lose contact on the back portion ... extreme annoyance... thats the price we pay for getting SLP... I doubt I'll ever buy another product from them again...

  6. #6
    Junior Member
    Join Date
    Aug 2008
    Location
    nj
    Posts
    23

    pewter
    2001 ws6

    me too,that why I just the MTI clear lid.hope will fit better.

  7. #7
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    69
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    Common problem is the user doesn't have the lid installed so the front edge fits inside the lower lip. Clips will pop off if not installed correctly.

  8. #8
    Sold: LS1 '85 El Camino ls1camino's Avatar
    Join Date
    Dec 2005
    Location
    Laurel, Maryland
    Posts
    4,977

    2000 Grand Prix GTP
    2000 Trans Am WS6 M6

    Quote Originally Posted by gofast View Post
    me too,that why I just the MTI clear lid.hope will fit better.
    Whisper Lid...I love mine

  9. #9
    Junior Member
    Join Date
    Aug 2008
    Location
    Somewhere down in Texas
    Posts
    66

    Black
    1998 Z28 M6

    Does anyone else make a smooth bellow other than SLP? After everything I have read recently I don't think I want to spend my money on one. Has anyone tried making their own?

  10. #10
    Member Bouvers's Avatar
    Join Date
    May 2006
    Location
    Canada
    Age
    31
    Posts
    857

    Blue 1997 Trans Am(Sold)
    Pewter 2001 Trans Am Vert

    well I can vouche for that I have never made the mistake of placing the front lip improperly, and thus have never had the clip pop off however I think some lids will still have this problem whether or not the lip is improperly installed.

  11. #11
    Member Bouvers's Avatar
    Join Date
    May 2006
    Location
    Canada
    Age
    31
    Posts
    857

    Blue 1997 Trans Am(Sold)
    Pewter 2001 Trans Am Vert

    Quote Originally Posted by LS1nterceptor View Post
    Does anyone else make a smooth bellow other than SLP? After everything I have read recently I don't think I want to spend my money on one. Has anyone tried making their own?
    well I tried finding something that would work at various hose and rubber places and could find anything that I thought would work properly .... the main problem with the SLP smooth bellow is its far to thick and stiff... the shape and overall form of it is actually very good but the stiffness doesn't allow for individiuality and margins for correction.

  12. #12
    Junior Member
    Join Date
    Aug 2008
    Location
    Somewhere down in Texas
    Posts
    66

    Black
    1998 Z28 M6

    I was thinking of trying some of the blue silicone hose that are used on superchargers and cold air kits and maybe a piece of PVC or something between them.

  13. #13
    Junior Member
    Join Date
    Sep 2008
    Location
    ks
    Posts
    1

    NBM
    99 Trans AM

    Quote Originally Posted by 1MileCrash View Post
    oh man i thought i was alone in this thing...granted i don't have the smooth bellows but my left clip has a tendency to pop off with the stock bellows.

    Same here, after trimming the bellows several times it still did it. Went to the dealership and bought a replacement and moved on.

    Wondering if it would work better with stiffer motor mounts? Since it seemed that the lid would pop open after revving the engine.

  14. #14
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    you can go to bakerprecision and do a search for "camaro". They sell a "baker hose" that's basically just a silicone hose that fits up there and you trim it to fit. The last time I was at the site I think it was ~$30 which is quite a bit more than I gave for mine many years ago when I bought one but it's another option to look at.

  15. #15
    Member jamessr's Avatar
    Join Date
    Jan 2007
    Location
    Newport News, VA
    Posts
    266

    White
    2000 Trans AM

    I know this may sound ghetto, but if you take the time to do it correctly it will look nice. I don't have any advice on the bellow, but the lid yes. Where latch sits on the plastic part, make a small indention with a razor knife. If you rush it it will look like crap. However a small slit will give the latch something to bite down into. I haven't had any issues since.

  16. #16
    Pony Killer Insert's Avatar
    Join Date
    Apr 2008
    Location
    Mississauga, Ontario, Canada
    Age
    29
    Posts
    242

    Black
    2002 Camaro SS M6

    i hate my SLP lid because the top rubs on the inside of the hood. so no matter how much i clean it and how many coats of clearcoat get put on there is that one small spot that rubs and gets dirty... very annoying.

  17. #17
    Speak the truth jad628's Avatar
    Join Date
    Apr 2006
    Location
    Charlotte, NC
    Age
    52
    Posts
    2,307

    Hugger Orange/W stripes
    1999 Z28 M6

    Quote Originally Posted by Insert View Post
    i hate my SLP lid because the top rubs on the inside of the hood. so no matter how much i clean it and how many coats of clearcoat get put on there is that one small spot that rubs and gets dirty... very annoying.
    I've been thinking about installing a small piece (4" x 4" or so) of felt right where the hood touches the lid.

    Anybody tried that yet?

  18. #18
    Member Bouvers's Avatar
    Join Date
    May 2006
    Location
    Canada
    Age
    31
    Posts
    857

    Blue 1997 Trans Am(Sold)
    Pewter 2001 Trans Am Vert

    thats a camaro trait your hoods sit just a tiny bit lower then us WS6 guys. what I've seen some Camaro do is they get a small clear sticker put on the hood where it rubs... saves the paint and minimizes the effects on the lid...I bet you could get a another sticker for your lid with a clear sticker over top that if you don't mind the look of a k&n sticker on your lid... just an idea...

  19. #19
    Member fxgs's Avatar
    Join Date
    Mar 2007
    Location
    Camp Hill, Pa
    Posts
    719

    Onyx Black
    2002 SLP Camaro SS

    Quote Originally Posted by jad628 View Post
    I've been thinking about installing a small piece (4" x 4" or so) of felt right where the hood touches the lid.

    Anybody tried that yet?
    Yep............a long time ago................since my car is black I put a small piece of black felt on the underside of the hood where the lid would touch......works like a charm. (p.s. but after I trimed the aftermarket bellows.......no problems)

  20. #20
    Speak the truth jad628's Avatar
    Join Date
    Apr 2006
    Location
    Charlotte, NC
    Age
    52
    Posts
    2,307

    Hugger Orange/W stripes
    1999 Z28 M6

    Quote Originally Posted by fxgs View Post
    Yep............a long time ago................since my car is black I put a small piece of black felt on the underside of the hood where the lid would touch......works like a charm. (p.s. but after I trimed the aftermarket bellows.......no problems)

    Cool beans. I'll do it too then!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 97 LT1 problems
    By james78657 in forum LT1
    Replies: 18
    Last Post: 01-20-2012, 10:30 AM
  2. Help: 62.9i problems
    By trooperrunner in forum Stereo and Electronics
    Replies: 1
    Last Post: 08-12-2009, 04:08 PM
  3. problems with my 66 g.t.o. (help)
    By 05gtoautoX in forum GTO
    Replies: 6
    Last Post: 07-11-2006, 04:49 AM
  4. Site problems or my problems?
    By oneBADDz in forum Request and Feedback
    Replies: 2
    Last Post: 04-03-2006, 07:26 PM
  5. A/C problems.
    By gnomee in forum General Help
    Replies: 2
    Last Post: 03-14-2006, 07:13 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •