Page 1 of 2 12 LastLast
Results 1 to 20 of 22

SLP Cold Air Package problem??

This is a discussion on SLP Cold Air Package problem?? within the General Help forums, part of the LSx Technical Help Section category; Has anyone had any problems with the Cold Air Package from SLP. If the pictures are attached you can see ...

  1. #1
    TNT
    Guest

    SLP Cold Air Package problem??

    Has anyone had any problems with the Cold Air Package from SLP. If the pictures are attached you can see that the front retainer clips pull down hard on the lid and when I close the hood they frequently pop off. I figured it was the lid and possibly that it didn't come out of the mold properly but after looking at the pictures perhaps the problem is the base.

    I contacted LMPerformance and they first thought I was missing the extra filter gasket but with that in the problem is worse. LMP next suggested that I trim the bellows so that it is not pushing forward on the lid but I test fit it without the bellows and it has the same problem. The lid just does not fit on the base.

    Has anyone else had this problem?

  2. #2
    Member Capster78's Avatar
    Join Date
    Dec 2005
    Location
    Newport News Va
    Age
    38
    Posts
    578

    Silver
    1998 WS6 M6

    Is it just me or is the problem that the lid seems to narrow and wont fit over the sides of the box? Iv never seen that before. Id have them send you another lid and see if you have the same problem.. Or just find someone with that same lid on their car and take it off and test fit it to your car.

  3. #3
    TNT
    Guest
    I think it is the lid. It looks like I will have to buy a new one before I can figure it out. I hate to spend the money on another lid to find out that the problem is the base.

  4. #4
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    68
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    Your problem is that you haven't pushed the lid far back enough.

    The front edge of the lid should be INSIDE the base slightly.
    From what I can see in your pic is that it is on the outside.

  5. #5
    TNT
    Guest
    I asked LMPerformance to send me a lid to test fit prior to trimming the bellows like they suggested and their response flat surprised me. LMPerformance said they sent the pictures to SLP and SLP said it is one of the best fits they have seen. They finished by saying that I needed to add the K&N extra gasket to complete it.

    All that after I explained to them that with the gasket in the front retainers won't stay closed.

  6. #6
    member
    Join Date
    Aug 2005
    Location
    Clifton Hts.,Pa.
    Age
    60
    Posts
    62

    Black
    2001 Camaro SS

    TNT=I agree with rbob93.It seems you don't have the lid back enough.But you should never have to trim anything or add an extra gasket.Don't blame LMPerformance or call them,call SLP direct.They will usually try and kiss ur butt to get it right.

  7. #7
    TNT
    Guest
    Yeah I tried it without the bellows behind it so I could push it back further but then the retaining clips won't close and when I force them closed they pop off when I close the hood. If I add the gasket like they suggest it makes the problem worse.

    I don't blame LMP for the problem but responding with trim the bellows then responding with SLP thinks it looks great is probably not a good idea. Why not just say use some 200 MPH tape on it and call it good. You only paid $250+ for it what do you expect.

    I'm going to mess with it more this weekend and see what happens. Any other suggestions are appreciated. I'm starting to like the tape idea at least I won't have to search for the retainer clips everytime I open the hood.

  8. #8
    Member
    Join Date
    Jan 2006
    Location
    houston
    Posts
    205

    Navy Blue
    ls1 trans am

    Mine fits on the inside.. liek the above said try to push it back... see if in the back the four groves are not hitting and not allowing it to go any further back. It seems your trying to fit the lid on the outside but I think its suppose to tuck in not fit over the base.

  9. #9
    I went to Playboy Mansion FantaZGuy28's Avatar
    Join Date
    Sep 2005
    Location
    Bakersfield/Long Beach Ca
    Age
    30
    Posts
    888

    YJ
    04 GTO M6

    Really force the lid back as far as you can with the 2 pieces of the lid into the slots where they go then put the locks in place. Mine was cake when I put it on.

  10. #10
    02 ws6 timmyvws6's Avatar
    Join Date
    Dec 2005
    Location
    Grandville MI.
    Age
    59
    Posts
    32

    Black
    2002 Transam ws6

    Got it. I am looking at the lid instructions right now. #13: FIT FRONT LIP ON WHISPER AIR LID INTO EXISTING HOUSING. What it should say is Fit front Lip into existing housing between the two hold down clamps. The Whisper lid that I have sits flush on both sides of the housing. I pushed the front lip between the clamps into the housing. The clamps now hold tight and will not open on there own. For sale: One roll of High performance black duck tape.
    Last edited by timmyvws6; 02-02-2006 at 12:49 PM.

  11. #11
    Shorty
    Guest
    Sounds like big hamma time to achieve Harley specs.

  12. #12
    TNT
    Guest
    Quote Originally Posted by Shorty
    Sounds like big hamma time to achieve Harley specs.
    Just drove it into the back wall of the garage after a spectacular burnout .... Fits great now, thanks LMP!!!!!!!!!!!!!!!!

    I'm gonna buy that tape to seal the coolant leaks and hold my airbags in

  13. #13
    Shorty
    Guest
    Quote Originally Posted by TNT
    Just drove it into the back wall of the garage after a spectacular burnout .... Fits great now, thanks LMP!!!!!!!!!!!!!!!!
    Not exactly the best way for home improvement.
    Did she love you long time? When you make Gunny?

  14. #14
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    Like everyone is saying...the front lip goes inside not outside the lower assembly. I have the same lid and bellow...brb gonna take a pic.

    EDIT: ok here's some pics....look at your pics and then look at least.










    Last edited by SeVeReDiStOrTiOn; 02-05-2006 at 07:26 PM.

  15. #15
    Senior Member clg82's Avatar
    Join Date
    Feb 2007
    Location
    California
    Age
    33
    Posts
    2,453
    2000 Trans Am

    Quote Originally Posted by TNT View Post
    Has anyone had any problems with the Cold Air Package from SLP. If the pictures are attached you can see that the front retainer clips pull down hard on the lid and when I close the hood they frequently pop off. I figured it was the lid and possibly that it didn't come out of the mold properly but after looking at the pictures perhaps the problem is the base.

    I contacted LMPerformance and they first thought I was missing the extra filter gasket but with that in the problem is worse. LMP next suggested that I trim the bellows so that it is not pushing forward on the lid but I test fit it without the bellows and it has the same problem. The lid just does not fit on the base.

    Has anyone else had this problem?
    I had this exact same problem!!!! I called slp direct and they said that some ta's and camaros had their motor mounts installed too far forward...so they suggested that i cut my bellows and i did and now mine fits fine.....the only problem i do have is that one of the clips doesn't stay fastened!!!........

  16. #16
    no more 4th gen secondgearscratch's Avatar
    Join Date
    Jun 2006
    Location
    St. Louis, Missouri
    Age
    28
    Posts
    2,463

    Pewter
    2000 z28

    you just need to make sure the bellows is on the throttle body all the way and then work forward. in all honesty i think the fitment of these lids suck and its difficult to get them just right. be patient.

  17. #17
    Senior Member clg82's Avatar
    Join Date
    Feb 2007
    Location
    California
    Age
    33
    Posts
    2,453
    2000 Trans Am

    Has anyone else had the problem of having the hose too long with the attachment and orig. tube that came off of the old air box......mine is really long....and almost touches the belts.........to you think i could trim that back a little bit......?

  18. #18
    no more 4th gen secondgearscratch's Avatar
    Join Date
    Jun 2006
    Location
    St. Louis, Missouri
    Age
    28
    Posts
    2,463

    Pewter
    2000 z28

    Quote Originally Posted by clg82 View Post
    Has anyone else had the problem of having the hose too long with the attachment and orig. tube that came off of the old air box......mine is really long....and almost touches the belts.........to you think i could trim that back a little bit......?
    yes., its just a hose. trim it so it wont hit the belts and give yourself peace of mind.

  19. #19
    Senior Member clg82's Avatar
    Join Date
    Feb 2007
    Location
    California
    Age
    33
    Posts
    2,453
    2000 Trans Am

    thanks for the help

  20. #20
    pimp spookyz28's Avatar
    Join Date
    Mar 2007
    Location
    Long Beach Ca
    Age
    34
    Posts
    122

    White
    2000 Camaro Z28

    Just get rid of that piece of crap air lid and go with the K&N 57 Series FIPK. That is the best set up and has the highest HP rating.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cat back is next....What brand?
    By timmyvws6 in forum External Engine
    Replies: 27
    Last Post: 01-06-2006, 12:09 PM
  2. Ram air with cold induction?
    By GottaHaveLS1 in forum General Help
    Replies: 2
    Last Post: 12-05-2005, 10:52 AM
  3. SLP Cold air induction package
    By RAWPWR3 in forum External Engine
    Replies: 8
    Last Post: 11-23-2005, 08:03 AM
  4. Ram air with cold air induction?
    By GottaHaveLS1 in forum External Engine
    Replies: 1
    Last Post: 11-05-2005, 04:53 PM
  5. SLP cold air kit
    By wolfdogg40 in forum External Engine
    Replies: 1
    Last Post: 10-11-2005, 05:39 AM

Members who have read this thread: 0

There are no members to list at the moment.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •