Results 1 to 4 of 4

slow acceleration

This is a discussion on slow acceleration within the General Help forums, part of the LSx Technical Help Section category; Today when driving my car I felt like it was having a hard time accelerating. I felt like their was ...

  1. #1
    Junior Member degenerate's Avatar
    Join Date
    Dec 2005
    Age
    32
    Posts
    50

    Silver
    98 WS6

    slow acceleration

    Today when driving my car I felt like it was having a hard time accelerating. I felt like their was more vibrations coming through the peddles and what seemed like in my seat than normal. The rpms seemed to struggle to go up rather than the usual steady climb. Any suggestions on where to begin looking into this?

  2. #2
    Member ErikElvis's Avatar
    Join Date
    Feb 2006
    Location
    north east
    Age
    36
    Posts
    185

    sunset orange
    02 SS M6

    How many miles on your car? May need a basic tune up. My car felt a little rough when I bought it and I added fuel system cleaner which didnt help. I tried again with the more expensive slick 50 kind and I sware its smoother. My car had 25000 on it when i bought it.

  3. #3
    Member jmhvenom's Avatar
    Join Date
    Oct 2005
    Location
    Cincinnati, OH
    Age
    31
    Posts
    821

    Silver
    2002 Z28

    slow acceleration? You just need more power lol jk Vibrations... I would check out all your tires, maybe even bent a rim or something, alignment, tons of things could go wrong in the suspension. Might even be a tranny thing.

  4. #4
    Junior Member degenerate's Avatar
    Join Date
    Dec 2005
    Age
    32
    Posts
    50

    Silver
    98 WS6

    Quote Originally Posted by jmhvenom View Post
    slow acceleration? You just need more power lol jk
    That most likely is part of the problem. With every new thing I do, I never feel like I'm going fast enough still.

    But the vibration feels like its coming from the chassis/suspension. I'm still driving the car around and testing it here and there to try to figure it out. I've had a few good accelerations, but I'm thinking when it is poor acceleration, its a lack of traction. The power just isn't getting to the ground it feels like in those instances.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •