Results 1 to 4 of 4

SES code PO103 (MAF)???

This is a discussion on SES code PO103 (MAF)??? within the General Help forums, part of the LSx Technical Help Section category; My car has been surging a bit in the last few months and I have noticed a drop off in ...

  1. #1
    Member Stricken1's Avatar
    Join Date
    Sep 2006
    Location
    Florida
    Posts
    248

    Black
    2001 Trans Am WS6

    SES code PO103 (MAF)???

    My car has been surging a bit in the last few months and I have noticed a drop off in power. I didnt have an engine light come on but I did but an OBD2 scanner on it today and it came up with MAF code something about low circuit voltage?

    My question is....Do I now need to replace the MAF or is it another problem? I use a Zex dry system (100 shot) and am afraid the MAF is gonna cause me to go lean and BAM! Where should I begin with this? If I need to replace it what should I get? My understanding is replace it with a factory one??? Or since I am spraying should I go another direction?

  2. #2
    Member Tman's Avatar
    Join Date
    Aug 2005
    Location
    Woodstock, GA
    Posts
    469

    Black
    2000 WS6

    You can try to first clean the MAF itself and see if that clears the problem.

  3. #3
    Member
    Join Date
    Aug 2005
    Location
    Tulsa,OK
    Age
    37
    Posts
    914

    Quick Silver
    2002 Z06

    I had a similar issue recently and cleaning the MAF fixed the problem.


    Slow Passenger Window - Want Passenger Express Down - Tired of Replacing DayTime Running Light Bulbs

    Camaro Owners Click Here
    Firebird Owners Click Here

    Need instructions to replace your F-Body window motor?
    www.AutoTrix.net

  4. #4
    Member Stricken1's Avatar
    Join Date
    Sep 2006
    Location
    Florida
    Posts
    248

    Black
    2001 Trans Am WS6

    Okay I will give it a shot thanks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: po 716 code on my gtp
    By SteveCZ28 in forum V6
    Replies: 3
    Last Post: 03-15-2012, 02:25 PM
  2. another code
    By ledesma54 in forum GTO
    Replies: 6
    Last Post: 07-21-2008, 08:13 PM
  3. Tuner won't tune car cause of Po103 ?
    By 9t8z28 in forum Forced Induction
    Replies: 7
    Last Post: 06-16-2008, 07:03 PM
  4. ses code
    By guy in forum General Help
    Replies: 5
    Last Post: 01-03-2008, 06:00 PM
  5. O2 code
    By silverz28camaro in forum General Help
    Replies: 5
    Last Post: 01-12-2007, 06:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •