Results 1 to 10 of 10

service vehicle light

This is a discussion on service vehicle light within the General Help forums, part of the LSx Technical Help Section category; hey all....I was driving my T/A this afternoon and the service vehicle light came on for just a few seconds ...

  1. #1
    Junior Member
    Join Date
    Aug 2005
    Location
    Georgia
    Age
    35
    Posts
    14

    Silver
    1999 Pontiac Trans am

    service vehicle light

    hey all....I was driving my T/A this afternoon and the service vehicle light came on for just a few seconds and then went off... I turned my car off as soon as I could once the light had come on and off, since then I havent seen it come back on...what could have caused this and whats the difference in the service vehicle vs ses light? also my ses light has been coming on and going off more rapidly lately...I was correct in assuming that it was my idle postition sensor, but it also threw a code of running lean on both banks...anyone know what could correct this....also, the reason that I thought the idle postition was weird cuz when I have the A/C running it makes the idle run at 1500-2000 rpm for a few seconds before it comes back to regular idle running speeds....any thought on how to correct that too...thanks

    Chris

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Ok as far as your service vehicle light, Car thinks its time too change oil, turn the car off, then turn too ign, but dont start, tap gas pedal too the floor three times, then let off and turn too off. Should reset your light.
    PUll out your iac control valve and clean it up, make sure not too damage the tip or adjust it.
    Its on the side of your intake right behind your maf housing.
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Member ADAM-00SS's Avatar
    Join Date
    Aug 2006
    Location
    Ohio
    Posts
    139

    Pewter
    2000 SS

    Every 3000 Miles A Light That Says Oil Change Will Light Up, Not Sevrice Vehicle. My Car Is Throwing The Same Lean At Both Banks Code. Could Be A Dirty Maf Or Could Be A Vaccum Leak Some Where

  4. #4
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Umm, Yea I can speak for an 01 and my service vehicle comes on there bud, and its for the oil change.
    J

  5. #5
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    I've seen posts for service vehicle light coming on for 3rd brake light out, cruise control out, etc. If it's staying off don't worry about it - probably a BCM code.

  6. #6
    Member ADAM-00SS's Avatar
    Join Date
    Aug 2006
    Location
    Ohio
    Posts
    139

    Pewter
    2000 SS

    If You Don't Have A Light That Says Oil Change That's Fine. Keep Speaking For Your 01 Instead Of Trying To Help Doggles13.

    Doggles13--its Normal For The Motor To Rev Up When You Click On The A/c. The Motor Has To Work Harder To Run The Compressor. Why Do You Think Your Car Feels Like A Sled When You Have The A/c On.

  7. #7
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Hey dude just calm down ok, were all here too help each other and not get into a childish bs session.
    Sorry too all for gettin off topic
    J

  8. #8
    Senior Member ss~zoso~ss's Avatar
    Join Date
    Dec 2004
    Location
    )
    Posts
    9,128

    SS: NBM, tan top
    1998-SS, 2010 Jetta TDI

    Quote Originally Posted by ADAM-00SS View Post
    If You Don't Have A Light That Says Oil Change That's Fine. Keep Speaking For Your 01 Instead Of Trying To Help Doggles13.

    Doggles13--its Normal For The Motor To Rev Up When You Click On The A/c. The Motor Has To Work Harder To Run The Compressor. Why Do You Think Your Car Feels Like A Sled When You Have The A/c On.
    you should change your attitude on this site, our tolerence for arrogance keeps going down

  9. #9
    Senior Member ss~zoso~ss's Avatar
    Join Date
    Dec 2004
    Location
    )
    Posts
    9,128

    SS: NBM, tan top
    1998-SS, 2010 Jetta TDI

    and eventually you might get one of these ( )

  10. #10
    Junior Member
    Join Date
    Aug 2005
    Location
    Georgia
    Age
    35
    Posts
    14

    Silver
    1999 Pontiac Trans am

    Thanks for the help...I checked the Idle Sensor and it was caked with carbon so I carefully cleaned all that off and reinstalled it. then I took the throttle intake off and cleaned all that plus the MAF. i checked a few of the hoses and sure enough I did have a vacuum leak on one of the hoses...I dont know what its called though but I could sure use a new one...after I did all that the car ran much smoother and all lights have been off and stayed off...thanks for all the help everyone

    Chris

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •