Results 1 to 5 of 5

"service ride control"

This is a discussion on "service ride control" within the General Help forums, part of the LSx Technical Help Section category; 1997 C5. AT Started car this afternoon and noticed several warnings. ABS light on continuously Traction control lit conrtinously Message ...

  1. #1
    Junior Member
    Join Date
    May 2006
    Location
    New York
    Posts
    5

    Black
    1997 Corvette

    "service ride control"

    1997 C5. AT

    Started car this afternoon and noticed several warnings.
    ABS light on continuously
    Traction control lit conrtinously
    Message display shows:
    Service ride control
    Shocks inoperative
    Maximum speed 80mph

    Anyone had this problem before and what is my fix!
    TIA
    Steve

  2. #2
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    Not an expert on the Vettes but I think your BCM may have quite, or you have a wheel speed sensor that craped out. There should be codes in the computer that will lead you in teh right direction.

  3. #3
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    I am leaning toward the BCM as well. Sounds like the system went into some sort of default mode activating the T/C, deactivating the programmable suspension and activated your overspeed programming. Like a failsafe mode.

  4. #4
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    1st step = get the codes read.
    The BCM isn't used for the suspension stuff. There is a separate ESC (Electronic Suspension Control) module.
    There are 4 suspension height sensors (one at each corner) and all 4 shocks have solenoids in them. The problem will most likely be one of those 8 things.

  5. #5
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    One of EIGHT things. HOLY S$%!!!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: "Service Engine Soon light" Got a P0430 code
    By gymrat11 in forum Camaro / SS
    Replies: 8
    Last Post: 01-09-2014, 08:42 AM
  2. Ohio "Greets" Bloomberg's Gun Control Bus Tour (pics)
    By wileyCoyote in forum Gun's & Ammo
    Replies: 3
    Last Post: 08-30-2013, 07:51 PM
  3. Anyone use "Straight Talk" phone service?
    By BrntWS6 in forum Almost Anything Goes
    Replies: 4
    Last Post: 05-06-2011, 06:53 AM
  4. Blinking "Service Engine Soon Light"??
    By Tampa T/A in forum Firebird / WS6
    Replies: 13
    Last Post: 02-13-2011, 04:23 AM
  5. This 1969 Nova SS is the Bosch "Ultimate Ride" Winner
    By Ed Blown Vert in forum Almost Anything Goes
    Replies: 0
    Last Post: 04-28-2007, 03:01 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •