Results 1 to 5 of 5

service engine light on

This is a discussion on service engine light on within the General Help forums, part of the LSx Technical Help Section category; my light just popped on at 45,000 mi.... i just put a k & n air filter in it.. i ...

  1. #1
    wolfman1265
    Guest

    service engine light on

    my light just popped on at 45,000 mi.... i just put a k & n air filter in it.. i checked the gas cap... could the k&n do that.. when i put it in there was a seal that was hook on the lid that connected to the maf i think.. it was hanging down so i pulled it out. it wasnt a rubber seal, but more of a sticky, squishy seal... just wondering if that would turn it on.. oh ya, i did this a week to a week and a half before the light came on.

  2. #2
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Probably nothing you did since the light didn't come on for over a week - I'd get the code read and post it up.

  3. #3
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    go to a local autozone and ask to use their scanner

  4. #4
    BlackHawk T/A
    Guest
    O'Reileys didn't let me use theirs because they said they've had problems with people running off with them...

    Motherf....

    Anyway the guy was nice and came out with me.

  5. #5
    Building My Ride
    Join Date
    Oct 2005
    Location
    Philadelphia
    Posts
    13

    Black/Black
    2000 TransAm WS6

    You really need to have the code checked, but it is likely an IAT error code indicating you have an air flow/mixture problem. About that seal you pulled - you should check around the area and see if anything is blowing or sucking air. You might need to put that seal back...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Some insight into the 3.4L OHV Motor...
    By Black34v6 in forum V6
    Replies: 115
    Last Post: 12-31-2015, 05:51 AM
  2. Check Engine Light has come on.
    By Jim_s in forum Camaro / SS
    Replies: 6
    Last Post: 11-11-2005, 01:00 PM
  3. Engine light
    By 01ssls1 in forum General Help
    Replies: 5
    Last Post: 09-26-2005, 11:21 AM
  4. Hate check engine light
    By white-Z in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 08-22-2005, 03:35 PM

Members who have read this thread: 0

There are no members to list at the moment.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •