Results 1 to 14 of 14

serious oil leak problem!

This is a discussion on serious oil leak problem! within the General Help forums, part of the LSx Technical Help Section category; the car is 1997 LT1 formula AUTO ok l parked my car for 2 days in the garage and todya ...

  1. #1
    Senior Member Musclefan21's Avatar
    Join Date
    Apr 2006
    Location
    IL
    Posts
    1,155

    1997 Formula & 2003 cobra

    serious oil leak problem!

    the car is 1997 LT1 formula AUTO

    ok l parked my car for 2 days in the garage and todya l pulled her back to wash but l saw a huge oil LAKE on the floor.. l got under the car and l saw it is coming BETWEEN TRANSMISSION and ENGINE OIL PAN (RIGHT ABOVE THE STARTER I GUESS) and l saw some antifreeze mixxed up with the oil too. also my power steering is getting real hard sometimes ( something is wrong with it it too) l dont know if it is related.. I CHECKED THE OIL, LEVEL LOOKS OK BUT THE OIL IS KINDA BLACK.. WTF?!?!?

    so what is it? and how can it be fixed? and how much would that cost?

    l have an oil leak from front of the engine but that is small and not a big deal.. it has been like that and not a problem..

    please help, this is the only car l have!

    thank you all..

    Erdal

  2. #2
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Leaking between the bellhousing and the block is normally the rear main seal.
    Oil is supposed to be black after it has been used. That is a good thing.

    Are you sure water was in the oil?? Or that it could not have been added by weather?? Rain or something??
    2008 Trailblazer SS
    Yank PTB3600, Kooks 1 7/8" LT's, 4" intake, E-fans, Magnaflow, Sonnax kit, tranny cooler, tune.
    Lowered, HID's, tinted.

    1999 Pontiac Trans Am WS.6 #1747 SOLD
    531.1 RWHP 481.3 FT/Pounds all motor.

  3. #3
    Senior Member Musclefan21's Avatar
    Join Date
    Apr 2006
    Location
    IL
    Posts
    1,155

    1997 Formula & 2003 cobra
    Quote Originally Posted by Mr. Luos View Post

    Are you sure water was in the oil?? Or that it could not have been added by weather?? Rain or something??
    l am sure the big leak ( between oil pan and transmission) has not antifreeze in.. just oil.. but l looked at the fron of the engine and on a couple hoses l saw small antifreeze about to drip. and l rev the engine a couple of times after cleaning under the engine and l saw my exhaust pipes sprayed some water.. it wasnt GREEN it was water and l tried to smell and it didnt smell at all..

    he car was fine in atlanta, l have no idea what happened now..

    also those leak areas are dangerous?

  4. #4
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Well you obviously need to make sure you keep a close eye on your oil level until you can get the rear leak fixed.

    As long as the coolant is leaking from a different place than the oil and they are just mixing on the floor...you are lucky in that respect.

    Sounds like a possible cracked hose for the coolant.
    Guessing rear main seal for the rear oil leak.

    Not sure about the front one.

  5. #5
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    WAIT!!

    Exhaust pipes sprayed water???

  6. #6
    Senior Member Musclefan21's Avatar
    Join Date
    Apr 2006
    Location
    IL
    Posts
    1,155

    1997 Formula & 2003 cobra
    Quote Originally Posted by Mr. Luos View Post
    WAIT!!

    Exhaust pipes sprayed water???
    yes, l revved the engine and then l looked at the back of the car, right under the pipes, l had water on the ground..l touched it and it was water color and tried to smell and didnt smell nothing. (BTW, l have multiple missifre, maybe it is related)

  7. #7
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Was the air conditioner running??

  8. #8
    Senior Member Musclefan21's Avatar
    Join Date
    Apr 2006
    Location
    IL
    Posts
    1,155

    1997 Formula & 2003 cobra
    Quote Originally Posted by Mr. Luos View Post
    Was the air conditioner running??

    no my A/C do not work so it is off all the time..

  9. #9
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Oh...out the back of the car??

    Don't worry about that too much.
    Is there any coolant leaking up front?

  10. #10
    Senior Member Musclefan21's Avatar
    Join Date
    Apr 2006
    Location
    IL
    Posts
    1,155

    1997 Formula & 2003 cobra
    Quote Originally Posted by Mr. Luos View Post
    Oh...out the back of the car??

    Don't worry about that too much.
    Is there any coolant leaking up front?
    oh. this made me to take a deep breath.

    no, l dont have coolant leak,, l cant see it on the floor.. water pump is new, radiator is new..

    also l need to mention this too, sometimes when my car is on DRIVE and whenever l am stopped, l hear noise coming under the car.. like something rolling and there is a piece hitting all over.. it is not a huge noise but l can hear.. (l know you cant diagnose this)

    well, thats it.. my girl started ti act crazy again.. maybe l havent washed her about 3 weeks thats why

  11. #11
    Senior Member Musclefan21's Avatar
    Join Date
    Apr 2006
    Location
    IL
    Posts
    1,155

    1997 Formula & 2003 cobra
    Thanks Curtis for your all help. l really appriciate it..

    so is this the bellhousing problem or intake manifold? can l do the job by myself or shop? and possible costs??

    thanks..

  12. #12
    Slow'er'Ass Mr. Luos's Avatar
    Join Date
    Aug 2005
    Location
    Thornton, CO
    Posts
    23,785

    Red Tint Jewelcoat
    2008 Trailblazer SS

    Your car is an auto...so that clunking I will take a stab at and say it is the tranny mount.

    The rear oil leak, I am guessing rear main seal.

    Good luck. Tranny mount is cheap and fairly easy, rear main isn't.

  13. #13
    The Mudkat
    Join Date
    Jun 2006
    Location
    "The good Lord sez he can get me outta this, but he sez he's pretty sure you're *****d!"
    Age
    54
    Posts
    61

    white
    2000 SS Convertible

    Could he have a cracked oil pressure sender???? That happened on my girl's Mazda 626 and we almost lost a motor real fast. Simple fix, ugly mess.

  14. #14
    Junior Member 02blackbeautyws6's Avatar
    Join Date
    Jun 2006
    Location
    louisiana
    Posts
    11

    black
    2002 trans am ws6

    i had a zo6 clutch put in and they called me at work and told me that my crankshaft had a crack. i didnt believe him so i told him to put it together anyway. i checked the oil every couple of days under the car leaked oil from the same spot as yours. the oil seemed like it wasnt going down so i didnt check it for a while.then one day me and a co worker took it out for a hot lap and when we got back the car was running bad the oil was down 3 qts. the shop told me it was shot to trade it in. maybe their was a crack on the crank so i traded it in problem gone. as far as the water out of the tail pipe a lot of car do that when first started check it after a ride to the store the water should be gone by then its no big deal just moisture in the exhaust like on your windshield in the morning

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •