Results 1 to 8 of 8

Running/Turn Signal Bulbs Blowing

This is a discussion on Running/Turn Signal Bulbs Blowing within the General Help forums, part of the LSx Technical Help Section category; Does anyone have a problem with the orange running lights burning out often? I have a 2000 T/A and have ...

  1. #1
    Junior Member
    Join Date
    Mar 2007
    Location
    Maryland
    Posts
    6

    Black
    2000 Trans Am

    Running/Turn Signal Bulbs Blowing

    Does anyone have a problem with the orange running lights burning out often? I have a 2000 T/A and have replaced them (both sides), it seems like 100 times. I keep some on hand, I have to replace them so much. Obviously somethings wrong. The flashers have both been replaced, but they still burn out. I think water is somehow getting in the lens/socket. Any suggestions and am I the only one with this problem?

  2. #2
    ArtistFormerlyKnownAsMac Silver Streak's Avatar
    Join Date
    Apr 2006
    Location
    Indianapolis, IN
    Posts
    4,845

    All Black
    83, 87, 02 All WS6 T/As

    Yep.. they are most likely cracking in the front as well... anyway.. both mine were and water was getting in.. and blowing bulbs... so I got a new set of lenses, and one new socket (the dr side is still ok) and its been like 9 months and I haven't changed a bulb yet.
    -Geno
    1983 Black WS6 "WindCharger"
    1987 Black WS6 "WS87"
    2002 Black WS6 "Silver Streak"
    Sold the other four f-bodies

  3. #3
    Senior Member Redphoenix1998's Avatar
    Join Date
    Apr 2002
    Location
    San Jose
    Age
    36
    Posts
    1,897

    Red
    1998 Pontiac Trans Am

    did you put dielectric grease in the socket on on the bulb connector? If you don't you will keep blowing bulbs even if you replace the lenses. Just goop the stuff in. I kept blowing mine cause I kept forgetting to put the grease in.

  4. #4
    Single Malt rbob93's Avatar
    Join Date
    Aug 2005
    Location
    Ft. Lauderdale, FL
    Age
    69
    Posts
    2,707

    Sebring Silver
    2000 CamaroSS

    to both

    Just finished with this crap two weeks ago

  5. #5
    Member jamessr's Avatar
    Join Date
    Jan 2007
    Location
    Newport News, VA
    Posts
    266

    White
    2000 Trans AM

    Quote Originally Posted by Redphoenix1998 View Post
    did you put dielectric grease in the socket on on the bulb connector? If you don't you will keep blowing bulbs even if you replace the lenses. Just goop the stuff in. I kept blowing mine cause I kept forgetting to put the grease in.
    +1 on that. I just bought some dielectric grease from autozone and coated the entire base with it. Water isn't an issue now for the past year.

  6. #6
    Member
    Join Date
    Aug 2005
    Location
    Tulsa,OK
    Age
    37
    Posts
    914

    Quick Silver
    2002 Z06

    We sell upgraded gaskets that will help fix this problem.

    If your lenses are actually cracked in the front then water will get in there but the factory gaskets shrink up and stop sealing which lets water in.


    Slow Passenger Window - Want Passenger Express Down - Tired of Replacing DayTime Running Light Bulbs

    Camaro Owners Click Here
    Firebird Owners Click Here

    Need instructions to replace your F-Body window motor?
    www.AutoTrix.net

  7. #7
    Something Diabolical... chuckie669's Avatar
    Join Date
    May 2007
    Location
    Houston, Texas
    Posts
    2,677
    2000 C5 Torch Red

    I took mine out and resealed with silicone on the front part and jbweld around the top back areas. Switched the bulbs to LED's on the front to keep them from getting the housing hot. My housing had apparently got hot and then been driven in the rain/car wash causing the piece to crack and leak.

    No issues since.

  8. #8
    Member QKSLVR99's Avatar
    Join Date
    Jan 2006
    Location
    Abilene, TX
    Age
    37
    Posts
    278

    Pewter
    1999 Trans Am

    use to had problem with drives side one swapped the socket and haven't changed that bulb in almost a yr now

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 3
    Last Post: 12-16-2014, 03:35 AM
  2. Turn Signal Bulb CONSTANTLY blowing
    By 64MonGooSe64 in forum Camaro / SS
    Replies: 29
    Last Post: 03-10-2014, 10:05 PM
  3. Help: I keep blowing turn signal lights?
    By kool-aide in forum General Help
    Replies: 29
    Last Post: 03-29-2012, 03:56 PM
  4. Help: Turn Signal Bulbs Keep Going Out!!!!
    By cz28mdn in forum Firebird / WS6
    Replies: 10
    Last Post: 08-14-2008, 11:13 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •