Results 1 to 5 of 5

Running a temp gauge/breaking in a new motor

This is a discussion on Running a temp gauge/breaking in a new motor within the General Help forums, part of the LSx Technical Help Section category; Well finally got to drive my car after about a year. Had it stroked to a 383. I was driving ...

  1. #1
    Junior Member Allday1017's Avatar
    Join Date
    Sep 2009
    Location
    IL
    Posts
    21

    Red
    1998 Z28

    Running a temp gauge/breaking in a new motor

    Well finally got to drive my car after about a year. Had it stroked to a 383. I was driving it for the first time the other day and went to make it pull and it didnt pull as hard as it should have and it wasnt going abover 2500rpm...then I relized my buddy is the one who mounted my throttle cable wrong so it would only open up a1/4 of the way... well when we went back to the shop to remount it and I noticed that I had smoke coming out of my pass side breather and my motor seemed to be a bit warmer then avg and went and looked at my temp gauge wasnt working. So before I drive it again I want to get a 2nd temp gauge installed to be safe. Anyone know how that could help me and any ideas where I should take the temp from??

  2. #2
    Member 20ws6speed01's Avatar
    Join Date
    Jun 2009
    Location
    Winston,OR
    Posts
    272

    blue
    2001 WS6

    Did u bleed all the air out of ur coolant system?

  3. #3
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Really good write up HERE.

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    You have a '98, so you get an actual working temp gauge in your dash versus the "approximator gauge" of later years. You can read your temp with a scanner through the OBDII port under the dash. That is the easiest way imo.

  5. #5
    Junior Member Allday1017's Avatar
    Join Date
    Sep 2009
    Location
    IL
    Posts
    21

    Red
    1998 Z28

    Got a gauge but the fittings that came with it didnt fit in my heads. But I ran it again and drove it about 4 miles and was running alot cooler. But everything is tore out again, getting it ready for the shop to weld/install my turbo kit. so ill let them deal with it haha.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Want to trade Tranny Temp gauge for Oil pressure gauge.
    By jrbonds in forum Parts Wanted / Trade
    Replies: 7
    Last Post: 07-29-2011, 09:47 AM
  2. temp gauge
    By Darkrider02 in forum General Help
    Replies: 6
    Last Post: 09-23-2010, 09:06 AM
  3. Question, temp gauge, running temps.
    By hozeman in forum Camaro / SS
    Replies: 11
    Last Post: 07-27-2008, 02:20 PM
  4. Hooking up Oil pressure gauge,and Temp Gauge
    By BirdFlewLS1 in forum General Help
    Replies: 5
    Last Post: 01-15-2008, 07:15 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •