Results 1 to 7 of 7

running lean, first post, need help!

This is a discussion on running lean, first post, need help! within the General Help forums, part of the LSx Technical Help Section category; This is my first post and I was thrilled to find this website. I have a 2000 Z28 that is ...

  1. #1
    Junior Member
    Join Date
    Aug 2006
    Location
    Highlands, NC
    Posts
    30

    Red
    2000 Camaro Z28

    running lean, first post, need help!

    This is my first post and I was thrilled to find this website. I have a 2000 Z28 that is plagued by the dreaded Service Engine Soon light. I had the car scanned and it is running lean on both banks. The light goes on and off but it has been staying on more lately. The light always comes on when I'm running low RPMs (1000-2000) usually after running around in 6th gear on the highway. The car is completelty stock except for a skip-shift eliminator. I replaced the fuel filter, cleaned the mass-airflow sensor, and I cleaned the little thingy (IAC?) on the driver's side in front of the MAF. None of this helped at all. I'm new to the LS1 thing- I'm used to working on stuff with a carburetor and distributor. Sorry to be so long winded, Any help will be GREATLY appreciated.

  2. #2
    Blown, Stroked, & Sprayed

    Ed Blown Vert's Avatar
    Join Date
    Aug 1999
    Location
    San Diego, Ca
    Posts
    50,526

    Black
    383 Procharged & N20 Vert

    Vacuum leak?
    Black 1999 Blown Convertible A4
    Forged 383, ATI D-1SC
    NX MAF Kit | 222/226 .585 115
    AS Stage II 6.0L FI Heads
    Moser 9" | 3.70 | Wavetrac | 35 Spline | Vigilante 3600
    548.0 RWHP - 563.8 RWTQ - 10# - D1

    666.0 RWHP - 734.2 RWTQ - 125 Shot - P1

    Black 2009 Escalade Hybrid 4WD
    Black 2008 GMC Yukon Hybrid 4WD (Totaled)

    Black 2013 Chevy Volt (Gone)

  3. #3
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    What codes where you throwing?
    J
    2001 SS, Its not the car its the Driver that matters....

  4. #4
    Junior Member
    Join Date
    Aug 2006
    Location
    Highlands, NC
    Posts
    30

    Red
    2000 Camaro Z28

    I'm not sure what the code was, I'll have to have it scanned again and write it down. I checked for cracks/holes in the bellows between the MAF and throttle body. Where else might I have a vacuum leak? Please excuse my lack of knowledge about these cars. Thanks for the help and keep it coming.

  5. #5
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    How many miles are on the beast? How long has it had this problem?
    J

  6. #6
    Junior Member
    Join Date
    Aug 2006
    Location
    Highlands, NC
    Posts
    30

    Red
    2000 Camaro Z28

    It has 87000 miles and it has been going on for a few months. I didn't worry about because it only seemed to come on when I drove on the highway and I rarely had to drive it on the highway- I live in the mountains on curvy roads where it rarely ever sees a consistent speed. Due to job change at the beginning of august, I now have a long commute on the highway and the light stays on half the time that I'm driving the car. The car runs great but the light is an annoyance and running around in open loop mode all the time probably isn't good(?) It usually seems to happen if it stays at 1200 or so RPMs for a long period of time like driving 60mph in 6th gear or driving around a parking lot looking for a space. thanks.

  7. #7
    MOTOR CITY MARO' SSTODD's Avatar
    Join Date
    Nov 2005
    Location
    LIVONIA,MICHIGAN
    Age
    50
    Posts
    786

    PEWTER
    2000 CAMARO SS #3821

    02 Sensors? That Is Alot Of Miles If They Are Original.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •