Results 1 to 7 of 7

running to lean

This is a discussion on running to lean within the General Help forums, part of the LSx Technical Help Section category; My car is running to lean I keep getting p0171 and p0174 I cleaned the Maf...it also stumbles sometimes. One ...

  1. #1
    Awaiting Activation
    Join Date
    Oct 2010
    Location
    n/a
    Posts
    190
    n/a

    running to lean

    My car is running to lean I keep getting p0171 and p0174 I cleaned the Maf...it also stumbles sometimes. One o2 sensor has Ben changed all the others are original...passenger side catalyst has been replaced

    Suggestions please....

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Is it the stock MAF?
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Awaiting Activation
    Join Date
    Oct 2010
    Location
    n/a
    Posts
    190
    n/a

    Quote Originally Posted by sunsetorangess View Post
    Is it the stock MAF?
    J
    No slP.... the stumbling is way to much to just be a bad maf though...
    once I cleaned it the cel light is on full-time

  4. #4
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Try swapping it out with a stock unit, Either your old one or if you have a buddy with a stocker and see what happens... You may be amazed.
    J

  5. #5
    Awaiting Activation
    Join Date
    Oct 2010
    Location
    n/a
    Posts
    190
    n/a

    Quote Originally Posted by sunsetorangess View Post
    Try swapping it out with a stock unit, Either your old one or if you have a buddy with a stocker and see what happens... You may be amazed.
    J
    Not an option others have Shelby cobras or vipers or Corvette zo6.

    My car came with it...no stocker

  6. #6
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Agree. Throw the SLP MAF away and get a stock or stock replacement MAF back on the car. Our car came with a modded MAF and a stumble that drove me nuts until I did the research. Other possibilities could be defective O2 sender(s), a post MAF air leak that is drawing unmetered air into the engine, or a vacuum leak that would have the same effect.

    Do you have access to a scanner to see the live sensor data?

  7. #7
    Awaiting Activation
    Join Date
    Oct 2010
    Location
    n/a
    Posts
    190
    n/a

    Quote Originally Posted by pajeff02 View Post
    Agree. Throw the SLP MAF away and get a stock or stock replacement MAF back on the car. Our car came with a modded MAF and a stumble that drove me nuts until I did the research. Other possibilities could be defective O2 sender(s), a post MAF air leak that is drawing unmetered air into the engine, or a vacuum leak that would have the same effect.

    Do you have access to a scanner to see the live sensor data?
    Diagnostic on sat keep u posted

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Running lean
    By MeanMachine1 in forum Internal Engine
    Replies: 9
    Last Post: 11-22-2012, 03:33 PM
  2. running lean
    By occamaroz in forum Computer & Tuning
    Replies: 4
    Last Post: 12-05-2009, 07:00 PM
  3. Would i be running lean
    By ledesma54 in forum GTO
    Replies: 6
    Last Post: 03-21-2008, 10:43 AM
  4. Running lean
    By emotionalpiracy in forum External Engine
    Replies: 5
    Last Post: 11-14-2007, 12:34 AM
  5. Running too lean
    By ddouds2000 in forum General Help
    Replies: 12
    Last Post: 01-03-2007, 10:27 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •