Results 1 to 13 of 13

Right DRL issues

This is a discussion on Right DRL issues within the General Help forums, part of the LSx Technical Help Section category; hey guys, i need some help with this one...i replaced the bulb socket for my right (passenger side) DRL cause ...

  1. #1
    Member godless-phoenix's Avatar
    Join Date
    Jan 2010
    Location
    culver city, Ca.
    Posts
    459

    Blackened fire chicken
    2000 Pontiac Trans Am WS6

    Right DRL issues

    hey guys, i need some help with this one...i replaced the bulb socket for my right (passenger side) DRL cause it was working on and off and the socket was pretty much fried anyway. did a solid wiring job, triple checked everything i did, the light still comes on and off randomly. When the light is off the blinker still works though, but when the blinker is off no light, then itll randomly come back on... the drivers side one has no problems just the passenger side...im thinking theres a short further up the wiring, drl control module, or parking brake switch maybe?

  2. #2
    Member godless-phoenix's Avatar
    Join Date
    Jan 2010
    Location
    culver city, Ca.
    Posts
    459

    Blackened fire chicken
    2000 Pontiac Trans Am WS6

    If i did the DRL delete mod where you just dissconnect the harness with the blue from the DRL module, will the blinkers/hazards still work?
    Last edited by godless-phoenix; 09-20-2013 at 05:37 PM.

  3. #3
    Member godless-phoenix's Avatar
    Join Date
    Jan 2010
    Location
    culver city, Ca.
    Posts
    459

    Blackened fire chicken
    2000 Pontiac Trans Am WS6

    just did the above...blinkers dont work anymore after i unplugged one of the harness connectors from the drl module so thats a no go haha
    the drls still did come on when you turn the parking or headlights on, just no blinker action

  4. #4
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Did you use the same bulb? I have had bulbs that the contacts wear down on or corrode over time. Continuity check your socket with your wire connections - could also be a bad socket.

  5. #5
    Member godless-phoenix's Avatar
    Join Date
    Jan 2010
    Location
    culver city, Ca.
    Posts
    459

    Blackened fire chicken
    2000 Pontiac Trans Am WS6

    brand new bulb, brand new socket, connections are solid. wiggled/pulled on everything i could think of..ill borrow my buddys DMM and check it out later, but its working fine for now...just randomly starts acting up going on and off random times then it'll work for a while

  6. #6
    Member godless-phoenix's Avatar
    Join Date
    Jan 2010
    Location
    culver city, Ca.
    Posts
    459

    Blackened fire chicken
    2000 Pontiac Trans Am WS6

    damn electrical gremlins

  7. #7
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    sounds like a ground wire or connection is loose

  8. #8
    Member godless-phoenix's Avatar
    Join Date
    Jan 2010
    Location
    culver city, Ca.
    Posts
    459

    Blackened fire chicken
    2000 Pontiac Trans Am WS6

    wouldnt a bad ground wire cause other things to act crazy?? connections are good...atleast the ones i made when i put the new socket on are good. i unplugged the DRL control module behind the radio and plugged it back in and the light hasnt acted up yet, ill keep an eye on it for now

  9. #9
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    If you haven't done it, strongly recommend some dielectric grease in the socket.

  10. #10
    Member godless-phoenix's Avatar
    Join Date
    Jan 2010
    Location
    culver city, Ca.
    Posts
    459

    Blackened fire chicken
    2000 Pontiac Trans Am WS6

    Quote Originally Posted by pajeff02 View Post
    If you haven't done it, strongly recommend some dielectric grease in the socket.
    I did that too...i have some experience from good ole' water getting in the lens housing issue haha

  11. #11
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    If your passenger side DRL ground is dedicated to ONLY that socket, only that light will act up.

  12. #12
    Member godless-phoenix's Avatar
    Join Date
    Jan 2010
    Location
    culver city, Ca.
    Posts
    459

    Blackened fire chicken
    2000 Pontiac Trans Am WS6

    Quote Originally Posted by cammed goat View Post
    If your passenger side DRL ground is dedicated to ONLY that socket, only that light will act up.
    im looking at the wiring schematic for '96 and later models exterior light system and it looks as if the right front marker lamps ground uses the same ground for that side DRL lamp...so im assuming that side marker lamp would be acting up to if it were the ground, right???

    the weird thing is ever since i unplugged, then replugged the drl control module, its not acting up anymore...go figure haha

  13. #13
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Connection at the DRL module could have been loose. Contacts loosen over time from vibration/age. Keep us posted if you have anymore issues with that light.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. tv issues
    By 2000redcamaro in forum Almost Anything Goes
    Replies: 15
    Last Post: 12-24-2009, 10:47 AM
  2. Q-Jet Issues?
    By pajeff02 in forum Classic Muscle
    Replies: 7
    Last Post: 09-07-2009, 01:31 PM
  3. will 20's fit on gto with no issues
    By johnjr45 in forum GTO
    Replies: 4
    Last Post: 08-11-2007, 05:48 PM
  4. PM Issues
    By schtick in forum Request and Feedback
    Replies: 0
    Last Post: 07-10-2007, 06:54 PM
  5. Having some serious issues.
    By Banshee1967 in forum Suspension and Handling
    Replies: 2
    Last Post: 03-31-2007, 08:45 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •