Page 1 of 2 12 LastLast
Results 1 to 20 of 25

rear window defroster

This is a discussion on rear window defroster within the General Help forums, part of the LSx Technical Help Section category; Seems to last only about a minute, then it won't come back on for 3, and when it does it ...

  1. #1
    Junior Member
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    54

    Pewter
    2000 Z-28

    rear window defroster

    Seems to last only about a minute, then it won't come back on for 3, and when it does it is out in 30 seconds. Is it the button itself????

    Thanks.

    p.s. I have had this car since 2000 and I was previously registered as of Nov 2000, but for some reason, my account has disappeared.....so I have re-registered but I am not new!

  2. #2
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Pittsburgh, PA
    Age
    36
    Posts
    21,719

    My life is a
    Ben Stiller movie.

    i'm adding to this strangness...my rear defroster won't even turn on...I press the button, the light blinks and it obviously doesn't turn on I don't see any severed connection.

    Milleniumz...we all had to reregister, teh site shut down in june and deleted all the user names and passes.

  3. #3
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Sounds like the "DEFOG/SEATS" circuit breaker in the main fuse box is going south. Most people just replace it with an equal size fuse, 30 AMP I believe. See if the power seat isn't working at the same time.

  4. #4
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    I've read that there's a timer for the defroster that can go out....not sure where it's at though.

  5. #5
    Junior Member
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    54

    Pewter
    2000 Z-28

    Thanks....did not know the system went down.....

    The window barely heats up when it turns itself off. It just started doing it the past few weeks.

  6. #6
    Junior Member
    Join Date
    Nov 2005
    Location
    Maryland
    Posts
    1

    red
    99 Camaro SS

    I have the same problem as MilleniumZ in my 99 SS. No idea where to look for a fix.

  7. #7
    No 55mph 1QuikWS6's Avatar
    Join Date
    Aug 2005
    Location
    USA
    Posts
    263

    Black
    2000 WS6 Trans Am

    There is an electronic timer somewhere in the circuit - but I have a good fix - don't drive your car when it's cold outside and you won't need the defroster!

  8. #8
    Junior Member
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    54

    Pewter
    2000 Z-28

    Thanks.....believe it or not I live in Florida, but the mornings do get down in the high 40's.....burr.

    TTT

  9. #9
    Junior Member
    Join Date
    Sep 2005
    Location
    NY
    Age
    35
    Posts
    90

    Black
    1999 Chevrolet Camaro Z28

    I used to have the same problem.

    I press the rear window defroster and it shuts off 4-5 mins then won't come on for like 5-10 mins. At the same time the power seat won't work.

    So what I do? I replaced the resettable circuit breaker in the seats/defog spot with a simple 30 amp fuse and that worked. Pressed the rear defrost heater button and it stays on for 10 mins like it should and shuts off.
    BTW don't set the power seats to it's stops when the rear defroster is on otherwise you'll blow the fuse.
    That's why GM put a resettable fuse in there but it's weak and opens to early with a light load.

    If it won't stay on for 10 mins this way, it's the timer that's the problem. I can't rememebr exactly where it is but it's somewhere on the driver's side either under the dash or in the rear driver seat side under the trim.

  10. #10
    Junior Member
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    54

    Pewter
    2000 Z-28

    I have moved my seat at the same time the defroster was on, no problem there........there must be a timer/sensor somewhere that could be replaced. I don't want to go to the dealer. Hopefully, someone else has experienced this dilema?????

    Thanks.

  11. #11
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Pittsburgh, PA
    Age
    36
    Posts
    21,719

    My life is a
    Ben Stiller movie.

    yeah, the dealership wants like 250 to fix my timer

  12. #12
    Junior Member
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    54

    Pewter
    2000 Z-28

    any info from the dealer as to where the timer is....maybe a part number????

  13. #13
    Junior Member
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    54

    Pewter
    2000 Z-28

    Does anyone know where this timer could be ???? Last time to the top....Thanks.

  14. #14
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Quote Originally Posted by milleniumz
    I have moved my seat at the same time the defroster was on
    You need to check the seat when the defogger decides to shut itself OFF to check the breaker since they're on the same circuit, right? Maybe I'm missing something here, but I'd put in a 30 AMP fuse just for the hell of it and see if it solves the problem.

  15. #15
    maroonZ
    Guest
    I noticed the same things this mroning for the first time in my Z.

    Came on for about 30 seconds and then shut off. Took a couple of mins before I could turn it on again.

    Gets to be a real problem in the freezing North. -22 C this morning with the wind chill.

  16. #16
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    My defroster shut off too....seat stopped moving and al. Gonna try that 30 amp fuse....wonder why gm put that resettable breaker in there?

  17. #17
    maroonZ
    Guest
    GM probably put in that breaker in to keep the people from having to replace fuses all the time and to keep from over heating and melting the wiring (would be bad if that happened). At least that is what my smart ass electrician brother said.

    I haven't had any problems with my seat yet though. Guess it is just a matter of time.

  18. #18
    Junior Member yellow93ta's Avatar
    Join Date
    Dec 2005
    Location
    missouri
    Posts
    29

    sunfire yellow
    1993 trans am

    mine was doing the same thing,,only on for a minute, then had to wait five to come on again. replaced the relay with a 30 amp. fuse yesterday works great, whish I would of know this last winter..lol...anyway I don't have power seats, just air lumbar...so hopefully it will last..

  19. #19
    I went to Playboy Mansion FantaZGuy28's Avatar
    Join Date
    Sep 2005
    Location
    Bakersfield/Long Beach Ca
    Age
    31
    Posts
    888

    YJ
    04 GTO M6

    Atleast you guys have defrosters. I have to use hopes and dreams when i drive and the window is icy or foggy.

  20. #20
    frederal
    Guest
    Ok everyone listen closey. GM has a Technical Service Bulletin, document ID# 1574990 or PIC3270 dated 12/2/2004, " rear defogger performance, off too soon". Frequent use of the rear defroster when used to clear snow, frost, etc. may cause the circuit breaker and terminals to overheat. Because of this , there is added resistance and ther circuit breaker begins to open at times and this will happen more and more frequently. The lenght of on time gets shorter and shorter. Replace the circuit breaker and the fuse box terminals from kit part# 22638255, this covers 1999 to 2001 models. This has nothing to do with a timer!!!!

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: rear window defroster
    By JayTA98 in forum General Help
    Replies: 14
    Last Post: 05-19-2011, 04:30 PM
  2. rear defroster
    By 04goatinmass in forum Firebird / WS6
    Replies: 18
    Last Post: 11-23-2010, 07:08 PM
  3. defroster lead broke off window ???
    By 3800rs in forum Convertible
    Replies: 4
    Last Post: 11-01-2006, 02:39 PM
  4. Rear Defroster
    By jrocs00z28 in forum General Help
    Replies: 8
    Last Post: 10-04-2006, 02:45 PM
  5. Help fixing rear defroster
    By Thewilldog in forum Stereo and Electronics
    Replies: 5
    Last Post: 11-14-2005, 02:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •