Page 2 of 2 FirstFirst 12
Results 21 to 26 of 26

Racetronix pump priming?

This is a discussion on Racetronix pump priming? within the General Help forums, part of the LSx Technical Help Section category; Glad to hear you found the problem...

  1. #21
    Senior Member tatertot91's Avatar
    Join Date
    Oct 2008
    Location
    Coral Springs, Fl
    Posts
    5,773

    Sunset Orange Metalic
    2001 Camaro SS

    Glad to hear you found the problem

  2. #22
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    yeah me too. that's what I like about this forum. We help each other out! Thanks again Orion.

  3. #23
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Well I'm still using the old fuel tube. It's holding pressure good. I didn't find any R10 rating hose. I got some R9 in my trunk with 2 hose clamps in case of an emegency. I still haven't heard from racetronix about them sending a new tube. I guess if i don't hear from them soon I will have to buy the R10 hose online or a new tube. Will worm screw clamps work for the R10 hose? Anyone know the model number of the walbro pump(just the pump)? I will like to have a spare one just in case for my 98 TA.

    One thing that i'm noticing is that when I fill up the tank it shows like 1/8 down from full and while I drive for the 1st 20 miles it slowly starts to go up. Weird.

  4. #24
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    don't use that R9 if you can help it......it'll degrade in the tank and cause more problems than it's worth. Your NAPA didn't have the R10? The ones around here do although some of the counter guys don't know the difference between R9 and R10. Worm gear clamps should work fine on it.
    That issue with the gas gauge is a fairly common one. You could try to run some cleaner through the tank and see if that helps....resistor for the sender could just have some build up on it.

  5. #25
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    yeah none of the guys at the counter don't know crap about the difference between R9 and R10. I think my fuel gauge issue is more that I might bent the float arm slightly when I tried to get it out while I attempted to drop the tank. When i fill up to the neck I'm reading close to 1/8 less than full. Like is out of adjustment. Not a big deal that makes me have more spare fuel on the reserve side. I might try to adjust the arm slightly. I'm not using the R9, I have it as a spare tube in my trunk in case the other one breaks while on the road. I wanna get a spare pump too just in case, I just need the model number.

  6. #26
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    man still no reply from racetronix except that I can post anything o help other members. I mean they have the right to do that but how about you answer my PM's and posts??? lol i don't get it. I'm really not too happy with their costumer service so far. I hear all the good things about them and I'm going to experience the quality of their products which I read that alot of people support but as far as costumer service I'm not too impressed...

    Now if you wanna talk about awesome costumer service I have to give props to TunedbyFrost.com and UMIperformance.com.
    Frost answered all my questions and even when he realized that made a mistake he paid for overnight shipping both ways to get the PCM back to me ASAP due to my DD situation. That's awesome service!!! Not to mention the difference in my car

    UMIperformance answered all my questions quickly and sent my items super fast too. Great products!

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: New racetronix pump not pumping
    By ponyslayer in forum General Help
    Replies: 14
    Last Post: 11-27-2011, 06:21 AM
  2. Racetronix pump whinning
    By JayTA98 in forum General Help
    Replies: 6
    Last Post: 07-24-2010, 04:29 PM
  3. oil pump priming for lt1 rebuild
    By HeadDown in forum LT1
    Replies: 1
    Last Post: 07-09-2008, 05:04 PM
  4. 98 LS1 Racetronix fuel pump
    By underated98z in forum Parts For Sale / Trade
    Replies: 0
    Last Post: 04-12-2007, 12:51 PM
  5. Oil pump priming
    By JEFF01Z in forum Internal Engine
    Replies: 6
    Last Post: 01-09-2007, 08:41 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •