Results 1 to 8 of 8

Pushrod Issue

This is a discussion on Pushrod Issue within the General Help forums, part of the LSx Technical Help Section category; installing a new cam today and after removing the pushrods i came across this problem on almost each one in ...

  1. #1
    Member kiddynamite's Avatar
    Join Date
    Mar 2008
    Location
    Indiana
    Posts
    119

    Black
    2002 Trans Am WS-6

    Pushrod Issue

    installing a new cam today and after removing the pushrods i came across this problem on almost each one in varying degrees of severity...

    i had some po-dunk shop install my head/cam a while back and it seems like everything they did the botched it up

    how did this happen and what can i do to make sure nothing like this happens in the future?

    any advice is appreciated.

  2. #2
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,997

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    pic is kinda small and dark. What exactly happened to that pushrod?

  3. #3
    Mustang Eater Ls_won's Avatar
    Join Date
    Feb 2010
    Location
    Springfield, Missouri, United
    Posts
    221

    Maroon
    2000 z28 6 speed

    cant really tell with that little picture...
    2001 B4C Totaled 4/25/11
    2000 Z28 M6 Cammed N' Slammed (SVT KLR)

  4. #4
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Quote Originally Posted by Cutlass View Post
    pic is kinda small and dark. What exactly happened to that pushrod?
    Quote Originally Posted by Ls_won View Post
    cant really tell with that little picture...
    There's a strange groove cut into the pushrod..
    Looks like 1/2" in size around the entire PR..

  5. #5
    ʢ ൧ ൨ ൩ ൪ ൫ ൬ ൭ ൮Ր Ց Ւ Փ Smittro's Avatar
    Join Date
    Feb 2009
    Location
    Pittsburgh
    Posts
    9,965

    White
    2008 Hummer H3

    Here, maybe this will help some..


  6. #6
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    Interesting. I've never seen anything like that before. Subscribed.

  7. #7
    Exalted Cyclops 67CamaroRSSS's Avatar
    Join Date
    Feb 2007
    Location
    San Diego, CA
    Posts
    5,824

    2002 Z28 A4 NBM
    Sadly now demodded :(

    An anecdote:

    Back in the day (late 70's - before I knew what I was doing) I set up a set of SBC 461 heads to run screw in studs and guide plates. I didn't have the push rods guides in the head drilled out (like I said - didn't know much) and I didn't run hardened push rods. I had the same effect as you, i.e., I watched (had clips on the rockers to prevent oil from spouting out everywhere) as a new set of pushrods were ground down to dust where they rubbed against the guide plates.

    Any of this sound familar?

    P.S.: Yeah, I learned a lot of shit the HARD way...
    67 Camaro: K-K + 797-z (look it up), 454/Th400/4.10 12-bolt = 6mpg, PS/PDB/PW tilt, tach, gauges...

    2005 Corvette LS2/M6 Magnetic Red Metallic (What else would it be?) w/ Cashmere interior

    2002 Z28: NBM/Tan, MTI smooth lid, smooth bellows, !AIR, !cats, 1-3/4" QTP SS LT's, 2-1/2" TD's with X-pipe, MagnaFlows dumped at axle, custom welded SFC's, MidWest Chassis body mount adjustable T/A, 3400 stall, 3.23 gears (was 2.73). Tuned: 343rwhp/357rwt (before TD's). Best: 12.559 @ 108+, 1.73 60' @ 3500' DA w/MT ET Street DR's.

    Carbon footprint? CLOWN SHOE!

  8. #8
    Mustang Eater Ls_won's Avatar
    Join Date
    Feb 2010
    Location
    Springfield, Missouri, United
    Posts
    221

    Maroon
    2000 z28 6 speed

    Oh i see that now, i have no idea! looks almost machined into it. Subscribed.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. pvc issue... vacuum leak....tune issue?
    By okiels1 in forum General Help
    Replies: 3
    Last Post: 03-05-2016, 10:10 AM
  2. Help: Bent Pushrod
    By cowstandmoto in forum Firebird / WS6
    Replies: 27
    Last Post: 06-06-2013, 04:49 PM
  3. pushrod length??
    By Mikat1 in forum Internal Engine
    Replies: 1
    Last Post: 03-15-2011, 10:36 AM
  4. bent pushrod issue
    By natews6 in forum Internal Engine
    Replies: 14
    Last Post: 06-15-2010, 10:09 PM
  5. Help: I think i have a bent pushrod!
    By camaroluvr447 in forum General Help
    Replies: 21
    Last Post: 12-24-2009, 11:18 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •