Results 1 to 4 of 4

PS pump noise?

This is a discussion on PS pump noise? within the General Help forums, part of the LSx Technical Help Section category; So I replaced the shaft seal on my PS pump. The removal and instalation went pretty well. I disconnected the ...

  1. #1
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    PS pump noise?

    So I replaced the shaft seal on my PS pump. The removal and instalation went pretty well. I disconnected the lines at the rack and pinion and moved the wheel all the way to both sides to bleed out the old fluid. I bled the lines and push air into them to clean the old fluid. I put everything back together and added some new fluid to the reservoir. I started the car and checked the fluid, it went down abit so added to the right level. I jacked the front wheels off the ground and slowly turn the wheel all the way to each side. I rechecked the fluid and added some more. I pulled the car out of the driveway and did a full right turn and full left turn. Recheck the fluid and it drop a little. I added more fluid unitil it won't don't drop anymore. The pump is making noise when the car is stopped and i start to turn the wheel. If im driving the car it doesn't make any noise.

    I know the pummp will make some noise when it reaches all the way on the turn. But it wasnt doing noise on the way to the full turn before I replaced the seal. Is the pump bad or did I miss something on the bleeding process?

  2. #2
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    Prolly still have air in the system. Can be a pain to bleed

  3. #3
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Yeah. Probably a little air in the fluid. Fluid might be a little foamy/aerated. Let it sit for 30 minutes or more. The fluid will settle out and it should be ok and noise free.

  4. #4
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Ty Cutlass. I quiet down some when I drove it today. i didn't have any luck getting a new o ring. I don't know if they sell them separate. I will need to find the part number. I put it back and I think is not leaking.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New power steering pump making subtle noise?
    By Ws6islife in forum General Help
    Replies: 20
    Last Post: 02-28-2013, 02:45 PM
  2. Replaced Oil Pump. Low pressure, no noise.
    By Black LS1 T/A in forum Internal Engine
    Replies: 22
    Last Post: 12-14-2011, 07:36 AM
  3. Question: fule pump noise .. any help?
    By Jeddah_z28 in forum General Help
    Replies: 35
    Last Post: 12-21-2010, 06:50 PM
  4. Hearing A Noise.... Power Steering Pump?
    By KyleLs1 in forum General Help
    Replies: 7
    Last Post: 08-03-2007, 05:02 PM
  5. Pump sounding noise
    By gareth001 in forum Camaro / SS
    Replies: 3
    Last Post: 07-23-2007, 03:33 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •