Results 1 to 9 of 9

Problem with rear end sway?

This is a discussion on Problem with rear end sway? within the General Help forums, part of the LSx Technical Help Section category; im having serious problems lately with the maro...at high way speeds it honestly feels like the rear end is rocking ...

  1. #1
    Senior Member SteveCZ28's Avatar
    Join Date
    Jul 2006
    Location
    Greene, Iowa
    Age
    32
    Posts
    1,707

    Red
    99 Chevrolet Camaro Z-28

    Problem with rear end sway?

    im having serious problems lately with the maro...at high way speeds it honestly feels like the rear end is rocking or swaying side to side just back and forth for some reason...the suspension has right at over 100k miles on the stock suspension. and am waiting for the new wheels to be put on to figure out what to do with the suspension, as far as me dropping it or not.i have no clue as to what to look for to help eliminate this problem, but i dont want the sway to get worse and kick the car out from under me and lose it..becuase honestly it feels like some days are worse than others. and i smetimes really have to jerk the wheel to keep it on track. anyone else have this problem?

    also it has brand new tires all the way around, not that, that could cause much to this problem......any help would be greatly appreciated...thanks in advance steve

  2. #2
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    you need to check for loose or broken suspension pieces. the first i would check is the sway bar mounts. then the panhard rod.

  3. #3
    That Ls1 Guy 00 silver ss's Avatar
    Join Date
    Apr 2009
    Location
    Winter Haven Fl
    Posts
    17

    Sebring Silver Metallic
    Chevrolet Camaro SS

    my car is doing the same thing but all my suspension stuff is rather new so what could be the problem.
    i replaced the shocks and struts. im not sure why its doing this ne help will be of great help
    Last edited by 00 silver ss; 04-29-2009 at 02:55 PM.

  4. #4
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Yes, Pan hard bar, sway bar, tire pressure?

    Also, make sure you didnt just install a set of Mickey Thompsons or Hoosiers!

  5. #5
    That Ls1 Guy 00 silver ss's Avatar
    Join Date
    Apr 2009
    Location
    Winter Haven Fl
    Posts
    17

    Sebring Silver Metallic
    Chevrolet Camaro SS

    tire press is 32 no panhard stock swaybar no mts

  6. #6
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    Subscribed.

    A couple of people down here have had the same issue, mine above 120 does this... (whoops) but they all had theirs taken to alignment shops and most of the time the stock 10 bolt can actually warp itself or warp stock components. One of the guys had 1/2inch warp. Adjustable suspension cured those.


    Poly bushings/end links should run you about 50 bucks for the rear from Mark at KY speed for the swaybar.. I would go that route because even if it isnt the problem at 100k they are wore the hell out.

  7. #7
    That Ls1 Guy 00 silver ss's Avatar
    Join Date
    Apr 2009
    Location
    Winter Haven Fl
    Posts
    17

    Sebring Silver Metallic
    Chevrolet Camaro SS

    what would cause it to warp like that. pm me w an answer cause im having troubl finding this thread

  8. #8
    Impounded
    Join Date
    Oct 2007
    Location
    Beaver Dam KY
    Posts
    7,746

    79 T/A -91 Firebird
    1998 Trans Am -Oynx Black

    PM sent.

    Warp is caused by the stock piece of shit products that GM put in the f-body rear ends. Not made to handle the power/abuse

  9. #9
    Member 02WS6dream's Avatar
    Join Date
    Jun 2006
    Location
    Charlotte, NC
    Age
    34
    Posts
    668

    08 Mustang GT/CS Blue
    2002 Trans Am WS6 traded

    inexperienced answer...but have ya'll checked into worn bushings (at 100K)?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: UMI front sway bar fitment problem
    By xmarkx in forum Suspension and Handling
    Replies: 11
    Last Post: 01-09-2011, 07:59 PM
  2. rear sway bar help
    By Ramairgod84 in forum Suspension and Handling
    Replies: 3
    Last Post: 04-23-2010, 08:39 AM
  3. MAf,AGX rear shocks, Strano sway bars,1LE sway bar
    By AFASTYZFR1 in forum Parts For Sale / Trade
    Replies: 3
    Last Post: 09-21-2008, 02:54 PM
  4. WTB BMR rear sway bar
    By QtrWhore in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 08-11-2008, 07:35 AM
  5. Stock front sway bar rear sway bar........
    By pewterzron in forum Parts For Sale / Trade
    Replies: 5
    Last Post: 06-27-2008, 04:42 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •