Results 1 to 9 of 9

problem with cavalier

This is a discussion on problem with cavalier within the General Help forums, part of the LSx Technical Help Section category; First off, I hope I am posting in the right section? Anyways my daily driver has been having an issue ...

  1. #1
    Junior Member The Machinist's Avatar
    Join Date
    Nov 2012
    Location
    washington
    Posts
    67

    NBM
    2001 Camaro SS SLP# 2646

    problem with cavalier

    First off, I hope I am posting in the right section? Anyways my daily driver has been having an issue with sputtering between 1500 and 2000 rpm when I mash the pedal. I was thinking maybe fuel pump/filter but at highway speeds it cruises just fine. So that leaves ignition. Maybe coil or wires. I replaced fuel filter and plugs about a year ago. Btw the sputtering feels really violent at times and i noticed it doesnt do it when engine is cold. Any input would be appreciated.

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    I take it you don't have any codes?

    Never a bad idea to clean the MAF with some CRC Spray MAF cleaner for starters. Any possibility you have a vacuum leak? If none of these easy fixes help, then it sounds like a spark or fuel issue absent codes.

  3. #3
    Former Mopar Man 2002ssslp's Avatar
    Join Date
    Jun 2011
    Location
    Branchville, NJ
    Posts
    3,111

    Silver & Blue
    02 Camaro SS, 04 GTO

    If you do not have any codes they I would test for vacuum leaks and clean your MAF and throttle body.
    My ride is a 2002 Camaro SS SLP #3296 with 30k, LTH, 3" Y, CME, Frost tune, K&N, ported TB, Blackwing lid, Bellows, MSD, Denso Iridium, and 85mm MAF, Bilsteins, Eibach springs, SLP strut brace, Adj. Panhard, TA Girdle, UMI, Pro 5.0, Nitto NT555
    My wife has a 2004 GTO with the rare SAP, 18" wheels, K&N Cold Air System, MSD, Ported TB, Frost tune, Denso Iridium, Flowmaster cat-back, 3200 Yank, 75k

  4. #4
    Junior Member The Machinist's Avatar
    Join Date
    Nov 2012
    Location
    washington
    Posts
    67

    NBM
    2001 Camaro SS SLP# 2646

    nope, no check engine lights. Ill try ckeaning the maf and tb thanks for the suggestions

  5. #5
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    it never does it when cold? How long into the drive does it start doing it? The list of possibilities is actually fairly long. How many miles on the O2's? The reason I ask is the O2's don't control fueling until the coolant hits a certain temp ( not sure of the temp on the crapalier) so what you're describing *could* be bad O2's. Normally you will get some O2 codes when that happens though. I would exhaust the other options first....check plugs and wires ( you say you swapped plugs but didn't mention wires) and check your fuel pressure and things like that. Cleaning the MAF never hurts like someone else mentioned.

  6. #6
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,511

    Navy Blue Metallic
    98 T/A w/a little mods...

    Check the oil and coolant for cross contamination. Cavaliers are known for their head gasket issues on the 2.2 motors.

    Like Orion stated it's a long list that can cause the problems you're posting about.



    I hugged my niece the day she traded her's in.........

  7. #7
    Junior Member The Machinist's Avatar
    Join Date
    Nov 2012
    Location
    washington
    Posts
    67

    NBM
    2001 Camaro SS SLP# 2646

    Yeah unfortunately I am aware of all of the woes that cavaqueers have. But fortunately I have had zero problems with mine the whole year and a half that i have owned mine until now. She has just shy of 200k so I dont expect to not have troubles now and again lol. I like to keep the miles low on the ss so this is just my winter beater to get me to and from work.

  8. #8
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Quote Originally Posted by 0rion View Post
    it never does it when cold? How long into the drive does it start doing it? The list of possibilities is actually fairly long. How many miles on the O2's? The reason I ask is the O2's don't control fueling until the coolant hits a certain temp ( not sure of the temp on the crapalier) so what you're describing *could* be bad O2's. Normally you will get some O2 codes when that happens though. I would exhaust the other options first....check plugs and wires ( you say you swapped plugs but didn't mention wires) and check your fuel pressure and things like that. Cleaning the MAF never hurts like someone else mentioned.
    This.



    Also, you can have stored engine fault codes without the check engine light coming on. Take it to the auto parts store and have them hook up the OBDII scanner and see if anything pops up.

  9. #9
    Junior Member The Machinist's Avatar
    Join Date
    Nov 2012
    Location
    washington
    Posts
    67

    NBM
    2001 Camaro SS SLP# 2646

    I have a preditor tuner I can scan it with

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Can you guys help with my Cavalier?
    By redrocketws6 in forum Domestics and Foreigns
    Replies: 3
    Last Post: 11-01-2010, 07:36 PM
  2. FS- 94 chevy cavalier
    By ls1blackbeauty98 in forum Eastern Members
    Replies: 5
    Last Post: 10-13-2008, 05:18 PM
  3. Fast Cavalier???
    By Y2K_CAMARO in forum Almost Anything Goes
    Replies: 1
    Last Post: 08-24-2008, 01:42 AM
  4. 2001 cavalier help!!!
    By JoshieDoom in forum Domestics and Foreigns
    Replies: 0
    Last Post: 03-23-2008, 11:24 PM
  5. Does anyone own a 98+ Cavalier/Sunfire?
    By Warbird in forum Almost Anything Goes
    Replies: 1
    Last Post: 08-24-2006, 11:33 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •