Results 1 to 9 of 9

Problem with 2000 Z28 wont go over 20 MPH

This is a discussion on Problem with 2000 Z28 wont go over 20 MPH within the General Help forums, part of the LSx Technical Help Section category; I was driving at about 70 MPH on the freeway and the car started acting like it was out of ...

  1. #1
    Member
    Join Date
    Oct 2005
    Location
    Houston,Texas
    Age
    36
    Posts
    149

    white
    2000 Camaro Z28

    Problem with 2000 Z28 wont go over 20 MPH

    I was driving at about 70 MPH on the freeway and the car started acting like it was out of gass but I had 1/4 tank. I pulled off to the shoulder and put it in park, it idled fine and reved good so I put it in drive and I had to punch it to get going cuz of traffic but the car just boged down and would not go over 20 MPH i stayed on the gas but it died.

    If you ease into the gas, it will go faster but if you floor it it dies.

    Any idea? I have it at the dealer hope in covered under my extended waranty

    Thanks, jason

    2000 Z28 Auto
    MTI Clear Lid (Free Ram Air Mod Raised Air box) Larger MAF Ends,K&N Filter, SS Exhasut with cut out, rear Lower control arms,smooth bellows,12.894@107.10MPH Dynoed 316 HP (Before RLCA and smooth bellows) 8.3.12 @86.86 1/8th mile 121,000 miles

  2. #2
    Senior Member ninobrn99's Avatar
    Join Date
    Aug 2003
    Location
    Honolulu HI
    Age
    33
    Posts
    2,486

    Pewter
    all bore 370 Trans Am

    are u sure the TB isnt stuck or the cable? maybe the iac motor went out

  3. #3
    We'll be back... GatorSS's Avatar
    Join Date
    Aug 2005
    Location
    THE SWAMP
    Posts
    1,446

    Light Pewter Metallic
    2000 Camaro SS M6

    Miles? SES light? Do you still have cats? I've seen that happen with clogged cats or other exhuast obstruction. Or, a fuel restriction, but that usually also causes a rough idle.

  4. #4
    Senior Member ninobrn99's Avatar
    Join Date
    Aug 2003
    Location
    Honolulu HI
    Age
    33
    Posts
    2,486

    Pewter
    all bore 370 Trans Am

    if you do have cats, does it smell like rotten eggs?

  5. #5
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,468

    98 Formula
    06 duramax

    I'd check fuel pressure at the rail first.

  6. #6
    SUPREME member-oderator oneBADDz's Avatar
    Join Date
    Nov 2005
    Location
    Lost in Texas
    Age
    33
    Posts
    2,683

    Custom Slate Blue
    99 B4C

    I'd say fuel problem or clogged cats. I'd vote fuel supply problem before anything else.

  7. #7
    Member
    Join Date
    Oct 2005
    Location
    Houston,Texas
    Age
    36
    Posts
    149

    white
    2000 Camaro Z28

    some people on other boards were sayinf MAF problem. I do have some larger blue MAF ends on the stock elctronic peice but I have never had a problem with it before and the ses light is not even on right now.

    thanks

  8. #8
    Senior Member ninobrn99's Avatar
    Join Date
    Aug 2003
    Location
    Honolulu HI
    Age
    33
    Posts
    2,486

    Pewter
    all bore 370 Trans Am

    has it been tuned for those maf ends? If not, they're going to throw your tune out of wack big time! Its running much leaner than it thinks it is. out the stock ones on and see if it helps.

  9. #9
    Member
    Join Date
    Oct 2005
    Location
    Houston,Texas
    Age
    36
    Posts
    149

    white
    2000 Camaro Z28

    Just got a call from the dealer. It was a dirty MAF sensor. I wonder if its the K&N oil? I have not reoiled it, its the oil that was on it since new

    That and my trans mount was broke. I was wondering what banging noise was when I hit the gas.

    $17.00 to clean it and $68 to find out it was dirty

    I wish I thought about it before I had it towed in cuz my mothers car was doing the same thing and I cleaned hers and it was fin after that. She has a 2000 Celica

    Thanks, jason

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •