Results 1 to 8 of 8

problem

This is a discussion on problem within the General Help forums, part of the LSx Technical Help Section category; ok here is the deal my 2002 TA ws6 like a month ago started puffing out some smoke when i ...

  1. #1
    Junior Member seth_12's Avatar
    Join Date
    Sep 2009
    Location
    Texas
    Posts
    93

    NBM
    2002 pontiac Trans Am Ws6

    Question problem

    ok here is the deal my 2002 TA ws6 like a month ago started puffing out some smoke when i started it up but it only does it sometimes not all the time and the smoke would last about 20secs and than it would stop...i cant figure out if its oil problem or fuel problem, i been looking to see if the smoke is blue which of course means oil problem but i cant tell but i have noticed that its eating up oil pretty quick and my low oil light would turn on and i would put oil in it but a week to two weeks later the light would turn on again...could it mean im leaking oil somewhere in the engine? Also does anyone out there know where i can get some HID lights for my headlights and fog lights?

  2. #2
    War Machine BIG GUNS's Avatar
    Join Date
    May 2007
    Location
    St. Louis MO.
    Age
    53
    Posts
    2,100

    Black
    00 Trans Am/Auto

    Mine will do it every now and then but, usually when it has been idling in park for a bit.

    I have headers so, I started seeing it after I put headers on and a tune. Not a big deal as oil bypass is common among the pre-2002 motors I believe. They fixed the seals in the 2001 or 2002 but, can't remember. Since yours is a 2002, I can't say that it is a seal issue.

    Mine runs lean so, it may be more pronounced in mine due to that.

  3. #3
    Member kevnstac's Avatar
    Join Date
    May 2006
    Location
    Woodstock
    Age
    57
    Posts
    211

    Black
    1999 WS6

    Sounds like valve seals to me, but I'm no expert that's for sure.

  4. #4
    Junior Member
    Join Date
    Sep 2009
    Location
    texas
    Posts
    26

    maroon
    2000 trans am

    You got my vote too.

  5. #5
    War Machine BIG GUNS's Avatar
    Join Date
    May 2007
    Location
    St. Louis MO.
    Age
    53
    Posts
    2,100

    Black
    00 Trans Am/Auto

    Yep, that's what I was trying to say on that. Thanks for the help.

  6. #6
    Junior Member seth_12's Avatar
    Join Date
    Sep 2009
    Location
    Texas
    Posts
    93

    NBM
    2002 pontiac Trans Am Ws6

    yea i think its valve seals im pretty sure its probably worn out

  7. #7
    Member Ramair1's Avatar
    Join Date
    May 2006
    Location
    Hugo, OK
    Posts
    144

    Black/PurpleChromeFlames
    1999 Pontiac Trans Am WS6

    I have the same issue on my white 99WS6, so I installed a oil catch can to help with the issue. It helps a little but does not resolve the issue. I bought a new scoggin dickey short block assy and put a hot cam in it with tuning and noticed the oil issue approx 6 months later with oil consumption. About a qt used every oil chng.

  8. #8
    Junior Member seth_12's Avatar
    Join Date
    Sep 2009
    Location
    Texas
    Posts
    93

    NBM
    2002 pontiac Trans Am Ws6

    hmmm true i do race the TA i need to get it tune and checked for all the stuff i added i put a cam, headers, exhaust, air intake, throttle body spacer, taylor thunder volt 50 ignition wires, ac delco racing spark plugs, 255lph aftermarket fuel pump and im fixing to get some bigger fuel injectors, intake manifold, ignition coils, and a bigger throttle body so i def. need to get it re-tuned...anyone out there know a good place to take it so far i found one place in austin tx and they want $125-$250 but that seems a lil to cheap so idk if i want them to mess with my comp.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. cluth problem??? transmission problem???? please HELP!!!
    By adamblake97 in forum Manual Transmission
    Replies: 3
    Last Post: 04-07-2014, 08:34 AM
  2. Obama's Woman Problem A Problem Of His Own Making
    By Ed Blown Vert in forum Political / Debate Forum
    Replies: 0
    Last Post: 01-14-2013, 03:50 PM
  3. Fuel Problem or Severe Engine Problem
    By pet_monk in forum General Help
    Replies: 3
    Last Post: 02-18-2008, 08:51 AM
  4. Electrical/charging problem problem
    By jchcomputers in forum General Help
    Replies: 4
    Last Post: 02-23-2007, 06:59 AM
  5. is it a clutch problem, or a tranny problem?
    By sgt0704 in forum Manual Transmission
    Replies: 3
    Last Post: 01-07-2007, 05:03 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •