Results 1 to 3 of 3

power steering went out at 16,000 miles

This is a discussion on power steering went out at 16,000 miles within the General Help forums, part of the LSx Technical Help Section category; Power steering suddenly went out, popped hood belt was still there, pump has plenty of fluid and never made any ...

  1. #1
    Junior Member SILVER BULLETT's Avatar
    Join Date
    Jan 2006
    Location
    Tipton,Mi
    Age
    53
    Posts
    15

    Silver
    00' WS6 Trans Am

    power steering went out at 16,000 miles

    Power steering suddenly went out, popped hood belt was still there, pump has plenty of fluid and never made any noise.Car only has 16000 miles just wondering if anybody else has had this happen, usually the pump will give you some kind of warning before going out.

  2. #2
    Member
    Join Date
    Aug 2005
    Location
    Tulsa,OK
    Age
    35
    Posts
    914

    Quick Silver
    2002 Z06

    Sometimes they will make noise and sometimes they won't. I had the pump in my 96 T/A actually break the shaft. The belt fell off and I could pull the pulley and shaft right out of the pump. No warning on that one, just got in it and no power steering.

  3. #3
    Junior Member SILVER BULLETT's Avatar
    Join Date
    Jan 2006
    Location
    Tipton,Mi
    Age
    53
    Posts
    15

    Silver
    00' WS6 Trans Am

    I'm thinking the shaft must have broke also

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •