Results 1 to 7 of 7

Power steering pump hose won't stay on!!

This is a discussion on Power steering pump hose won't stay on!! within the General Help forums, part of the LSx Technical Help Section category; The hose got popped off when I jacked the motor up to swap motor mounts - I reinstalled it, everything ...

  1. #1
    Junior Member
    Join Date
    Apr 2007
    Location
    Colorado Springs
    Age
    37
    Posts
    47

    Gold
    1998 Z28

    Power steering pump hose won't stay on!!

    The hose got popped off when I jacked the motor up to swap motor mounts - I reinstalled it, everything looked fine, refilled the fluid - but when I start the car it pops the hose off. I have tried reinstalling it + adding a worm style hose clamp below the standard clamp (tried above too) to no avail. Anyone heard of this happening before? I've filled the reservoir a couple times and it keeps blowing all over my garage when I start the car. The hose is not pinched from the pump to the crimped metal connector it goes into... I haven't checked past that.

    Thanks
    Tom

  2. #2
    Senior Member Orcus79's Avatar
    Join Date
    Feb 2006
    Location
    Canada
    Age
    38
    Posts
    1,346

    black
    2002 WS6

    ok, if I get what you are saying, It sounds as if the hose has blown out of the crimp and off the fitting on the pump. If that is the case you'r best bet would be to get a new hose as it would seem top me the you have experianced a hose failure.

    Or if you really wnat bullet proof and have the time and money. Look at getting an areoquip set up and running your own. FYI if you can find one Areoquip does make industrial hydrolic hose and chances are it is much cheaper per foot then the stainless braid and the aluminum fittings.

  3. #3
    Junior Member
    Join Date
    Apr 2007
    Location
    Colorado Springs
    Age
    37
    Posts
    47

    Gold
    1998 Z28

    well, the hose looks ok - it just won't stay on the pump. even with multiple clamps holding it on.

  4. #4
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Hose is pinched, or the elbow is.
    J
    2001 SS, Its not the car its the Driver that matters....

  5. #5
    Junior Member
    Join Date
    Feb 2008
    Location
    Southwest Oregon
    Posts
    30

    light grey
    1978 Volvo 242GT

    I know this sounds crazy but.....reversed hoses? Wrong pump (reverse rotation?) Or...like already said, some cink or obstruction inside the pump? Goood luck.

  6. #6
    Dirty Harry hec33's Avatar
    Join Date
    Sep 2007
    Location
    Starkville, MS
    Age
    31
    Posts
    78

    Pewter
    1999 Z28 M6

    Which hose is it? The big hose that has metal or just the little return hose? If its the big metal to rubber hose, I'd advise you to buy another one. They generally have to hold atleast 1,800 psi! The return hose, on the other hand, shouldn't build up much pressure at all...

  7. #7
    Junior Member
    Join Date
    Apr 2007
    Location
    Colorado Springs
    Age
    37
    Posts
    47

    Gold
    1998 Z28

    yeah it was the one with metal to rubber... i just figured out the problem and I sure feel like a retard! when the hose popped of and was spilling fluid everywhere I had plugged the bottom of the reservoir with a golf tee looking plastic object and forgot it was in there... the hose kept popping off and it seemed like a pressure buildup, finally I remembered. That's the problem with having to wait 3 weeks before finishing a project like the motor mounts here. she runs great now, although still a little banging from the y-pipe i'm guessing during good throttle... even with poly tranny and motor mounts... i need to investigate more - i've already bent the bracket out that is real close to the pipe

    thanks for all the help!

    Tom

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Power steering return hose
    By Pete Rock98 in forum General Help
    Replies: 10
    Last Post: 04-09-2011, 06:47 AM
  2. Power Steering Hose
    By karpetcm in forum General Help
    Replies: 3
    Last Post: 10-21-2010, 09:23 AM
  3. Help: ws6 power steering hose
    By Pony_Eater in forum Suspension and Handling
    Replies: 3
    Last Post: 08-13-2009, 07:46 PM
  4. Power Steering Hose Wanted
    By xpauliber in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 08-22-2006, 07:08 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •