Results 1 to 16 of 16

Power steering issues

This is a discussion on Power steering issues within the General Help forums, part of the LSx Technical Help Section category; ok so first i have a 98 ss and my power steering pump was shot making the whining noise when ...

  1. #1
    Junior Member 1998ss's Avatar
    Join Date
    Nov 2010
    Location
    california
    Posts
    23

    white
    1998 camaro ss

    Power steering issues

    ok so first i have a 98 ss and my power steering pump was shot making the whining noise when you press the gas, so i changed that and the hydrolic line and everything was good for about a week then it starts doin the same thing again becoming hard to turn making that annoying whining sound again, someone said it could be the PS cooler but i dunno, so does anyone have any advice?

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Did you flush out all the old fluid before installing the new pump? What kind of shape is your belt and tensioner in? If it is badly slipping that may also cause an issue when you apply pressure to the steering. Also, just because the pump is new does not mean that it isn't broken. Some of the reman pumps and stuff that you get at the parts store comes faulty, or fail soon after installation -- I can tell you this from experience.

  3. #3
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Is the fluid full? Is the fluid milky like its mixed with coolant?

  4. #4
    Junior Member 1998ss's Avatar
    Join Date
    Nov 2010
    Location
    california
    Posts
    23

    white
    1998 camaro ss

    the belt is only a couple months old i replaced it when i replaced the water pump and yes i flushed all the ps fluid and yes its milky like it got mixed with the coolant thats why i thought it could be the ps cooler

  5. #5
    Member DVrec21's Avatar
    Join Date
    Sep 2009
    Location
    PA
    Age
    28
    Posts
    202

    Pewter
    99 z28

    hmm... im having this same problem seems to be only when its cold out and i make a quick right turn. (Turning the wheel fast). uhm I have yet to check the fluid I'll do that today. My only .2cents really is that I heard bad things about the power steerin pumps for our cars.

    PS: I replaced mine last year, right around this time. Would suck if its going bad again.

  6. #6
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by 1998ss View Post
    the belt is only a couple months old i replaced it when i replaced the water pump and yes i flushed all the ps fluid and yes its milky like it got mixed with the coolant thats why i thought it could be the ps cooler
    I will take out the PS cooler and get a new hose without the PS option. Drain and flush all the fluid and put fresh one in it. Or get you a new PS cooler. hopefully the pump didn't went south.

  7. #7
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    Quote Originally Posted by 1998ss View Post
    the belt is only a couple months old i replaced it when i replaced the water pump and yes i flushed all the ps fluid and yes its milky like it got mixed with the coolant thats why i thought it could be the ps cooler
    So you PS fluid was milky. The only thing it could be the PS cooler leaking. To fix the problem you need to replace your PS cooler or eliminate it as mentioned above.

  8. #8
    Spaz is My Mentor SMWS6TA's Avatar
    Join Date
    Feb 2009
    Location
    Ugy Lower Corner of AL
    Posts
    10,509

    Navy Blue Metallic
    98 T/A w/a little mods...

    Like Cutlass stated it is leaking some where in the system. It could be a bad o ring in the high pressure line, another O ring is where the reservoir and the pump meet. If either are incorrect size or broke, air will leak in and can cause it to look milky.

  9. #9
    Junior Member 1998ss's Avatar
    Join Date
    Nov 2010
    Location
    california
    Posts
    23

    white
    1998 camaro ss

    would there be a problem if i eliminated the ps cooler? like it would over heat?

  10. #10
    Senior Member JayTA98's Avatar
    Join Date
    Dec 2007
    Location
    Orlando, FL
    Posts
    3,351

    Mean Black
    1998 Trans Am

    Quote Originally Posted by 1998ss View Post
    would there be a problem if i eliminated the ps cooler? like it would over heat?
    It will get hot but it won't affect the PS. It might whine a little bit when you try to move the wheel at a complete stop. My car never had one.

  11. #11
    Junior Member 1998ss's Avatar
    Join Date
    Nov 2010
    Location
    california
    Posts
    23

    white
    1998 camaro ss

    ok cool, how did u plug the 2 hose from the power steering?

  12. #12
    Moderator Cutlass's Avatar
    Join Date
    Apr 2008
    Location
    Madison, WI
    Posts
    6,996

    1999 Formula WS6 M6-sold
    2001 Silverado Z71

    You connect them together or get a hose for a car that doesn't have a ps cooler

  13. #13
    Junior Member
    Join Date
    Jan 2010
    Location
    Phoenix, AZ
    Posts
    77

    Red
    2000 Trans AM

    Just went thru this. Im not sure what cause what to fail first but i put a new ps pump on and it went out 3 weeks later. found out my cooler had fractured. I delete it, had a new ps intalled and than finally found out my rack was leaking. Now i have an all new ps system. If you want i would delete the shitty ps that came with our cars and install the after market one, they're way more efficient anyways. Our coolers heat the fluid more than cool them.

  14. #14
    TerribleTed TerribleTed's Avatar
    Join Date
    Jan 2010
    Location
    California-Sacramento-Roseville
    Posts
    145

    Red
    2000 Chevy Camaro Z28

    Quote Originally Posted by 1998ss View Post
    would there be a problem if i eliminated the ps cooler? like it would over heat?
    I had my PS cooler bypassed and it runs fine,,
    The PS pump does benefit from a PS Cooler in that if the fluid gets to hot in the PS Pump it will break down the internals faster then not having a PS cooler.

    I have capped my stocl PS cooler in/out ports and installed a separate fluid cooler (small radiator) in front of the main radiator and all shall be fine.

    I drive my car in summer heat that gets to 110 at times so a PS pump cooler of some sort is needed, else you can remove it and it will be fine, but wont last the years.

  15. #15
    Member LgndKller20073's Avatar
    Join Date
    Jul 2007
    Location
    Denver,CO
    Age
    28
    Posts
    455

    Arctic White
    2001 Firebird

    Has anybody ever replaced the PS pump on the V6? I believe mine went out today and needs to be replaced. How labor intensive is it and what will I need?

  16. #16
    Junior Member
    Join Date
    Jan 2010
    Location
    Phoenix, AZ
    Posts
    77

    Red
    2000 Trans AM

    Quote Originally Posted by LgndKller20073 View Post
    Has anybody ever replaced the PS pump on the V6? I believe mine went out today and needs to be replaced. How labor intensive is it and what will I need?
    I've never done the v6 but I imagine its relatively the same. the worst part is getting the damn pulley on and off. its best to have someone help hold it or have a very sturdy bench vice.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Anyone have power steering issues?
    By RedFenix_68 in forum Firebird / WS6
    Replies: 17
    Last Post: 03-29-2016, 04:46 PM
  2. Steering Issues
    By 79Firebird_99TA in forum Suspension and Handling
    Replies: 8
    Last Post: 07-10-2013, 06:37 PM
  3. Question: Power Steering, Manual Rack, Power Steering Pumps-etc
    By TerribleTed in forum General Help
    Replies: 2
    Last Post: 11-18-2010, 05:37 PM
  4. Question: Steering issues
    By 99TAguy75 in forum Suspension and Handling
    Replies: 9
    Last Post: 06-01-2010, 08:49 PM
  5. Power Steering/cooling issues...
    By RPO_WU8 in forum Camaro / SS
    Replies: 2
    Last Post: 08-18-2007, 10:03 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •