Results 1 to 15 of 15

power seats won't work

This is a discussion on power seats won't work within the General Help forums, part of the LSx Technical Help Section category; So I just put a set of TA seats out of a 97 in my 01 Camaro and when I ...

  1. #1
    Member transamgirl89's Avatar
    Join Date
    Dec 2009
    Location
    Dacula, Georgia, United States
    Posts
    555

    White
    2001 RS Camaro

    power seats won't work

    So I just put a set of TA seats out of a 97 in my 01 Camaro and when I got everything plugged in and installed I realized the air lumbar doesn't work. I press the buttons on the driver seat and all I hear is a clicking noise but no air going to the seats. I have the TA wiring harness installed. The driver seat is not power as far as moving back and forward that I know. There are 4 buttons on the side and I know 2 of them control the lumbar. Could someone please help me out. I'm pretty sure the air pump under the pass seat is clogged or has failed completely.

  2. #2
    Senior Member redbird555's Avatar
    Join Date
    Mar 2009
    Location
    pompano beach florida
    Age
    27
    Posts
    1,008
    2002 Camaro Z/28 Pewter

    can you ppost up a pic or a diagram on how you currently have everything wired? could be that the lumbar motor is shot tho

  3. #3
    Member transamgirl89's Avatar
    Join Date
    Dec 2009
    Location
    Dacula, Georgia, United States
    Posts
    555

    White
    2001 RS Camaro

    Quote Originally Posted by redbird555 View Post
    can you ppost up a pic or a diagram on how you currently have everything wired? could be that the lumbar motor is shot tho
    I'll post some pics later tonight.

  4. #4
    Senior Member INMY01TA's Avatar
    Join Date
    Jan 2006
    Location
    The great red state of MD.
    Posts
    5,755

    Black
    2001 Trans Am (sold)

    I had the air bladder in one of my seats go bad years ago. The dealership fixed it under warranty. Symptoms were just as you describe yours.

  5. #5
    Member transamgirl89's Avatar
    Join Date
    Dec 2009
    Location
    Dacula, Georgia, United States
    Posts
    555

    White
    2001 RS Camaro

    Quote Originally Posted by INMY01TA View Post
    I had the air bladder in one of my seats go bad years ago. The dealership fixed it under warranty. Symptoms were just as you describe yours.
    Is it something I can fix myself or do I have to take it to the stealership? Where is the bladder in the seat?

  6. #6
    Member transamgirl89's Avatar
    Join Date
    Dec 2009
    Location
    Dacula, Georgia, United States
    Posts
    555

    White
    2001 RS Camaro

    Also my passenger seat will not go back or forwards.

  7. #7
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    So the drivers side will go back and forward but the lumbar doesn't work, and the pass side doesn't do anything?

  8. #8
    Member transamgirl89's Avatar
    Join Date
    Dec 2009
    Location
    Dacula, Georgia, United States
    Posts
    555

    White
    2001 RS Camaro

    Quote Originally Posted by bluehawk2000 View Post
    So the drivers side will go back and forward but the lumbar doesn't work, and the pass side doesn't do anything?
    yep pretty much. Guess I got what I payed for......

  9. #9
    Senior Member bluehawk2000's Avatar
    Join Date
    Aug 2009
    Location
    Hickory, NC
    Age
    28
    Posts
    1,492

    midnight blue
    2000 trans am

    Quote Originally Posted by transamgirl89 View Post
    yep pretty much. Guess I got what I payed for......
    Did you check and make sure that all of the wiring was correct, and I would def say that the motor is most likely shot!!

  10. #10
    Member transamgirl89's Avatar
    Join Date
    Dec 2009
    Location
    Dacula, Georgia, United States
    Posts
    555

    White
    2001 RS Camaro

    Quote Originally Posted by bluehawk2000 View Post
    Did you check and make sure that all of the wiring was correct, and I would def say that the motor is most likely shot!!
    Yeah all the wiring is good. Guess I'll have to order a new motor. shit.

  11. #11
    Senior Member redbird555's Avatar
    Join Date
    Mar 2009
    Location
    pompano beach florida
    Age
    27
    Posts
    1,008
    2002 Camaro Z/28 Pewter

    like i said get some pics of the wiring up and we can all take a look could be something simple. did you test them before you bought them?

  12. #12
    Member transamgirl89's Avatar
    Join Date
    Dec 2009
    Location
    Dacula, Georgia, United States
    Posts
    555

    White
    2001 RS Camaro

    Quote Originally Posted by redbird555 View Post
    like i said get some pics of the wiring up and we can all take a look could be something simple. did you test them before you bought them?
    No they were already out of a wrecked WS6 when I got them. He said they worked when they were in the car.

  13. #13
    Electrical Engineer KMdef9's Avatar
    Join Date
    Jul 2009
    Location
    North of the Motorcity
    Posts
    2,611

    Custom Swirly Black
    2001 WS6 M6

    Maybe this could be some help?

    Electric seat

  14. #14
    Member Joels1's Avatar
    Join Date
    Jan 2008
    Location
    Dighton Massachusetts
    Posts
    219

    Black soon to be red
    2000 Trans am Ws6

    May sound stupid but is the lumbar air line under seat disconnected? couldn`t figure what the heck it was til I noticed the air lines.

  15. #15
    Member transamgirl89's Avatar
    Join Date
    Dec 2009
    Location
    Dacula, Georgia, United States
    Posts
    555

    White
    2001 RS Camaro

    Quote Originally Posted by Joels1 View Post
    May sound stupid but is the lumbar air line under seat disconnected? couldn`t figure what the heck it was til I noticed the air lines.
    Nah everything is hooked up. I took the passenger seat out over the weekend and couldn't see anything visually wrong with the wiring so it may be the motor or the air pump is clogged.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Using Firebird power seats in a Camaro
    By wildhare in forum General Help
    Replies: 5
    Last Post: 12-10-2009, 06:51 AM
  2. Power seats issue
    By MotorDogStar in forum Firebird / WS6
    Replies: 5
    Last Post: 08-13-2009, 08:19 PM
  3. Wanted: 4th gen seats power leather?
    By pyrows666 in forum Parts Wanted / Trade
    Replies: 0
    Last Post: 02-18-2008, 04:17 AM
  4. Help w/ Non-power seats
    By Xtreme03 in forum Firebird / WS6
    Replies: 0
    Last Post: 02-23-2006, 01:10 PM
  5. Question about power seats
    By slim_john in forum Firebird / WS6
    Replies: 4
    Last Post: 09-13-2005, 01:14 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •