Results 1 to 5 of 5

Power locks intermittently clicking on and off

This is a discussion on Power locks intermittently clicking on and off within the General Help forums, part of the LSx Technical Help Section category; Having a weird experience lately while driving on the freeway I can hear what sounds like my power locks going ...

  1. #1
    Junior Member
    Join Date
    Jul 2008
    Location
    Hawaii
    Posts
    3

    Light Pewter Metallic
    1999 Z28

    Power locks intermittently clicking on and off

    Having a weird experience lately while driving on the freeway I can hear what sounds like my power locks going on/off intermittently. Seems more noticeable when driving over rough roads. Has anyone experienced this?

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Are the locks actually moving? Could be a bad connection or a BCM on the fritz.

  3. #3
    Moderator 98TransAmWs-6's Avatar
    Join Date
    Apr 2010
    Location
    Fairfax, VA
    Posts
    3,596

    Black/ Silver
    98 TA WS6/ 01 C5 Corvette

    I have not had experience with this but one of the first things I would check are the connections to the locks to ensure they are seated correctly and not corroded. You could try cleaning the connections up if dirty. Next I would check out the body control module to ensure it is work properly and it is not surging causing the issue you described if it is indeed the power locks you hear.

    Others may have had this issue and hopefully will chime in.
    1998 Trans Am WS6 - Phantom
    421 CI LQ9, Tick Performance Custom Cam, TFS 255cc LS3 heads, Kooks 2" LT headers, Kooks 3" True Duals w/ high flow cats, FTP 104 lid, Speed Density Tune, 4" silicon tube, LS6 VCT, FAST 102 Intake, NW 102 TB, Oil Catch Can, SLP Bilstein Shocks w/ Vogtland Springs, CTS-V 4-piston Calipers w/C6 Z06 rotors, Stainless Steel Brake Lines, R1 concepts premium rotors, Hawk HP+ brake pads, VFN WSQ Hood, C5-R timing chain, SLP oil pump, E85 tune, Walbro 450 fuel pump, Deatschwerkz 95# injectors, Breathless performance headlights, Frost Tune, !HVAC.
    (Coming Soon) BMR DSL, UMI TQ Arm
    421 LQ9 14.8:1 on E85 Build/

  4. #4
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Agree on the BCM.

  5. #5
    Retired NOT tired SteveC's Avatar
    Join Date
    Jul 2005
    Location
    Poway, Ca
    Posts
    1,126

    SOM
    2001 Z28 (Sara)

    Quote Originally Posted by pajeff02 View Post
    Are the locks actually moving? Could be a bad connection or a BCM on the fritz.
    Quote Originally Posted by cammed goat View Post
    Agree on the BCM.
    Another vote for a faulty BCM, the BCM is located behind the glove box.

    You can purchase them on ebay, however they have to be programed to your VIN (I do not know how this is done), or else you will have to change your ignition keys.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: Power locks not working. 2000 T/A
    By M1K3H00D in forum Stereo and Electronics
    Replies: 3
    Last Post: 12-29-2014, 04:13 AM
  2. Power door locks deciding not to work
    By 98ls1t/a in forum General Help
    Replies: 6
    Last Post: 02-22-2010, 06:23 PM
  3. Help: Power Door Locks
    By jdnoyes in forum Stereo and Electronics
    Replies: 3
    Last Post: 11-18-2008, 02:27 PM
  4. Getting rid of the power windows and locks....
    By xinthenight in forum General Help
    Replies: 8
    Last Post: 08-25-2007, 11:18 AM
  5. Power Locks not working
    By firemedic0135 in forum General Help
    Replies: 2
    Last Post: 06-03-2007, 10:17 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •