Results 1 to 9 of 9

the plugs wasnt the problem

This is a discussion on the plugs wasnt the problem within the General Help forums, part of the LSx Technical Help Section category; i thought of i changed my plugs it would fix my problem. lack of power and when you step on ...

  1. #1
    Member mingo99z's Avatar
    Join Date
    Nov 2006
    Location
    casper wyoming
    Posts
    230

    pewter
    1999 camaro Z28

    the plugs wasnt the problem

    i thought of i changed my plugs it would fix my problem. lack of power and when you step on the gas it falls on it face. and i heard maby the EGR? can anyone tell me a little about this

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,576

    Black & Blue
    '02 WS.6 / '07 Suburban

    Any idea what your fuel pressure is? Have you changed the filter lately? Any codes?

  3. #3
    The Bandit Wesman's Avatar
    Join Date
    Apr 2006
    Location
    NJ
    Posts
    4,033

    SGM
    1998 Trans Am WS6

    No check engine light??

    As mentioned, could be fuel pump or clogged filter.

    Other possibilities include a bad sensor, such as the MAF.

  4. #4
    Member mingo99z's Avatar
    Join Date
    Nov 2006
    Location
    casper wyoming
    Posts
    230

    pewter
    1999 camaro Z28

    once in a great while the cheack eng light comes on but not for long whats the maf where is it located

  5. #5
    Senior Member Too Fast's Avatar
    Join Date
    Nov 2006
    Location
    Indianapolis
    Age
    54
    Posts
    5,170

    Black
    2000 WS6 6spd Hooker LT

    Easiest thing to do is clean the MAF first, buy some Mass Airflow Sensor cleaner at just about any auto parts store. Comes in a spray can about the size of a spray paint can. Your MAF is in the air intake, just behind the air filter housing and just ahead of the throttle body. Don't touch the wires inside the MAF when you do this, just use the spray. Take it off the car, clean it, then put it all together before you start the car.

    But your problem could be a fuel pressure problem, but if you have nothing to check that with it's not so easy. Pressure should be 58-62 with the 2 second prime when you turn the key on, engine off.

  6. #6
    Member mingo99z's Avatar
    Join Date
    Nov 2006
    Location
    casper wyoming
    Posts
    230

    pewter
    1999 camaro Z28

    yep it was the fuel filter dam it runs better then when i bought it

  7. #7
    Smiles for 9.5 Years cammed goat's Avatar
    Join Date
    Jan 2009
    Location
    Paterson/Ridgewood, NJ
    Posts
    11,474

    Phantom Black Metallic
    2004 GTO M6

    Cleaning the MAF gets my vote. With these engines, the MAF is the first thing to check IMO.

  8. #8
    Member JRENIGAR's Avatar
    Join Date
    Oct 2009
    Location
    arkansas
    Posts
    371

    red
    99 camaro

    Quote Originally Posted by mingo99z View Post
    yep it was the fuel filter dam it runs better then when i bought it
    Id still clean the maf If I were you. Chances are if the previous owner didnt change the fuel filter probably didnt clean the maf either...

  9. #9
    Senior Member
    Join Date
    Jan 2010
    Location
    texas
    Posts
    1,621

    silver
    2000 formula

    check pcv hose for leaks.......bet you have 1......or many

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. She def wasnt
    By bluehawk2000 in forum Multimedia Section
    Replies: 3
    Last Post: 01-11-2011, 11:50 AM
  2. Plugs and Wires Install...MSD wires E3 plugs
    By Demon_Z28 in forum External Engine
    Replies: 13
    Last Post: 05-04-2008, 04:53 AM
  3. last night wasnt my night!!
    By slpgto2004 in forum GTO
    Replies: 5
    Last Post: 10-29-2007, 07:03 AM
  4. if the new zo6 wasnt bad enough
    By ss~zoso~ss in forum Multimedia Section
    Replies: 6
    Last Post: 12-25-2006, 05:05 AM
  5. spark plugs, tr55 iridium or plane tr55 plugs?
    By got-a-ls1 in forum General Help
    Replies: 8
    Last Post: 02-09-2006, 07:06 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •