Results 1 to 3 of 3

Please help with my car!!

This is a discussion on Please help with my car!! within the General Help forums, part of the LSx Technical Help Section category; I have a 2000 model trans am. It has forged internals with a P1SC procharger with it. An external boost-a-pump ...

  1. #1
    Junior Member
    Join Date
    May 2011
    Location
    Cowen, WV
    Posts
    2
    2000 Trans Am

    Please help with my car!!

    I have a 2000 model trans am. It has forged internals with a P1SC procharger with it. An external boost-a-pump with 61lb injectors. While I am driving the car and it is over 3k rpms and I stomp the gas it's like it will completely shut of, or its like the fuel shuts off then back on.
    If I ease onto the throttle it does ok, but as soon as I get past half throttle it will start cutting out. If anyone has any ideas please let me know. I would greatly appreciate it!!!!

  2. #2
    Super Moderator
    pajeff02's Avatar
    Join Date
    Feb 2009
    Location
    Mansfield, PA
    Posts
    21,567

    Black & Blue
    '02 WS.6 / '07 Suburban

    Have you checked the basics? Fuel pressure, changed the fuel filter, SES codes, charging system voltage?

  3. #3
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    agreed....start with fuel pressure.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •