Results 1 to 4 of 4

Please Help!!!!

This is a discussion on Please Help!!!! within the General Help forums, part of the LSx Technical Help Section category; Ok I have a 98 z28 camaro with long tube headers, cat delete, off road y pipe, magnaflow cat back, ...

  1. #1
    Junior Member
    Join Date
    May 2008
    Location
    Kaysville Utah
    Posts
    6

    Silver
    1998 Z28 Camaro

    Please Help!!!!

    Ok I have a 98 z28 camaro with long tube headers, cat delete, off road y pipe, magnaflow cat back, electric cut out, k&n intake, ported throttle body, ls6 intake with egr adapter, granitelli maf, and slp underdrive pulley. I had everything done but the intake, manifold, throttle body, electric cut out and underdrive pulley already done when i bought the car and it run amazing. After I did those five things the car actually got slower and I also got a check engine light on. I then ran the codes and came up with P0101 which is a MAF code, P0108 which is a MAP code, and P0121 which is tps. I have replaced the tps and put the stock maf on so I am pretty sure that its not the actual sensors and it kind of needs a good tune now. I am wondering if you think a tune can help me out with those things or if there are some other things i can try or if anyone has even ever heard of something like this. I am also kind of curious what everyone thinks i might put down to the rear wheels once i get this running the way it should. Well at this point any help would be great. Thank you all so much for taking some time out of your day to help me its very awsome of you.

  2. #2
    Member
    Join Date
    Jun 2007
    Location
    winfield, wv
    Posts
    253

    Silver
    2000 3.8 liter camaro

    ive had the mass air flow code...and once i cleaned it, i noticed a huge difference.

  3. #3
    Junior Member
    Join Date
    May 2008
    Location
    Kaysville Utah
    Posts
    6

    Silver
    1998 Z28 Camaro

    I have cleared the damn thing a couple of times and even change the maf to a different one but the thing still throws a code. But I am glade you noticed a difference i cant wait to find out what this is and get my car back to where it should. My car is now slower then when i got it with just exhaust it sucks.

  4. #4
    Member
    Join Date
    Jun 2007
    Location
    winfield, wv
    Posts
    253

    Silver
    2000 3.8 liter camaro

    ive been in the same situation...hope ya get it back.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •