Results 1 to 3 of 3

P0121.. Throttle Position Sensor A Circuit Range/Performance

This is a discussion on P0121.. Throttle Position Sensor A Circuit Range/Performance within the General Help forums, part of the LSx Technical Help Section category; Ok I have read up to the best of my ability on the problem and have done a few things ...

  1. #1
    Slower Than a 3rd Gen juiced99ws6's Avatar
    Join Date
    Aug 2005
    Location
    Cape Coral, FL
    Age
    33
    Posts
    3,097

    Mystic Teal
    99 Trans Am & 01 CBR 929

    P0121.. Throttle Position Sensor A Circuit Range/Performance

    Ok I have read up to the best of my ability on the problem and have done a few things and cannot figure out what the hell is causing it. I have read symptoms that people have had and said that they experience a surging idle from it and that the car will bog down real bad to the point of barely running and then pick itself up again and go like normal. My car is doing both of those and also is getting horrible gas mileage which again is a symptom so the problem is definatly there is what im getting at. This is the only code I get and I have already replaced the Throttle Position Sensor. I have also checked for continuity to groud and checked for the 5 volt referance signal and everything is there. Also on my Predator I checked the TPS after installing the new one a few days back and the throttle angle seems to register from 0-100% just fine going slowly or quickly. Does anyone have any other ideas on what I may be able to check.

  2. #2
    Slower Than a 3rd Gen juiced99ws6's Avatar
    Join Date
    Aug 2005
    Location
    Cape Coral, FL
    Age
    33
    Posts
    3,097

    Mystic Teal
    99 Trans Am & 01 CBR 929

    ok it is now paired with a P0122 Throttle position sensor circuit low input



    Edit:
    Ok I am going out on a limb here and saying that I just tripped that code when I was checking wires since I had the TPS disconnected with the car on so I just need advise about the first problem for now if possible
    Last edited by juiced99ws6; 09-05-2007 at 06:23 PM.

  3. #3
    Slower Than a 3rd Gen juiced99ws6's Avatar
    Join Date
    Aug 2005
    Location
    Cape Coral, FL
    Age
    33
    Posts
    3,097

    Mystic Teal
    99 Trans Am & 01 CBR 929

    Ok I have done tons of reading on this now, I guess I finally lucked out and found a good batch of links for this topic and it seems to me that it could be a tuning issue that wasnt resolved in my initial dyno tune. Hopefully I can have it fixed relatively easy tomorrow. I will report back on here afterwards and let everyone know if it fixes the problem.
    Last edited by juiced99ws6; 09-07-2007 at 08:57 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Question: Need to change Throttle Position Sensor
    By LS1BL in forum General Help
    Replies: 13
    Last Post: 02-20-2013, 01:02 PM
  2. Question: Bad throttle position sensor?
    By clg82 in forum Firebird / WS6
    Replies: 7
    Last Post: 07-29-2010, 01:10 PM
  3. Help: Installing a throttle position sensor
    By 454transam in forum External Engine
    Replies: 4
    Last Post: 06-03-2010, 12:43 AM
  4. Throttle Position Sensor Voltage
    By SilverFish in forum General Help
    Replies: 1
    Last Post: 08-30-2008, 01:33 PM
  5. throttle position sensor
    By dpinson in forum Nitrous
    Replies: 6
    Last Post: 09-24-2007, 02:22 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •