Results 1 to 8 of 8

P0101 & p0155?

This is a discussion on P0101 & p0155? within the General Help forums, part of the LSx Technical Help Section category; truck is throwin these 2 codes and running like crap. a/f is all over the place. i know the first ...

  1. #1
    Junior Member
    Join Date
    May 2011
    Location
    TEXAS
    Posts
    7
    2001 Silverado

    P0101 & p0155?

    truck is throwin these 2 codes and running like crap. a/f is all over the place. i know the first has to do with the maf and the second is o2. i just replaced the maf and that didn't seem to help any. where should i go from here? thanks

  2. #2
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    check your cats to make sure they aren't clogged...

  3. #3
    Junior Member
    Join Date
    May 2011
    Location
    TEXAS
    Posts
    7
    2001 Silverado

    no cats, just shells

  4. #4
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Might not be the answer...but on the F-body the MAF and 02's (couple more things for M6) are on the same ENG SEN fuse circuit. If yours is the same something easy to check first.

  5. #5
    Junior Member
    Join Date
    May 2011
    Location
    TEXAS
    Posts
    7
    2001 Silverado

    which fuse is this? i didn't see an eng ses fuse in the fuse box.

  6. #6
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    On F-bodies ENG SEN = Engine Sensor. Look at the fuse into in your owners manual, should list everything on the circuit if it's there. Ours is under the hood.

  7. #7
    Junior Member
    Join Date
    May 2011
    Location
    TEXAS
    Posts
    7
    2001 Silverado

    all the engine managment fuses are good. i'll check again for any vacuum leaks again this afternoon but after that, i'm stumped..

  8. #8
    Junior Member rbws6's Avatar
    Join Date
    Nov 2010
    Location
    Nederland, Texas
    Posts
    25

    Red
    1999 WS6

    air filter

    Make sure your air filter is clean. I have Volant intake with K&N's and had the same codes popping. My car however was not running too bad. I cleaned the filters and the code disappeared (for now). Just a suggestion

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: P0155 & P0135 codes
    By fna7302 in forum Computer & Tuning
    Replies: 3
    Last Post: 04-09-2015, 09:07 PM
  2. p0101?
    By CHEVY211 in forum General Help
    Replies: 6
    Last Post: 06-14-2011, 05:35 PM
  3. low idle and p0155 code
    By slpdablueZ28 in forum General Help
    Replies: 4
    Last Post: 04-06-2010, 04:01 PM
  4. P0101 - maf?
    By turbojimmy in forum General Help
    Replies: 6
    Last Post: 03-27-2010, 09:47 AM
  5. Question: code P0101
    By pmolina0436 in forum GTO
    Replies: 3
    Last Post: 04-24-2009, 09:30 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •