Page 2 of 4 FirstFirst 1234 LastLast
Results 21 to 40 of 71

Overheating problem

This is a discussion on Overheating problem within the General Help forums, part of the LSx Technical Help Section category; Dear god coolant in the oil! I hope you have main and rod bearings on order...

  1. #21
    Member TA98's Avatar
    Join Date
    Mar 2009
    Location
    Maryland
    Posts
    863

    Black
    1998 Trans Am

    Dear god coolant in the oil! I hope you have main and rod bearings on order

  2. #22
    Member herculesrider1's Avatar
    Join Date
    Apr 2008
    Location
    TX
    Posts
    504

    Red
    '00 TransAm RamAir WS6 M6

    That's probably why it's running sluggish...the anti-freeze has burnt off and deposited itself on the plugs. Sad that someone who is going to UTI has told someone to add anti-freeze to their oil. May as well put WD-40 on your brakes to stop the squeeling, or put brake fluid in the oil to help you slow down quicker.....and I use to think UTI was a place of higher learning....probably is....the students must be HIGH to give this type of advice!!!!!!

  3. #23
    Senior Member bigrondownhiller's Avatar
    Join Date
    Feb 2006
    Location
    Orange County, NY
    Age
    42
    Posts
    2,674

    Black
    1996 Camaro Z28 vert

    Quote Originally Posted by herculesrider1 View Post
    That's probably why it's running sluggish...the anti-freeze has burnt off and deposited itself on the plugs. Sad that someone who is going to UTI has told someone to add anti-freeze to their oil. May as well put WD-40 on your brakes to stop the squeeling, or put brake fluid in the oil to help you slow down quicker.....and I use to think UTI was a place of higher learning....probably is....the students must be HIGH to give this type of advice!!!!!!
    I would hope he didn't learn that at uti. You can teach someone the right way to do something but that doesn't always mean they will do it right.

  4. #24
    Member
    Join Date
    Feb 2008
    Location
    NEW JERSEY
    Posts
    814

    PEWTER
    2001 TRANS AM WS6

    remember kids always check your muffler bearings for wear around the blinker flange

  5. #25
    LSwut tep98ws6's Avatar
    Join Date
    Jun 2009
    Location
    Saint Louis, MO
    Posts
    1,705

    Arctic White & Black
    '98 WS6 M6 - SWAPTIME!

    Quote Originally Posted by DIRTY JERZY View Post
    remember kids always check your muffler bearings for wear around the blinker flange
    don't forget the canooder valve and flux

  6. #26
    Member herculesrider1's Avatar
    Join Date
    Apr 2008
    Location
    TX
    Posts
    504

    Red
    '00 TransAm RamAir WS6 M6

    and always use the skyhook when pulling your motor, oh and almost forgot....don't let the ohms run out of your battery when you open your hood....

  7. #27
    Senior Member 35thAnniZ28's Avatar
    Join Date
    Mar 2007
    Location
    Texas
    Posts
    1,809

    eating bulldog
    son of biscuit

    Quote Originally Posted by silverWS.6 View Post
    Okay WAIT WAIT WAIT..... Let me get this straight, you actually poured like Anti-Freeze/Coolant into your oil? Like where you normally put oil in, you put half a gallon of 50/50 in there? And you ran it like that for 1 month?

    If the answer to all those questions is "YES" then your engine is beat sir. Go beat the living shit out of your friend now...
    I think we should beat the shit outta him for not thinking

  8. #28
    Member herculesrider1's Avatar
    Join Date
    Apr 2008
    Location
    TX
    Posts
    504

    Red
    '00 TransAm RamAir WS6 M6

    Krazy Kamaro,
    Did you replace the tstat? How'd it go? Any issues?

  9. #29
    Member TA98's Avatar
    Join Date
    Mar 2009
    Location
    Maryland
    Posts
    863

    Black
    1998 Trans Am

    try and flush the system too, you might have gunk built up in it somewhere

  10. #30
    Junior Member
    Join Date
    Oct 2009
    Location
    Austin
    Posts
    10

    Teal
    2002 Camaro

    I havent gotten around to replacing anything, the car doesnt get too hot when i drive it because work is so close, ill try and pick up the tstat sometime today.

  11. #31
    Moderator 35th-ANV-SS's Avatar
    Join Date
    Oct 2008
    Location
    Wherever life takes me
    Posts
    12,465

    Red
    02 35th LE Camaro SS

    You are still driving it around with coolant in the oil?

  12. #32
    Veteran Hi-Po's Avatar
    Join Date
    Nov 2005
    Location
    Florida
    Posts
    10,461

    Black
    1999 TA WS.6

    Im still lost about putting coolant in the oil. Have yet to hear that one. You really need to drain the oil out, run some cheap oil in it. Get it hot, drain that out and put good OIL in the OIL cap. Your bearing are hating what's in there now.

  13. #33
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    Ok this just hurts to read. omg...this seriously is hurting my head reading this. I'm about to blow up.

    Change the damn oil or take the car to your dad and have him pay someone to change the thermostat and oil.

  14. #34
    Member herculesrider1's Avatar
    Join Date
    Apr 2008
    Location
    TX
    Posts
    504

    Red
    '00 TransAm RamAir WS6 M6

    Krazy, Maybe you don't realize the gravity of the situation. You have installed a liquid into your crankcase that was never designed to be installed there. You have drastically decreased your viscosity level of your oil, drastically decreased the oils ability to insulate and keep a metal to metal scenario from developing. Do you have $10 thousand dollars for a new engine just laying around? Are you ready to have your vehicle down 'permanently' while you have to have a rebuild? Spend $40 for an oil change like yesterday and make changing the tstat your top priority. At first I was highly peeved at the UTI person instructing you to add anti freeze to your oil, now I'm beginning to wonder if perhaps you have a few screws loose. The heart of your vehicle is at very high risk, but you act like it's nothing. Catch some snap dude, wake up and smell the coffee......I would not sleep til all these things were done, but that's just me....I love my T/A.

  15. #35
    LSX whore allbaugh_04's Avatar
    Join Date
    Mar 2007
    Location
    Omaha, NE
    Age
    32
    Posts
    5,895

    Pewter
    2000 Z28 Camaro

    Well put, stop driving the car and get it fixed...NOW

  16. #36
    Junior Member
    Join Date
    Oct 2009
    Location
    Austin
    Posts
    10

    Teal
    2002 Camaro

    Alright, I didnt realize something could happen to the engine here. Ill take it to a shop tomorrow morning and have them replace the oil and tstat then let you guys know how it went.

  17. #37
    Yeah baby! Yeah! silverWS6's Avatar
    Join Date
    May 2009
    Location
    okc
    Posts
    2,571

    Silver 2002 WS.6
    Red 1989 Formula



    This has to be a joke

  18. #38
    Junior Member
    Join Date
    Oct 2009
    Location
    Austin
    Posts
    10

    Teal
    2002 Camaro

    So I took it to a shop and they replaced the oil and tstat in about an hour. I got the car back and it has one of the worst ticking noises ive ever heard coming from it. I talked to the manager of the shop and he claims they didnt do anything to it, but it was nothing like this when i dropped it off. I got it home and they clearly scraped off the sealant around the water pump too. The car runs like shit and I dont know what to do about this. How can I go about brining this up with the shop and making them fix it?

  19. #39
    LSwut tep98ws6's Avatar
    Join Date
    Jun 2009
    Location
    Saint Louis, MO
    Posts
    1,705

    Arctic White & Black
    '98 WS6 M6 - SWAPTIME!

    Quote Originally Posted by Krazy Kamaro Kid View Post
    So I took it to a shop and they replaced the oil and tstat in about an hour. I got the car back and it has one of the worst ticking noises ive ever heard coming from it. I talked to the manager of the shop and he claims they didnt do anything to it, but it was nothing like this when i dropped it off. I got it home and they clearly scraped off the sealant around the water pump too. The car runs like shit and I dont know what to do about this. How can I go about brining this up with the shop and making them fix it?
    just bring it up. it's your car, if it didn't sound like that before then tell them that. BUT if you brought up the fact that you put coolant in the oil, it may be all on you since you aren't supposted to put coolant in the oil and that would all be operator error. im surprised it just now started ticking.

  20. #40
    Member NoscamaroSS's Avatar
    Join Date
    Oct 2008
    Location
    Durant, Okla
    Posts
    737

    NBM
    2002 Camaro

    If anybodys responsible for fixing your car, then it is your asshat friend who told you to put antifreeze in your oil! Or maybe you, for listening to your dumbass friend!
    02 Camaro
    PRC Stg 2.5 5.3's, Futral F14, PP Typhoon intake, True duals, Performabuilt tranny, & 3500 convertor, HSW plate kit.
    *Old Time* 10.90@ 125mph

Page 2 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. LS1 - overheating
    By kris in forum General Help
    Replies: 19
    Last Post: 07-22-2014, 01:52 PM
  2. 98 TA overheating????
    By 98RedTA in forum Firebird / WS6
    Replies: 13
    Last Post: 03-22-2014, 01:39 PM
  3. Help: Overheating Lt1
    By Red 93 Z in forum LT1
    Replies: 5
    Last Post: 06-26-2009, 12:08 PM
  4. Overheating Problem!!!
    By Arlis03 in forum V6
    Replies: 3
    Last Post: 12-30-2007, 11:17 PM
  5. Car overheating need help!!!!!!!!!
    By ramair1999 in forum External Engine
    Replies: 11
    Last Post: 10-30-2006, 06:01 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •