Results 1 to 4 of 4

Overheating help question.

This is a discussion on Overheating help question. within the General Help forums, part of the LSx Technical Help Section category; Hi, I have a 99Z28/LS1 that just recently developed an issue. My car has 125,000 miles on it and it ...

  1. #1
    Junior Member
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4

    Navy
    1999 Camaro Z28

    Unhappy Overheating help question.

    Hi, I have a 99Z28/LS1 that just recently developed an issue. My car has 125,000 miles on it and it threw the P0405 code which is something about the EGR valve and voltage. At the same time this happened, my car has started to run hot. It would always warm up to 210 on the gauge and stay there, but at the same time the EGR issue happend, it would go to 210 for awhile, but then (usually when on the freeway) start creeping higher and fluctation some between 230-250 and never going back to 210.

    I disconnected the EGR altogether but the temps still rise the same way.
    Any ideas ? I thought maybe the EGR is sticking open even when closed, but I haven't really noticed any kind of rough idle/running conditions. Just the temps.

    I thought the cooling system thermostat may have stuck closed, but that would be ruled out by the car heating to 210 and staying there awhile before creeping past that (usually takes 10 min at 210 before it goes over)

    Thanks for any insight.
    Car is pretty much stock as far as upgrades.

  2. #2
    Member Goldcuffs's Avatar
    Join Date
    Aug 2008
    Location
    Florida
    Posts
    411

    Silver
    2000 Trans Am

    do you know if the fans are running?

  3. #3
    Junior Member
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4

    Navy
    1999 Camaro Z28

    I believe so - aren't there 2 fans - I know when I turn the car off, I can still hear them going - which must be a safeguard when it runs over a certain temp ? I say that because I don't think - and I've never had my car - keep the fans running for awhile AFTER I turned the car off. Maybe 1 fan is out and the other can't cool it enough ?

    The cooling system has never been flushed - maybe there's build up or something.

  4. #4
    Junior Member
    Join Date
    Sep 2008
    Location
    Ohio
    Posts
    4

    Navy
    1999 Camaro Z28

    I replaced the thermostat last night and that fixed it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 98 TA overheating????
    By 98RedTA in forum Firebird / WS6
    Replies: 13
    Last Post: 03-22-2014, 01:39 PM
  2. overheating
    By kenny johns in forum General Help
    Replies: 5
    Last Post: 03-24-2010, 10:20 AM
  3. General Overheating question
    By AKA Speedy in forum General Help
    Replies: 6
    Last Post: 02-21-2010, 04:08 PM
  4. overheating!! please help
    By CamaroKidZ28 in forum General Help
    Replies: 12
    Last Post: 10-05-2009, 05:43 PM
  5. Always something.. Car overheating.
    By juiced99ws6 in forum General Help
    Replies: 8
    Last Post: 07-13-2007, 02:40 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •