Page 4 of 4 FirstFirst 1234
Results 61 to 76 of 76

oil pressure question

This is a discussion on oil pressure question within the General Help forums, part of the LSx Technical Help Section category; alright, cool.. how do i get that checked out to make sure its right? just take it to a mechanic?...

  1. #61
    Junior Member 02TransSD's Avatar
    Join Date
    Jul 2007
    Location
    San Diego, CA
    Posts
    98

    Burgandy
    2002 Pontiac Trans Am

    alright, cool.. how do i get that checked out to make sure its right? just take it to a mechanic?

  2. #62
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    I personally wouldnt even worry about it. I would only be concerned if it was extremely low pressure. What weight oil did you put in your car? If its higher then 5-30 then that can make the pressure go up.

  3. #63
    Junior Member 02TransSD's Avatar
    Join Date
    Jul 2007
    Location
    San Diego, CA
    Posts
    98

    Burgandy
    2002 Pontiac Trans Am

    the car was serviced by the dealership just before i bought it so i am unsure on the oil weight. Since i bought i have only put not even 2000 miles on the car. I am going to take it in here soon. Any recommendations on the oil weight or anything like that, that i should be using?

  4. #64
    Miss Pennsylvania ls1blackbeauty98's Avatar
    Join Date
    Aug 2005
    Location
    West Cheter, PA
    Posts
    2,851

    '98 Black Gone :(
    01 WS6 Midnight Blue

    Quote Originally Posted by 02TransSD View Post
    the car was serviced by the dealership just before i bought it so i am unsure on the oil weight. Since i bought i have only put not even 2000 miles on the car. I am going to take it in here soon. Any recommendations on the oil weight or anything like that, that i should be using?
    i use 5w30, my oil pressure is always around 20 at idle and goes up to 40 when accel...just throwin that info in there

  5. #65
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    If you live in a very hot area like Florida I would go with 10w-30. 5w-30 if you live anywhere else. My car has 70,000 miles idles at 40psi and goes to 50-55psi while driving. But just to ease your mind-even 80 oil pressure would be find. I wouldnt worry one bit. Dont lose any sleep over it man. Youre fine.

  6. #66
    Junior Member 02TransSD's Avatar
    Join Date
    Jul 2007
    Location
    San Diego, CA
    Posts
    98

    Burgandy
    2002 Pontiac Trans Am

    Well i live in Socal, So we get out hot spurts but in my part of town i still get the cool ocean breeze ever so often so usually hardly ever over 90-95..thanks for the input and help guys

  7. #67
    LS1 or bust b.lee's Avatar
    Join Date
    Aug 2006
    Location
    SE, Michigan
    Posts
    701

    Blue
    00 Z28 6Spd / 03 Z71 LT

    Quote Originally Posted by 02TransSD View Post
    my 02 T/A is usually running around the 60-80 range on a majority of my driving. Even when i am able to keep it at 65. I keep getting afraid that im running to high of a pressure for when i am just crusin
    just make sure its not overfilled with oil.
    or using to heavy of an oil.

  8. #68
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    Yea could be overfilled or too heavy oil used by mistake if you are taking it to get the oil changed. Those guys fuck up thats for sure. They forgot to put oil in my sisters car when they did a oil change-its sad but true.

  9. #69
    Junior Member 02TransSD's Avatar
    Join Date
    Jul 2007
    Location
    San Diego, CA
    Posts
    98

    Burgandy
    2002 Pontiac Trans Am

    Quote Originally Posted by BREAKxNECKxSPEED View Post
    Yea could be overfilled or too heavy oil used by mistake if you are taking it to get the oil changed. Those guys fuck up thats for sure. They forgot to put oil in my sisters car when they did a oil change-its sad but true.
    how?? lol. i cant picture someone being so dumb at their job that they can forget to put oil in a car while doing and oil change...

  10. #70
    LS1 or bust b.lee's Avatar
    Join Date
    Aug 2006
    Location
    SE, Michigan
    Posts
    701

    Blue
    00 Z28 6Spd / 03 Z71 LT

    Quote Originally Posted by 02TransSD View Post
    how?? lol. i cant picture someone being so dumb at their job that they can forget to put oil in a car while doing and oil change...
    Chit happens, thats all I can think.
    I hope they fixed the car after the engine blew? how did that story work out?

  11. #71
    Impounded
    Join Date
    Mar 2007
    Location
    Milwaukee
    Age
    30
    Posts
    2,159

    Red
    2000 Trans Am

    This just started the like 2 days ago, this only happens when the car has been driven for more than a hour but when its been running for a while it stays just above 40psi and then moves from like 41 to 45 and then back down again it just keeps moving a little. Only at idle when drving its moves like normal but at idle it moves slightly about 4-5psi. Anyone know why this is i heard it could be low oil and it picking it up but the oil is fine about 6-6.5 quarts still.

  12. #72
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    Quote Originally Posted by 2000T/A Guru View Post
    This just started the like 2 days ago, this only happens when the car has been driven for more than a hour but when its been running for a while it stays just above 40psi and then moves from like 41 to 45 and then back down again it just keeps moving a little. Only at idle when drving its moves like normal but at idle it moves slightly about 4-5psi. Anyone know why this is i heard it could be low oil and it picking it up but the oil is fine about 6-6.5 quarts still.
    I would try to put in a new oil pressure sending unit. Alot cheaper and smarter then just assuming the oil pump is bad. The sending unit is located way in the back of the engine/drivers side/on top. Part is 30-40 bucks I believe. I had the same problem as you and this fixed it.

  13. #73
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    Quote Originally Posted by b.lee View Post
    Chit happens, thats all I can think.
    I hope they fixed the car after the engine blew? how did that story work out?
    Okay what happened was the jiffey lube guy put a quart or 2 of engine cleaner in the car and forgot to drain it and put fresh oil in the car. So the car ran for about 26 days on a few quart of engine cleaner. When my dad checked my sisters oil - there was none. My dad put oil in it and the car has run perfect ever since. I dont understand it. The car is a 1998 Mercury Gran Marquis 4.6 V8. I still dont understand how it didnt blow. My dad says he always put synthetic oil in her car. My dad was in the hospital so my sister took it to a oil change place for the first time and this happened. The oil change place went out of business soon after this happened.

    * you have to be a dumb MF not to put oil back in a car when changing oil.

  14. #74
    LS1 or bust b.lee's Avatar
    Join Date
    Aug 2006
    Location
    SE, Michigan
    Posts
    701

    Blue
    00 Z28 6Spd / 03 Z71 LT

    true that. lol.
    00 Z28 M6 T-tops
    00 SS A4 T-tops (Sold)
    99 Corvette M6 (Sold)
    98 Z28 A4 Coupe (Sold)
    98 Z28 A4 T-tops (Sold)

  15. #75
    Junior Member sunstylez's Avatar
    Join Date
    Sep 2007
    Location
    Trenton, Georgia
    Posts
    18

    Black
    1998 Pontiac Trans AM

    I would personally buy a cheap $15.00 Oil Pressure gauge to check the levels. It might not even be the sender.. Worst case scenario your main bearings are destroyed.. But a lot of LS1's are known for their oil pumps to go out.. Causing extensive damage if not destroying it. So.. If you want to play it safe... Check it out.. Replace the sender if it's the case.. (usually if it's the sender your oil gauge will be erratic). If it's the pump.. Which in my TA I've already replaced the pump for insecurity issues.. Get it taken care of, or you will regret it. I'd recommend the SLP oil pump.

  16. #76
    I lika da Chevy's LETHALxLS1's Avatar
    Join Date
    Oct 2006
    Location
    USA
    Posts
    5,329

    BLACK
    Z/28 LS1

    ^ I had the sending unit go bad in my car and it read just like it would read normally except very low pressure. It would read 20psi when it was cold and 10psi when it got hot. I put a new one in and it reads 60 psi cold and 50 psi hot.

Page 4 of 4 FirstFirst 1234

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Oil temp/pressure question.
    By Young11b in forum Internal Engine
    Replies: 11
    Last Post: 08-29-2012, 01:13 AM
  2. Oil Pressure Question
    By BradZ01 in forum General Help
    Replies: 1
    Last Post: 10-01-2009, 10:48 PM
  3. Oil Pressure Question
    By VENOMIZED03 in forum Internal Engine
    Replies: 11
    Last Post: 01-26-2008, 12:05 AM
  4. oil pressure question
    By gsxrsteve in forum General Help
    Replies: 1
    Last Post: 07-15-2007, 12:54 AM
  5. oil pressure question
    By gsxrsteve in forum General Help
    Replies: 2
    Last Post: 07-13-2007, 05:44 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •