Results 1 to 4 of 4

Oil needle acting weird.

This is a discussion on Oil needle acting weird. within the General Help forums, part of the LSx Technical Help Section category; Everytime i brake the oil pressure goes down and its in the red, then the cluster lights up and says ...

  1. #1
    Junior Member Zeroskater1028's Avatar
    Join Date
    Aug 2005
    Location
    La Puente, Ca
    Age
    29
    Posts
    64

    Red
    96' Camaro SS M6

    Oil needle acting weird.

    Everytime i brake the oil pressure goes down and its in the red, then the cluster lights up and says check guages. If i rev my engine before i stop the pressure goes back up. All i wanna know is why does it go down so fast and what can I do to stop it.

  2. #2
    Member LS1Z28's Avatar
    Join Date
    Aug 2005
    Location
    Lake Elsinore,CA
    Posts
    280
    Camaro

    Have you checked your oil level?

  3. #3
    Junior Member Zeroskater1028's Avatar
    Join Date
    Aug 2005
    Location
    La Puente, Ca
    Age
    29
    Posts
    64

    Red
    96' Camaro SS M6

    Yea everythings at their correct level. Ive checked all the fluids and nothing.

  4. #4
    Member redz284u's Avatar
    Join Date
    Aug 2005
    Location
    Littlerock, CA
    Age
    40
    Posts
    205

    Red
    1998 SS

    if u have messed with your intake manifold, u probably did what i did and thats messed up the oil pressure sensor....after removing my intake manifold my needed started jumping and at times not working, and seemed it didnt work more when i came to stop....took intake off again thinking i mustave not pluged something back in, and there it was, broken ......take a look, maybe just old and went out....

    my bad..just noticed, u have a lt1......right?????....this might not apply to u, dunno...
    98SS A4, TSP CLR LID, LS6 INTAKE, BMR SFC/STB/ LWR CNTRL & TRQ ARMS, KYB ADJ., HOTCHKINS SWAY BARS, MSD WIRES, JETHOT LT/ORY, MAGNAFLO CATBACK, EIBACH PROKIT, 19" TSW WHEELS, PERMA COOL TRANY COOLER.

    257.8 hp (MUSTANG-DYNO) b4 ANY MODS.
    13.6 1/4 mile

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I'm a Oil Junkie
    By Sarge in forum General Help
    Replies: 1356
    Last Post: 06-30-2016, 12:20 PM
  2. oil change light acting retarded?
    By madhouse in forum General Help
    Replies: 7
    Last Post: 11-28-2005, 08:36 AM
  3. No oil supply to heads!
    By hissin'98 in forum Internal Engine
    Replies: 10
    Last Post: 11-16-2005, 01:50 AM
  4. winter V6 oil question
    By quicky06 in forum General Help
    Replies: 5
    Last Post: 10-23-2005, 07:35 PM
  5. blinker switch acting weird
    By myk02k in forum General Help
    Replies: 3
    Last Post: 10-15-2005, 09:23 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •