Page 1 of 2 12 LastLast
Results 1 to 20 of 21

Oil low question (help)

This is a discussion on Oil low question (help) within the General Help forums, part of the LSx Technical Help Section category; Ok, I got my oil changed at the dealership ( I am not a mechanic) and I always run mobil ...

  1. #1
    Member knightryda01's Avatar
    Join Date
    May 2008
    Location
    Michigan
    Posts
    710

    midnight blue
    2000 Pontiac ram air ws-6

    Oil low question (help)

    Ok, I got my oil changed at the dealership ( I am not a mechanic)
    and I always run mobil 1 in my vehicles.... Never let me down yet.

    After reading the threads on here about the ls1 motors being known to lose oil and whatnot I decided to check mine. Came in at the add level on the dipstick. So I'm a quart low?

    How much oil does it take to satisfactory fill up the motor? I have heard of people running an extra quart. I want to use just enough oil and be safe.

    What weight does GM reccomend? I am guessing they used 5-30 at the dealership.

    Also If I am a quart low would it be a good guess that they only filled it with 5 quarts to begin with?

  2. #2
    Member knightryda01's Avatar
    Join Date
    May 2008
    Location
    Michigan
    Posts
    710

    midnight blue
    2000 Pontiac ram air ws-6

    c'mon guys I need some quick help here...

  3. #3
    someday joejenkinsglass's Avatar
    Join Date
    Oct 2006
    Location
    Iowa
    Age
    40
    Posts
    1,120

    green
    98 formula

    5 1/2 quarts for an ls1 thats all you need. don't use more the extra oil can actually wind around the crankshaft.

  4. #4
    Asphault Cowboy dphillips1984's Avatar
    Join Date
    May 2008
    Location
    Mineola,Texas
    Posts
    61

    Arctic White
    2000 Trans Am WS6

    fill it until the dipstick shows full......

  5. #5
    Member Cronex's Avatar
    Join Date
    Jul 2007
    Location
    Philadelphia, PA
    Posts
    367

    Pewter
    2001 Trans Am #693

    Quote Originally Posted by knightryda01 View Post
    Ok, I got my oil changed at the dealership ( I am not a mechanic)
    and I always run mobil 1 in my vehicles.... Never let me down yet.

    After reading the threads on here about the ls1 motors being known to lose oil and whatnot I decided to check mine. Came in at the add level on the dipstick. So I'm a quart low?

    How much oil does it take to satisfactory fill up the motor? I have heard of people running an extra quart. I want to use just enough oil and be safe.

    What weight does GM reccomend? I am guessing they used 5-30 at the dealership.

    Also If I am a quart low would it be a good guess that they only filled it with 5 quarts to begin with?
    Get a rag, take the dipstick out and wipe it off the first time. Put it back in and check it again. The oil should be inbetween either the grooves and or the holes. (I forget off hand what our cars dipsticks have for markers.) The higher mark on the dipstick is Full. Our cars call for 5W30 oil. I don't recommend going higher then the full line / mark, people do but I don't..your not suppose to anyway. I don't know about this "losing oil" problem. My car is fine and acts like any other car would oil wise. I only put in about 5 - 5 1/2 quarts of oil when I change mine for it to be full. But if it is at the Add line like you say it should only take a quart or quart and a half to have it at the Full mark. If you are having doubts, go to someone who knows what they are doing.

  6. #6
    Member Mike's TA's Avatar
    Join Date
    Nov 2006
    Location
    Austin, TX
    Age
    35
    Posts
    880

    Black
    99 Trans Am(sold)

    If you're losing oil between changes, I would say you have a problem. I have never had to add extra between changes.

  7. #7
    Member 1998 T/A's Avatar
    Join Date
    Aug 2008
    Location
    Huron Ohio
    Posts
    759

    Black
    2000 WS6 Trans AM

    i have a small gasket leak on mine but it lost like 1/8th of a quart in 5k miles

  8. #8
    Member Benner's Avatar
    Join Date
    Nov 2007
    Location
    Delaware, OH
    Age
    30
    Posts
    946

    Pewter
    2001 GrandPrix GTP

    Your probally losing it at your rear main seal. LS1's are notorious for the rear main seals leaking.

  9. #9
    Member 1998 T/A's Avatar
    Join Date
    Aug 2008
    Location
    Huron Ohio
    Posts
    759

    Black
    2000 WS6 Trans AM

    alright i'll have to have that main seal checked out...I was told that when using synthetic you can just change the filter and put the old oil back in. makes sense synthetic never goes bad right? anyone ever hear of this?

  10. #10
    Member Benner's Avatar
    Join Date
    Nov 2007
    Location
    Delaware, OH
    Age
    30
    Posts
    946

    Pewter
    2001 GrandPrix GTP

    where are you heaing that from. whoever it is tell them they're complete morons. You'd just be allowing metal particles to keep going through your engine and the synthetic will break down over time just like conventional.

  11. #11
    Member Cronex's Avatar
    Join Date
    Jul 2007
    Location
    Philadelphia, PA
    Posts
    367

    Pewter
    2001 Trans Am #693

    Quote Originally Posted by Benner View Post
    where are you heaing that from. whoever it is tell them they're complete morons. You'd just be allowing metal particles to keep going through your engine and the synthetic will break down over time just like conventional.
    +1 on that. Ofcourse synthetic breaks down too.

  12. #12
    Member Mike's TA's Avatar
    Join Date
    Nov 2006
    Location
    Austin, TX
    Age
    35
    Posts
    880

    Black
    99 Trans Am(sold)

    I'm sure Sarge will be posting on here soon, now that someone has questioned oil usage.

    I like reading posts from Sarge, they are so informative.

  13. #13
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    did you make sure you plug is tight and that the filter is snug???

  14. #14
    Member
    Join Date
    Jul 2006
    Location
    Glen Carbon, IL
    Age
    39
    Posts
    397

    Silver
    2000 Camaro SS

    LS1's use a little oil. It is a known fact that the PCV system is the cause. As far as the goofball saying that the rear mains are notorious for leaking, you are wrong. LT1's are, but not LS1's.

  15. #15
    Member
    Join Date
    Jan 2007
    Location
    STL
    Posts
    126

    RED
    2001 CAMARO Z

    mine uses a littel

  16. #16
    old timer blue02Z's Avatar
    Join Date
    Sep 2005
    Location
    Texas
    Age
    31
    Posts
    3,805

    Navy Blue Metallic
    2002 Z28

    yeah, ls1's dont leak much, lt1 does. also i run a oil filter for a trailblazer, a pf61. it is the same filter ours calls for just deeper and holds a lil more oil. also you would be fine running a full 6 quarts. 5.5 is always just a lil low and .5 quart wont hurt these cars. another thing mentioned above, the oil doesnt wind up around the crank, the crank aerates the oil

  17. #17
    Member Benner's Avatar
    Join Date
    Nov 2007
    Location
    Delaware, OH
    Age
    30
    Posts
    946

    Pewter
    2001 GrandPrix GTP

    Quote Originally Posted by 02blkws6 View Post
    LS1's use a little oil. It is a known fact that the PCV system is the cause. As far as the goofball saying that the rear mains are notorious for leaking, you are wrong. LT1's are, but not LS1's.
    I'm going off what I've seen personally. Mine leaks, 3 of my friends leak, and we got vettes and fbodies in the dealership several times that had leaks.

  18. #18
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,520

    98 Formula
    06 duramax

    Quote Originally Posted by knightryda01 View Post
    Ok, I got my oil changed at the dealership ( I am not a mechanic)
    and I always run mobil 1 in my vehicles.... Never let me down yet.

    After reading the threads on here about the ls1 motors being known to lose oil and whatnot I decided to check mine. Came in at the add level on the dipstick. So I'm a quart low?

    How much oil does it take to satisfactory fill up the motor? I have heard of people running an extra quart. I want to use just enough oil and be safe.

    What weight does GM reccomend? I am guessing they used 5-30 at the dealership.

    Also If I am a quart low would it be a good guess that they only filled it with 5 quarts to begin with?
    the most important thing you can do is educate yourself. Ask these questions and as many as it takes. Typically people that run extra oil run a larger truck filter. I personally don't. GM recommends 5/30. LS1's do tend to use some oil. Just give it a check every now and then and keep it in the hatched area of the stick. Don't overfill it. Just make sure it's in the hatched area and you'll be fine. Sarge can tell you more about oil than I can, I can only tell you what I do. I don't run synthetic so I don't have experience there but I can tell you I'd never swap a filter and not the oil no matter what type of oil it is. True, the lifespan of synthetic is longer than conventional oil but it still needs changed and maintained just like any other oil. I've heard of people swapping filters only, I just personally wouldn't do it.

  19. #19
    O U 8 1 2 Spaz's Avatar
    Join Date
    Nov 1999
    Location
    over here...
    Age
    39
    Posts
    25,693

    []D [] []V[] []D
    1999 trans am

    my LS1's that i've had... all of them... was me pulling in to a gas station filling the oil and checking my gas... my LS6 don't eat any oil...

  20. #20
    I run 6 quarts with the longer truck filter. My car eats mobil 1 but I was running valve cover breathers. I switched to a catch can setup with castrol oil, so far so good...

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. speedometer question + top speed question
    By Krazy351w in forum General Help
    Replies: 7
    Last Post: 06-21-2007, 06:51 PM
  2. HPIII question (not the same old question)
    By slims00ls1z28 in forum Computer & Tuning
    Replies: 5
    Last Post: 06-01-2007, 05:55 PM
  3. 97 Bird Headlight question also engine noise question
    By Zapper2003 in forum General Help
    Replies: 2
    Last Post: 12-13-2006, 04:03 AM
  4. Speedometer question, RPO question
    By acrylicophobia in forum Firebird / WS6
    Replies: 12
    Last Post: 11-02-2006, 08:08 AM
  5. Sex Question spinoff- PORN QUESTION
    By egaian in forum Almost Anything Goes
    Replies: 77
    Last Post: 07-26-2006, 04:07 PM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •