Results 1 to 15 of 15

Oil change light then SES light came on. Are they related?

This is a discussion on Oil change light then SES light came on. Are they related? within the General Help forums, part of the LSx Technical Help Section category; My oil change light came on and about 3 hours later, my SES light came on and stays on even ...

  1. #1
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Cincinnati, OH ish
    Posts
    21,707

    My life is a
    Ben Stiller movie.

    Oil change light then SES light came on. Are they related?

    My oil change light came on and about 3 hours later, my SES light came on and stays on even if I shut the car off. Are they related or not?

  2. #2
    your parts guy!!! 1fastcamarosss11's Avatar
    Join Date
    Aug 2005
    Location
    cleveland ohio
    Posts
    11,376

    trans am 00 ws6
    1998 camaro ss vert

    Quote Originally Posted by third_shift|studios View Post
    My oil change light came on and about 3 hours later, my SES light came on and stays on even if I shut the car off. Are they related or not?
    possable you stop and check the oil? oil can be low. hope look. did the pressure drop? sounds just like what happened to mine. you here any noise?
    get some oil in there if not that have a new pump down now. wish i did. any chance you would be interested in my head and cam package cheap. i have to go win this auction i'll be on for a while.

  3. #3
    ƃuoɹʍ ʇsnɾ sı sıɥʇ Firebug's Avatar
    Join Date
    Jul 2006
    Location
    Newcastle Australia
    Posts
    1,390

    White
    2002 VY SS

    Oil pressure sender? Wire might only be loose.

    SES? Like 'Check Engine' light?

  4. #4
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Cincinnati, OH ish
    Posts
    21,707

    My life is a
    Ben Stiller movie.

    SES = Service engine sooon. I didn't get the big red 'CHECK GAUGES" light though.

    Intresting you mentioned Oil pressure, as mine looked to be kinda low. [it's @ 1/4 on the gauge in idle, normally it's at the middle]

    I just added a quart of oil before doing a 600 mile round trip, not to mention; i haven't driven the car this hard/far for over 3 months b/c i just got it out of the shop from the accident last week.

  5. #5
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Cincinnati, OH ish
    Posts
    21,707

    My life is a
    Ben Stiller movie.

    got this off the train...

    Quote Originally Posted by Sarge View Post
    Well...low oil pressure and all those lights going off tell me it aint no bad guage or sending unit...could be anything from a clogged pick up in the pan/bad oil pump...to a stuck valve on your oil filter....I'd flush that damn thing with some solvent ( no I dont recommend this often)....like any oil engine flush you can get at AutoZone etc. Get a good AC Delco filter and fresh oil....flush it...drain it good....get an extra quart and after it drains all out....pour that extra quart thru and just let it run right out the drain...this will flush most of the debris out....then put your drain plug back in and change filters ( refill your filter before you put it on)...and fill it up with fresh oil....let me know what happens.....

  6. #6
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,468

    98 Formula
    06 duramax

    Have the code read also and that'll tell you where you stand with the SES light.

  7. #7
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Cincinnati, OH ish
    Posts
    21,707

    My life is a
    Ben Stiller movie.

    just thought of something: last time i had my oil changed I got 5000 mile oil but used a 3000 mile filter...would it be possible that the filter is clogged to the point that it can't do it's job anymore? I've probbaly driven about 4000 miles on it.

  8. #8
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Cincinnati, OH ish
    Posts
    21,707

    My life is a
    Ben Stiller movie.

    Ok, i went to autozone and they said there was a 'link error' anybody know wtf that meant? They think my computer and the little port aren't talking to eachother.

  9. #9
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    Don't know what they meant by "link error" - maybe no power at the DLC port? Check your "CIG/ACCY" fuse.

  10. #10
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Cincinnati, OH ish
    Posts
    21,707

    My life is a
    Ben Stiller movie.

    Ok, i took it to Firestone and they read a P0420A code that indicated a faulty catyletic convertor.

    If i have the rear o2's deleted will this solve my problem?

  11. #11
    Senior Member
    Join Date
    Jul 2005
    Location
    Jacksonville, FL
    Posts
    2,725
    P0420 is the drivers side cat, you could have the rear 02's turned off (SES) but the problem will still be there. Sometimes it'll throw that inefficiency code cause it's coming apart/rattling inside. Stock cats are covered for 8yrs/80K. Lots of posts here on P0420.

  12. #12
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Cincinnati, OH ish
    Posts
    21,707

    My life is a
    Ben Stiller movie.

    well, i am 100k miles and about 6 years old...no free replacement. Bah. I was thinking maybe headers and Y?

  13. #13
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,468

    98 Formula
    06 duramax

    Quote Originally Posted by third_shift|studios View Post
    well, i am 100k miles and about 6 years old...no free replacement. Bah. I was thinking maybe headers and Y?
    Sounds like as good a reason as any. If you timed it right I could drive down and help you with the install but with the family deal I have going here free time is pretty hard to come by but I'd try.

  14. #14
    Detailing + Design third_shift|studios's Avatar
    Join Date
    Aug 2005
    Location
    Cincinnati, OH ish
    Posts
    21,707

    My life is a
    Ben Stiller movie.

    Quote Originally Posted by 0rion View Post
    Sounds like as good a reason as any. If you timed it right I could drive down and help you with the install but with the family deal I have going here free time is pretty hard to come by but I'd try.
    that was the coolest thing anyone's ever offered me...thanks!

  15. #15
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,468

    98 Formula
    06 duramax

    Well, let me know if you go that route and maybe we can schedule it to where I can come down and give you a hand with it. You're less than 2 hours from me Depending on what side of cinci you live on.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •