Results 1 to 3 of 3

Odd rattle after belt dressing?

This is a discussion on Odd rattle after belt dressing? within the General Help forums, part of the LSx Technical Help Section category; So today I was out re-introducing my car to the road after 4 months in storage but before I left, ...

  1. #1
    Junior Member
    Join Date
    Mar 2006
    Location
    Lansing, MI USA
    Age
    30
    Posts
    25

    Pewter
    '99 Z28

    Odd rattle after belt dressing?

    So today I was out re-introducing my car to the road after 4 months in storage but before I left, I went through everything and also sprayed belt dressing on. After doing so, I noticed a strange ratle that would happen periodically while just cruising down the road.

    Anyone know what the problem might be? Did I just get belt dressing overspray on something that shouldn't have been sprayed? Hopefully it's just an easy fix....

    Thanks

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    I'm not sure belt dressing would cause a "rattle" all is does is quiet belt squeal for temp. where is the rattle coming from? see if it does it with the car stationary, raise the hood and pull on the throttle cable from under the hood and see if you can hear it and pinpoint it.
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Junior Member
    Join Date
    Mar 2006
    Location
    Lansing, MI USA
    Age
    30
    Posts
    25

    Pewter
    '99 Z28

    Quote Originally Posted by sunsetorangess
    I'm not sure belt dressing would cause a "rattle" all is does is quiet belt squeal for temp. where is the rattle coming from? see if it does it with the car stationary, raise the hood and pull on the throttle cable from under the hood and see if you can hear it and pinpoint it.
    Well I just tried to locate it, I really can't tell for certain. If I had to give it my best guess, I would say its the A/C compressor, considering the way the noise cycles on and off. If it is that, I guess I'd just have to re-charge the refrigerant...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •