Results 1 to 7 of 7

o2 sensor problems

This is a discussion on o2 sensor problems within the General Help forums, part of the LSx Technical Help Section category; Okay I have had these codes for a cuple of months now, one is a p0137 {o2 sensor bank 1 ...

  1. #1
    Dcdrummer LS1buckey's Avatar
    Join Date
    May 2007
    Location
    Delaware, Ohio
    Age
    32
    Posts
    311

    pewter
    1999 Pontiac Trans Am

    o2 sensor problems

    Okay I have had these codes for a cuple of months now, one is a p0137 {o2 sensor bank 1 sensor 2 low volts} and the other code is the same code except bank 2 sensor 2. The car is a 1999 trans am Ls1 5.7L. I don't know what's causing this. Thier both new sensors and the plugs on them are good as far as I can tell. I also checked my grounds, Witch seem to be in good shape. What ever it is I'm pretty sure it's what's causing my car to choke from time to time...witch is not good. Plz anyone any help will be very appreiciated. thanx.

  2. #2
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Any mods?
    Possibly clogged cats.
    J
    2001 SS, Its not the car its the Driver that matters....

  3. #3
    Member TACE02's Avatar
    Join Date
    Aug 2005
    Location
    Texas
    Age
    40
    Posts
    568

    ASC #753
    2002 Collector's Edition

    also is that code the front 02 sensors or the rear sensors???

  4. #4
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    sensor 2 is the rear's
    J

  5. #5
    Senior Member SeVeReDiStOrTiOn's Avatar
    Join Date
    Aug 2005
    Location
    Roseville, CA
    Posts
    8,164

    05 Wrangler
    00 Z28 sold :-(

    Quote Originally Posted by sunsetorangess View Post
    Possibly clogged cats.
    +1...If you're still under 80,000 mi they're covered under warranty

  6. #6
    Dcdrummer LS1buckey's Avatar
    Join Date
    May 2007
    Location
    Delaware, Ohio
    Age
    32
    Posts
    311

    pewter
    1999 Pontiac Trans Am

    No I'm not under 80k anymore, was when I got it. Thanks for the info, I'm going to get the cats gutted this weekend and get an o2 simulator. We'll see how that goes.

  7. #7
    Dcdrummer LS1buckey's Avatar
    Join Date
    May 2007
    Location
    Delaware, Ohio
    Age
    32
    Posts
    311

    pewter
    1999 Pontiac Trans Am

    I have heard the cats could be the problem from a cuple of people.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •