Page 1 of 3 123 LastLast
Results 1 to 20 of 53

O2 sensor

This is a discussion on O2 sensor within the General Help forums, part of the LSx Technical Help Section category; i recently put some long tubes and y-pipes on my car and the y-pipe doesnt have a place for the ...

  1. #1
    Junior Member racingbeauty's Avatar
    Join Date
    Feb 2008
    Location
    Abilene, TX
    Posts
    14

    Black
    98' Camaro Z28

    O2 sensor

    i recently put some long tubes and y-pipes on my car and the y-pipe doesnt have a place for the sensors sooo my check engine light is on. i wanted to get some simulators but ive heard they dont make them anymore...? any ideas on how can i get some or make some myself?

  2. #2
    Alabama Member bamaz28's Avatar
    Join Date
    Jan 2008
    Location
    heart of dixie
    Posts
    1,215

    06 Jeep Grand Cherokee.
    02 superchipsZ28 M6(sold)

    Check Around On This Site Someone Can Point You In The Right Direction.

  3. #3
    Veteran 0rion's Avatar
    Join Date
    Aug 2005
    Location
    ohio
    Posts
    22,519

    98 Formula
    06 duramax

    you'd be much better off having the codes turned off. Sims are gonna be tough to find and expensive to buy more than likely.

  4. #4
    Junior Member SouthBLVD's Avatar
    Join Date
    Jan 2008
    Location
    NM
    Posts
    18

    Black
    2001 SS

    Quote Originally Posted by 0rion View Post
    you'd be much better off having the codes turned off. Sims are gonna be tough to find and expensive to buy more than likely.
    What he said. I got mine tuned out for $75 along with AIR. I just recently installed lt's and ory and !AIR and I don't have any SES or CES lights on!

  5. #5
    Junior Member racingbeauty's Avatar
    Join Date
    Feb 2008
    Location
    Abilene, TX
    Posts
    14

    Black
    98' Camaro Z28

    Quote Originally Posted by SouthBLVD View Post
    What he said. I got mine tuned out for $75 along with AIR. I just recently installed lt's and ory and !AIR and I don't have any SES or CES lights on!


    where did you have that done? i live in abilene tx and we dont have anyone that can do it.

  6. #6
    Life in the Fast lane sunsetorangess's Avatar
    Join Date
    Aug 2005
    Location
    Bragg NC
    Posts
    2,835

    Met. Sunset Orange
    01 SS

    Find a local tuner or shop i know there are several down yonder, if you post in the texas section you will probly get some hits. Also Check out some of our sponsers they can hook you up, you send your comp and they will take care of it and then send it back to you.
    J
    2001 SS, Its not the car its the Driver that matters....

  7. #7
    Junior Member racingbeauty's Avatar
    Join Date
    Feb 2008
    Location
    Abilene, TX
    Posts
    14

    Black
    98' Camaro Z28

    Quote Originally Posted by sunsetorangess View Post
    Find a local tuner or shop i know there are several down yonder, if you post in the texas section you will probly get some hits. Also Check out some of our sponsers they can hook you up, you send your comp and they will take care of it and then send it back to you.
    J


    thanks ill just have to travel a little bit if i take the car to somewhere

  8. #8
    Junior Member SouthBLVD's Avatar
    Join Date
    Jan 2008
    Location
    NM
    Posts
    18

    Black
    2001 SS

    Quote Originally Posted by racingbeauty View Post
    where did you have that done? i live in abilene tx and we dont have anyone that can do it.
    I got mine done in Lubbock, at Texas Speed and Performance.

  9. #9
    Junior Member racingbeauty's Avatar
    Join Date
    Feb 2008
    Location
    Abilene, TX
    Posts
    14

    Black
    98' Camaro Z28

    Quote Originally Posted by SouthBLVD View Post
    I got mine done in Lubbock, at Texas Speed and Performance.

    ok thanks ill try there

  10. #10
    Senior Member Bottesini's Avatar
    Join Date
    Sep 2007
    Location
    Denton, Texas soon Lafayette, Louisiana
    Posts
    2,955

    Blue
    2002 Z28 Camaro M6

    Quote Originally Posted by racingbeauty View Post
    where did you have that done? i live in abilene tx and we dont have anyone that can do it.
    I can only imagine your pain. I go into Abilene about once a month. Your two best bets are already mentioned and almost the same distance away. As far as I know the closest places are either in Lubbuck or DFW are. If you want some info on shops I can point you in a good direction. You might even consider getting a full tune which will cost more, but I picked up 20+ RWHP and driveability just from a tune when my car was just exhaust and lid. (357 RWHP total).

  11. #11
    Junior Member 98 Z/28's Avatar
    Join Date
    Jan 2008
    Location
    Maryland
    Age
    36
    Posts
    44

    Red
    98 Camaro Z/28

    I welded new 02 bungs onto my ORY and spaced them out enough where they don't throw any codes at all. You have to place them a little way back to get them to do this, call and ask a local performance shop to see if they can help you.

  12. #12
    Junior Member racingbeauty's Avatar
    Join Date
    Feb 2008
    Location
    Abilene, TX
    Posts
    14

    Black
    98' Camaro Z28

    thanks for the info im just tryin to find a cheap way to fix it. I think the rear O2 sensors are the reason my car is acting up even tho you wouldnt think so since they are just for emmisons. but something is making my car not wanna shift after 50 mph sometimes. the car was running perfect before i put on the long tubes and unplugged the O2's so thats why i think this is the problem.

  13. #13
    TunedbyFrost.com Tuner Frost's Avatar
    Join Date
    Jul 2007
    Location
    Richmond VA
    Posts
    2,415

    LS1.com Sponsor
    GM Tuner

    your rear O2s have absolutely no bearing on how your car acts, they just set a code and a light. Shoot me an email through my site or a PM here if you can't find anyone local to fix you up and can live without your PCM for a few days.

  14. #14
    Junior Member racingbeauty's Avatar
    Join Date
    Feb 2008
    Location
    Abilene, TX
    Posts
    14

    Black
    98' Camaro Z28

    well my dads a mechanic and him & i are the ones that do all the work to my car. we have a code reader and the only codes that come up are rear O2's. it doesnt act up everyday but when it does its usaully on the hiway and doesnt want to shift into a higher gear until i let off then get back on. obviously its an automatic too.

  15. #15
    TunedbyFrost.com Tuner Frost's Avatar
    Join Date
    Jul 2007
    Location
    Richmond VA
    Posts
    2,415

    LS1.com Sponsor
    GM Tuner

    If your dad is an auto mechanic he will agree that the back O2s are ONLY to monitor the cats. I wouldn't lie; have no reason to I am 100% sure that back O2s and trans issues are seperate.

    Having to let off under heavy throttle to have a car shift can be a bad sign of work-to-come in the tranny.

  16. #16
    Junior Member SouthBLVD's Avatar
    Join Date
    Jan 2008
    Location
    NM
    Posts
    18

    Black
    2001 SS

    have you checked your tranny fluid? if it doesn't want to shift, that might be a reason.

  17. #17
    Member SS-Power's Avatar
    Join Date
    Jan 2007
    Location
    PA
    Posts
    241

    White
    2000 SS Camaro

    O2 sims

    *non-sponsor link*
    Last edited by 0rion; 03-06-2008 at 09:07 PM.

  18. #18
    Junior Member racingbeauty's Avatar
    Join Date
    Feb 2008
    Location
    Abilene, TX
    Posts
    14

    Black
    98' Camaro Z28

    Quote Originally Posted by Frost View Post
    If your dad is an auto mechanic he will agree that the back O2s are ONLY to monitor the cats. I wouldn't lie; have no reason to I am 100% sure that back O2s and trans issues are seperate.

    Having to let off under heavy throttle to have a car shift can be a bad sign of work-to-come in the tranny.


    well we just checked the codes again today and now its showing the front O2's soooo we thought that cold have been the problem so we changed the front ones and so far so good. hopefully thats it

  19. #19
    Junior Member racingbeauty's Avatar
    Join Date
    Feb 2008
    Location
    Abilene, TX
    Posts
    14

    Black
    98' Camaro Z28

    Quote Originally Posted by SS-Power View Post
    O2 sims

    thanks alot for the website i really was looking for them. i called jegs and summit and they told me that no one made them anymore
    Last edited by 0rion; 03-06-2008 at 09:07 PM.

  20. #20
    Member Zedicous's Avatar
    Join Date
    Feb 2008
    Location
    Slidell, LA.
    Age
    48
    Posts
    397

    Mystic Magentic Red
    99 C5, 98 Z28.

    If you have the bung, i could show how to get rid of it for about $10...

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Help: 02 sensor bank 1 sensor 1-Is this drivers side or Passenger
    By cballweg in forum General Help
    Replies: 4
    Last Post: 01-15-2012, 11:44 AM
  2. Question: Reading trans temp stock sensor vs aftermarket sensor in pan
    By senicalj4579 in forum Computer & Tuning
    Replies: 1
    Last Post: 03-29-2011, 08:41 AM
  3. Knock Sensor/Oil Pressure Sensor Issue
    By Slow '99 in forum External Engine
    Replies: 1
    Last Post: 04-04-2007, 09:28 AM

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •